@Hugues-Mercusot
In order to use the curl you have to install the following:
ca-certificates and ca-bundle
The error happened because ca-certificates is used to allow SSL-based applications to check for the autchencity of SSL connections and ca-bundle is the file that contains root and intermediate certificates.