omega2 plus sdcard not working



  • dmesg info

    [ 1.139219] mmc0: new high speed SDHC card at address 0007
    [ 1.145137] mmcblk mmc0:0007: no of_node; not parsing pinctrl DT
    [ 1.145215] mmcblk: probe of mmc0:0007 failed with error -28



  • Please update the firmware that supports sdcard



  • Yep, same problem here. Tried two different brands but they both (ext4 formatted) didn't work:
    mmcblk: probe of mmc0:0001 failed with error -28
    or
    mmcblk: probe of mmc0:aaaa failed with error -28



  • Same here:
    [ 1.249160] mmc0: new high speed SDHC card at address 0001
    [ 1.255123] mmcblk: probe of mmc0:0001 failed with error -28



  • @Jari-Myllys same here! I don't get what's going on...



  • I am having the same issues and the following errors when running dmesg as well:
    [ 542.418508] mmc0: new high speed SDHC card at address 1234
    [ 542.424731] mmcblk: probe of mmc0:1234 failed with error -28
    I have emailed onion and am just waiting for a reply. Anyone found a solution/workaround yet?



  • same for me...



  • I am finding the same issue. The Linkit Smart7688 uses the same SoC and also has a microSD-card slot, so I thought to take a look at their device-tree table and compare it to the Omega's one, and sure enough, the Linkit Smart7688 sets mediatek,cd-high; in their DTS, whereas Omega2's DTS sets it as mediatek,cd-low; -- I am reasonably certain that this is the issue.

    EDIT: Ugh, stupid baddies haven't enabled configfs in kernel-configuration, so I can't load a device-tree overlay. Why the hell do they omit configfs-support on a device meant for embedded stuff? What the heck is the point? It doesn't increase the kernel's size by more than a few damn kilobytes! :angry:



  • @WereCatf In a reply to myself, I think I'll compile a custom version of LEDE with a fixed DTS later on and see if microSD-slot works then.



  • @WereCatf Cool, let me know if it works please



  • Well, it appears that the issue wasn't what I thought, so I still don't know what is causing this. The microSD-slot works fine with my own, custom build of LEDE with kernel 4.4.39.



  • I am seeing exactly (well, with a different address) the same error. Running Ω-ware: 0.1.6 b136.



  • I have the Onion Omega2 with the built-in SD card slot. I'm not using ext like the other posters, but FAT, and the card is not recognized at all by the Omega.

    I know the card is OK because I can put it in a USB card reader and connect that to the Omega's USB port and it works fine. But somehow the internal card reader is not recognized.

    Updated to the latest firmware with oupdate, and still no change.

    Thoughts?



  • @WayneL While I could be wrong, my understanding is that the Omega requires the card to be formatted as ext4



  • @Kit-Bishop No, it doesn't. The firmware-image does come with several different filesystem-kmods installed, including fat32 and exFAT.



  • @WayneL It's not anything you are doing wrong, their firmware-image is simply broken. Like I said above, the microSD-card slot works fine with my own custom build. You just have to wait until they release a new image.



  • @WereCatf All good, thanks for update :-)
    I was going on my experience with the original Omega with USB storage - that seemed to need ext4
    Still awaiting my Omega2+ to try things out - I have received notification it is on its way :-)



  • Baddies released a new firmware-upgrade with kernel version 4.4.39, but the microSD-slot still ain't working.



  • Hello I upgrade the firmware to Repo Firmware Version: 0.1.6 b137.
    SD-Card still not working.

    Error:

    [ 283.843931] mmc0: new high speed SDHC card at address aaaa
    [ 283.849876] mmcblk: probe of mmc0:aaaa failed with error -28



  • I has installed last firmware 0.1.7 but the sdcard not work.
    Why?
    Onion support write me not back of my mail..



  • The problem still exists.


Log in to reply