Omega 2 and Arduino dock.



  • @Gamaliel-Valencia hi, it's been awhile since this was discussed so not 100% but i think you may have flashed wrong software. there was one
    software for original arduino dock and another for arduino dock2. they are not interchangeable. but it might be something else entirely. search on flash correct firmware for arduino dock 2 on google or here.



  • @Gamaliel-Valencia Probably you mixed up the two Arduino Dock tutorials or used the old one.
    If you have an Arduino Dock 2 with Omega2(+) you should follow the official Onion Omega2 Documentation Flashing the Arduino Dock - step by step very carefully.
    Firstly you should flash / upload a few simple sketches from File -> Examples -> Built-in examples of Arduino IDE.
    Afterwards you could try Manually Flashing on the Command line some precompiled hex files.

    Actually - on the Arduino Dock 2 - you can program the ATmega chip (the Arduino) with a bit-banged ISP / ICSP / Serial Downloading programmer.
    Any built in / on chip ATmega bootloader is a completely different story.

    There isn't I2C communication (eg. i2cget, i2cset) between Omega and Arduino by default - you should flash some kind of I2C slave program to the ATmega chip.



  • @György-Farkas said in Omega 2 and Arduino dock.:

    Probably you mixed up the two Arduino Dock tutorials or used the old one.
    If you have an Arduino Dock 2 with Omega2(+) you should follow the official Onion Omega2 Documentation Flashing the Arduino Dock - step by step very carefully.
    Firstly you should flash / upload a few simple sketches from File -> Examples -> Built-in examples of Arduino IDE.
    Afterwards you could try Manually Flashing on the Command line some precompiled hex files.
    Actually - on the Arduino Dock 2 - you can program the ATmega chip (the Arduino) with a bit-banged ISP / ICSP / Serial Downloading programmer.
    Any built in / on chip ATmega bootloader is a completely different story.
    There isn't I2C communication (eg. i2cget, i2cset) between Omega and Arduino by default - you should flash some kind of I2C slave program to the ATmega chip.

    I really appreciate your replies @György-Farkas and @Douglas-Kryder, let me try to explain better my situation.

    First I have an Arduino Dock 2 with Omega2, With this I tried to flash following the manual for Arduino dock 2 the Blinking led Program, the first flash its OK, but later when I tried to flash another program, in the process, I noticed that the blinking led program was deleted. But in the process of trying to flash the new program, this stops abruptly and it always marks the following error message:

    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
    Double check connections and try again, or use -F to override
    this check.

    After to receive this message on multiple tryings, I decided to make a default reset on Omega2 and reinstalling the software for my Arduino Dock2 but I'm still receiving the same message. The steps that I realized after default reset are:

    opkg update
    opkg install arduino-dock-2

    I hope that this can complement you a little more in what happened to me and you can support me with other solutions.
    I greatly appreciate your support.



  • @Gamaliel-Valencia well, if the thing is still within any type of warranty framework then i would put in a ticket for return, mention the thread so if they have any ideas over what has already been discussed they can join in. but it seems to me you have tried all that you could. other boards have just not responded as well so some of them just may be broken. wish i could offer something else but out of ideas.



  • @Douglas-Kryder said in Omega 2 and Arduino dock.:

    @Gamaliel-Valencia well, if the thing is still within any type of warranty framework then i would put in a ticket for return, mention the thread so if they have any ideas over what has already been discussed they can join in. but it seems to me you have tried all that you could. other boards have just not responded as well so some of them just may be broken. wish i could offer something else but out of ideas.

    @Douglas-Kryder I really appreciate your support and I think you are right, I will send my ticket and wait.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.