Omega2+ fails to connect to wifi



  • Same issue for me as well.

    Omega2+
    Exp dock

    Device Firmware Version: 0.1.7 b140

    root@Omega-C5A3:~# wifisetup
    Onion Omega Wifi Setup
    
    Select from the following:
    1) Scan for Wifi networks
    2) Type network info
    q) Exit
    
    Selection: 1
    Scanning for wifi networks...
    
    Select Wifi network:
    1) foo
    2) bar
    3) baz
    
    Selection: 3
    Network: baz
    Authentication type: WPA2PSK
    Enter password: redacted
    
    > Restarting wifimanager for changes to take effect
    root@Omega-C5A3:~# 
    
    root@Omega-C5A3:~# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.ifname='eth0.1'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wan=interface
    network.wan.ifname='eth0'
    network.wan.proto='dhcp'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.proto='dhcp'
    
    root@Omega-C5A3:~# uci show wireless
    wireless.ra0=wifi-device
    wireless.ra0.type='ralink'
    wireless.ra0.mode='9'
    wireless.ra0.channel='auto'
    wireless.ra0.txpower='100'
    wireless.ra0.ht='20'
    wireless.ra0.country='US'
    wireless.ra0.disabled='0'
    wireless.@wifi-iface[0]=wifi-iface
    wireless.@wifi-iface[0].device='ra0'
    wireless.@wifi-iface[0].network='wlan'
    wireless.@wifi-iface[0].mode='ap'
    wireless.@wifi-iface[0].encryption='psk2'
    wireless.@wifi-iface[0].key='12345678'
    wireless.@wifi-iface[0].ApCliAuthMode='WPA2PSK'
    wireless.@wifi-iface[0].ApCliEncrypType='AES'
    wireless.@wifi-iface[0].ssid='Omega-C5A3'
    wireless.@wifi-iface[0].ApCliSsid='baz'
    wireless.@wifi-iface[0].ApCliPassWord='redacted'
    wireless.@wifi-iface[0].ApCliEnable='0'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].ssid='baz'
    wireless.@wifi-config[0].encryption='WPA2PSK'
    wireless.@wifi-config[0].key='redacted'
    


  • @Luciano-S. Manual sysupgrade does not work:

    root@Omega-6D3B:/# sysupgrade -v --force /omega2p-v0.1.7-b140.bin 
    Saving config files...
    etc/config/dhcp
    etc/config/dropbear
    etc/config/firewall
    etc/config/mountd
    etc/config/network
    etc/config/onion
    etc/config/rpcd
    etc/config/system
    etc/config/ubootenv
    etc/config/uhttpd
    etc/config/wireless
    etc/dropbear/dropbear_rsa_host_key
    etc/fw_env.config
    etc/group
    etc/hosts
    etc/inittab
    etc/opkg/keys/1afebb2008639538
    etc/opkg/keys/2ea9a9bc60cbc099
    etc/opkg/keys/60366ca0eb621637
    etc/opkg/keys/6405feca1ff7d881
    etc/opkg/keys/72a57f2191b211e0
    etc/opkg/keys/7afde20b15076f21
    etc/opkg/keys/9ef4694208102c43
    etc/opkg/keys/b5043e70f9a75cde
    etc/opkg/keys/dace9d4df16896bf
    etc/opkg/keys/dd6de0d06bbd3d85
    etc/passwd
    etc/profile
    etc/rc.local
    etc/shadow
    etc/shells
    etc/sysctl.conf
    etc/sysctl.d/local.conf
    root/.config/htop/htoprc
    killall: watchdog: no process killed
    Sending TERM to remaining processes ... onion-helper udhcpc dnsmasq mountd ntpd ubusd askfirst logd rpcd netifd odhcpd uhttpd device-client avahi-daemon 
    Sending KILL to remaining processes ... askfirst 
    Switching to ramdisk...
    Performing system upgrade...
    Could not get image magic
    Image check failed.
    Upgrade completed
    Rebooting system...
    umount: can't unmount /dev/pts: Resource busy
    umount: can't unmount /dev: Resource busy
    

    And the Omega boots into the old image:

    @arte ➜  Zemeplytis rvm:(system)  ssh root@Omega-6D3B.local
    root@omega-6d3b.local's password: 
    
    
    BusyBox v1.25.1 () built-in shell (ash)
    
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
     -----------------------------------------------------
       Ω-ware: 0.1.7 b139
     -----------------------------------------------------
    

  • administrators

    @Zogg-Baubas yikes! why the --force flag??



  • @Lazar-Demin said in Omega2+ fails to connect to wifi:

    @Zogg-Baubas yikes! why the --force flag??

    Hey, Administrators, when will you resolve the wifi connectivity issues that we're talking about on this thread?



  • @Lazar-Demin said in Omega2+ fails to connect to wifi:

    @Zogg-Baubas yikes! why the --force flag??

    Because without it I'v got the same result. Figured, as this particular Omega was useless in this state, it couldn't get worse even if bricked. In the end '--force' didnt achieve anything that unforced version didnt.



  • @Zogg-Baubas It seems that we have to find the solution by ourselves, the Admins do not help at all.
    Have you tried the new version of firmware?



  • @Zogg-Baubas I already instructed you in http://community.onion.io/topic/1178/wifi-connection-problem-with-omega2/21 how to flash the image correctly.



  • @Kostas-David - I tried omega2p-v0.1.8-b145.bin and still no luck getting the wi-fi working yet. I'm using a Mikrotik router and I've never had any issues with other devices.



  • I had also connection problems because i had special characters in my wlan password! After the upgrade of the firmware it also works with special letters!



  • @xmatt I also confirm that upgrading the firmware didn't help.
    @Gerald-Schalek my wlan password does not container special characters but the wifi does not connect



  • Status update: By installing firmware omega2p-v0.1.8-b145.bin I managed to get connected to my Android phone's mobile hotspot with no security.
    Problems:

    1. Omega cannot get connected to Access points with security enabled (WPA, WPA2 etc)
    2. No access to cloud, it is shown as "Offline"
    3. LED is constantly blinking, even after restart
    4. No internet access from the SSH terminal
    5. Sometimes there is internet access from Console (it checks for new firmware successfully.

    Still unusable...



  • Hello, I would like to share my progress. I finally managed to connect Omega2 to my router. The problem was the encryption type. My router uses "TKIP" but Omega2 has "AES".

    So, I entered the following:

    uci set wireless.@wifi-iface[0].ApCliEncrypType=TKIP
    uci commit wireless
    etc/init.d/network restart

    Note: The firmware I am using is 0.1.7 b139 because for some strange reason the firmware update downloads this version instead of 0.1.8. But it works



  • Hi,

    I had the same problem but I solved it. Here's how i did:

    1. connect to your Omega2
    2. list APs with this command: aps
    root@Omega-XXXX:~# aps
    WRTnode AP scaner.
    Begin scaning APs, pls wait...
    Finished.
    APs available are...
    ra0       get_site_survey:
    Ch  SSID   BSSID               Security         Signal(%) W-Mode  ExtCH  NT
    ...
    10  MyAP   02:6f:d7:3e:8e:60   WPAPSK/TKIPAES   50        11b/g/n NONE   In
    ...
    

    This command give you more information about your AP. The most important is Security.

    1. Take this conversion table to modify your /etc/config/wireless config file:
    aps:Security            vw:ApCliAuthMode/ApCliEncrypType
    =========================================================
    WPA1PSKWPA2PSK/TKIPAES	WPA2PSK/AES
    WPA2PSK/AES		WPA2PSK/AES
    WPA2PSK/TKIP		WPA2PSK/TKIP
    WPAPSK/TKIPAES		WPAPSK/TKIP
    WPAPSK/AES		WPAPSK/AES
    WPAPSK/TKIP		WPAPSK/TKIP
    WEP			WEP/WEP
    

    Before edit it, my /etc/config/wireless contained:

    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ApCliEncrypType 'TKIP'
    	option ApCliSsid 'MyAP'
    	option ApCliPassWord 'xxxxxxxx'
    	option ssid 'Omega-xxxx'
    	option ApCliEnable '1'
    
    config wifi-config
    	option ssid 'MyAP'
    	option encryption 'WPA1PSK'
    	option key 'xxxxxxxx'
    

    With convertion table, i edited it like this:

    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ApCliEncrypType 'TKIP'
    	option ApCliSsid 'MyAP'
    	option ApCliPassWord 'xxxxxxxx'
    	option ssid 'Omega-xxxx'
    	option ApCliEnable '1'
    
    config wifi-config
    	option ssid 'MyAP'
    	option encryption 'WPAPSK'
    	option key 'xxxxxxxx'
    

    (I modified option encryption 'WPA1PSK' -> option encryption 'WPAPSK' in config wifi-config section)

    1. To finish, restart network:
    root@Omega-xxxx:/etc/config# nr
    
    1. After some time, you can reconnect to your Omega and verify if you have an IP:
    root@Omega-xxxx:~# ia
    apcli0    Link encap:Ethernet  HWaddr 42:A3:6B:00:BE:3B
              inet addr:192.168.1.16  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::40a3:6bff:fe00:be3b/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:265 errors:0 dropped:0 overruns:0 frame:0
              TX packets:281 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:74379 (72.6 KiB)  TX bytes:25424 (24.8 KiB)
    
    1. You can continue with Onion Setup Wizard web interface (http://omega-xxxx.local/) if you want

    ps: after network restart, i checked my /etc/config/wireless, and i saw that a new line was added in config wifi-iface section: option ApCliAuthMode 'WPAPSK':

    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ApCliEncrypType 'TKIP'
    	option ApCliSsid 'MyAP'
    	option ApCliPassWord 'xxxxxxxx'
    	option ssid 'Omega-xxxx'
    	option ApCliEnable '1'
    	option ApCliAuthMode 'WPAPSK'
    
    config wifi-config
    	option ssid 'MyAP'
    	option encryption 'WPAPSK'
    	option key 'xxxxxxxx'
    

    Hope this help you.



  • @Mikaël-PIRIO After trying everything else, only this worked. Thanks for putting in time for this answer.


  • administrators

    @Mikaël-PIRIO Thanks for finding the issue and posting the guide!
    We'll try to fix this in the coming weeks. For now, I've added it to the known issues listing



  • @Mikaël-PIRIO While this worked for me as well, it required me to modify the settings of my wireless network; namely 1) making it 802.11g/n (previously hard-set to 802.11n only), 2) downgrade from AES to using TKIP. WPA or WPA2 doesn't seem to matter. Having to decrease the encryption strength of the network and switching MAC/PHY standard doesn't seem like a good long-term solution.

    Some other puzzling observations: my previous router settings (802.11n, WPA2 with AES) works fine with the Omega 1; also, the Omega 2 works fine when connecting to my mobile phone configured as a hotspot with AES. Seems like an odd corner-case with the Omega 2 and certain APs when using AES. I suspect the 4-way handshake never gets completed since my router never receives the DHCP requests, but verifying/debugging this would require doing some wireless packet captures.



  • I managed to make Omega2 connect my wireless network provided by Mikrotik RB951B and will share my knowledge with you guys. If you find anything wrong, please, correct me.

    Here we go:

    Mikrotik configuration:
    • Wireless
      • Frequency: auto
      • Band: 2GHz-B/G/N
      • Country: no_country_set
    • Wireless/Security Profiles
      • Authentication types: WPA2 PSK
      • Unicast Ciphers: aes ccm
    Build notes:
    • I use official LEDE sources to build the image
      • Target System: MediaTek Ralink MIPS
      • Subtarget: MT7688 based boards
      • Target Profile: Onion Omega2
    • I do not use Omega2 feeds (FTBFS during typing this post)
    Configuration:
    • /etc/config/wireless:
    config wifi-device 'radio0'
            option type 'mac80211'
            option channel 'auto'
            option path 'platform/10300000.wmac'
            option disabled '0'
    
    config wifi-iface 'default_radio0'
            option device 'radio0'
            option network 'wwan'
            option mode 'sta'
            option encryption 'psk2'
            option key 'MyWPA2Key'
            option ssid 'MyWirelessNetworkSSID'
    
    • /etc/config/network:
    config interface 'loopback'                                                     
            option ifname 'lo'                                                         
            option proto 'static'                                                      
            option ipaddr '127.0.0.1'                                                  
            option netmask '255.0.0.0'                                                 
                                                                                       
    config globals 'globals'                                                           
            option ula_prefix 'fd1d:48c4:7633::/48'                                    
                                                                                                                           
    config interface 'default_radio0'                                                  
            option type 'bridge'                                                       
            option ifname 'eth0.1'                                                     
            option proto 'static'                                                      
            option ipaddr '192.168.3.1'                                                
            option netmask '255.255.255.0'                                             
            option ip6assign '60'                                                      
                                                                                       
    config interface 'wan'                                                             
            option ifname 'eth0'                                                       
            option proto 'dhcp'                                                        
                                                                                       
    config interface 'wwan'                                                            
            option proto 'dhcp' 
    

    Having changed those 2 configuration files, I restarted the wireless subsystem by wifi and I could read this:

    [ 1329.657946] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1331.436860] wlan0: authenticate with aa:bb:cc:dd:ee:ff
    [ 1331.459985] wlan0: send auth to aa:bb:cc:dd:ee:ff (try 1/3)
    [ 1331.468056] wlan0: authenticated
    [ 1331.475129] wlan0: associate with aa:bb:cc:dd:ee:ff (try 1/3)
    [ 1331.486320] wlan0: RX AssocResp from aa:bb:cc:dd:ee:ff (capab=0x401 status=0 aid=5)
    [ 1331.494544] wlan0: associated
    [ 1331.497749] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    

    Then I verified that I obtained a network address from DHCP service running on Mikrotik:

    # ip a s dev wlan0
    8: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
        link/ether aa:bb:cc:dd:ee:ff brd ff:ff:ff:ff:ff:ff
        inet 192.168.88.224/24 brd 192.168.88.255 scope global wlan0
           valid_lft forever preferred_lft forever
        inet6 fe80::42a3:6bff:fec0:85e1/64 scope link 
           valid_lft forever preferred_lft forever
    

    The crucial part was to configure the wireless subsystem to use Client/Station (option mode 'sta') mode. The effect of this setting is following: OpenWRT/LEDE spawns a wpa_supplicant daemon for the configured interface which takes care of authentication and assiciation... See:

    $ cat /var/run/wpa_supplicant-wlan0.conf
    network={
            scan_ssid=1
            ssid="MyWirelessNetworkSSID"
            key_mgmt=WPA-PSK
            psk="MyWPA2Key!"
            proto=RSN
    }
    
    Conclusion

    I can now reach my device! :)



  • Hi Guys,

    let me add my 2 cents..

    The way I have solved my wifi issue:

    1. Check if you have issues already solved by the community, like
    • there isn't any collision going on,
    • there are no problems with the channels,
    • or the encryption,
    • or your router!
    1. wifisetup, and follow the guide
    2. vi /etc/config/wireless
    3. Focus on the ApCli settings in the wifi-iface block! It was not updated in my case and was also disabled (option ApCliEnable '0'). Add or update all the relevant ApCli options manually to your file! Like this:
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'US'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ssid 'Omega-XXXX'
            option ApCliSsid 'MyID'
            option ApCliPassWord 'XXXXX'
            option ApCliEncrypType 'AES'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEnable '1'
    
    config wifi-config
            option ssid 'MyID'
            option encryption 'WPA2PSK'
            option key 'XXXXXX'
    
    1. wifi
    2. Enjoy your network! ;)

    Hope this works for you!



  • How do I exit out of the config setup? So after I do the changes, how do I exit out of there to enter a new command? Thanks!



  • @Michelle-Esponda , i propose to install nano and use this instead.

    For now you can check out the manual of vi:
    https://www.cs.colostate.edu/helpdocs/vi.html



Looks like your connection to Community was lost, please wait while we try to reconnect.