Omega2+ fails to connect to wifi



  • Status update: By installing firmware omega2p-v0.1.8-b145.bin I managed to get connected to my Android phone's mobile hotspot with no security.
    Problems:

    1. Omega cannot get connected to Access points with security enabled (WPA, WPA2 etc)
    2. No access to cloud, it is shown as "Offline"
    3. LED is constantly blinking, even after restart
    4. No internet access from the SSH terminal
    5. Sometimes there is internet access from Console (it checks for new firmware successfully.

    Still unusable...



  • Hello, I would like to share my progress. I finally managed to connect Omega2 to my router. The problem was the encryption type. My router uses "TKIP" but Omega2 has "AES".

    So, I entered the following:

    uci set wireless.@wifi-iface[0].ApCliEncrypType=TKIP
    uci commit wireless
    etc/init.d/network restart

    Note: The firmware I am using is 0.1.7 b139 because for some strange reason the firmware update downloads this version instead of 0.1.8. But it works



  • Hi,

    I had the same problem but I solved it. Here's how i did:

    1. connect to your Omega2
    2. list APs with this command: aps
    root@Omega-XXXX:~# aps
    WRTnode AP scaner.
    Begin scaning APs, pls wait...
    Finished.
    APs available are...
    ra0       get_site_survey:
    Ch  SSID   BSSID               Security         Signal(%) W-Mode  ExtCH  NT
    ...
    10  MyAP   02:6f:d7:3e:8e:60   WPAPSK/TKIPAES   50        11b/g/n NONE   In
    ...
    

    This command give you more information about your AP. The most important is Security.

    1. Take this conversion table to modify your /etc/config/wireless config file:
    aps:Security            vw:ApCliAuthMode/ApCliEncrypType
    =========================================================
    WPA1PSKWPA2PSK/TKIPAES	WPA2PSK/AES
    WPA2PSK/AES		WPA2PSK/AES
    WPA2PSK/TKIP		WPA2PSK/TKIP
    WPAPSK/TKIPAES		WPAPSK/TKIP
    WPAPSK/AES		WPAPSK/AES
    WPAPSK/TKIP		WPAPSK/TKIP
    WEP			WEP/WEP
    

    Before edit it, my /etc/config/wireless contained:

    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ApCliEncrypType 'TKIP'
    	option ApCliSsid 'MyAP'
    	option ApCliPassWord 'xxxxxxxx'
    	option ssid 'Omega-xxxx'
    	option ApCliEnable '1'
    
    config wifi-config
    	option ssid 'MyAP'
    	option encryption 'WPA1PSK'
    	option key 'xxxxxxxx'
    

    With convertion table, i edited it like this:

    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ApCliEncrypType 'TKIP'
    	option ApCliSsid 'MyAP'
    	option ApCliPassWord 'xxxxxxxx'
    	option ssid 'Omega-xxxx'
    	option ApCliEnable '1'
    
    config wifi-config
    	option ssid 'MyAP'
    	option encryption 'WPAPSK'
    	option key 'xxxxxxxx'
    

    (I modified option encryption 'WPA1PSK' -> option encryption 'WPAPSK' in config wifi-config section)

    1. To finish, restart network:
    root@Omega-xxxx:/etc/config# nr
    
    1. After some time, you can reconnect to your Omega and verify if you have an IP:
    root@Omega-xxxx:~# ia
    apcli0    Link encap:Ethernet  HWaddr 42:A3:6B:00:BE:3B
              inet addr:192.168.1.16  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::40a3:6bff:fe00:be3b/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:265 errors:0 dropped:0 overruns:0 frame:0
              TX packets:281 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:74379 (72.6 KiB)  TX bytes:25424 (24.8 KiB)
    
    1. You can continue with Onion Setup Wizard web interface (http://omega-xxxx.local/) if you want

    ps: after network restart, i checked my /etc/config/wireless, and i saw that a new line was added in config wifi-iface section: option ApCliAuthMode 'WPAPSK':

    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ApCliEncrypType 'TKIP'
    	option ApCliSsid 'MyAP'
    	option ApCliPassWord 'xxxxxxxx'
    	option ssid 'Omega-xxxx'
    	option ApCliEnable '1'
    	option ApCliAuthMode 'WPAPSK'
    
    config wifi-config
    	option ssid 'MyAP'
    	option encryption 'WPAPSK'
    	option key 'xxxxxxxx'
    

    Hope this help you.



  • @Mikaël-PIRIO After trying everything else, only this worked. Thanks for putting in time for this answer.


  • administrators

    @Mikaël-PIRIO Thanks for finding the issue and posting the guide!
    We'll try to fix this in the coming weeks. For now, I've added it to the known issues listing



  • @Mikaël-PIRIO While this worked for me as well, it required me to modify the settings of my wireless network; namely 1) making it 802.11g/n (previously hard-set to 802.11n only), 2) downgrade from AES to using TKIP. WPA or WPA2 doesn't seem to matter. Having to decrease the encryption strength of the network and switching MAC/PHY standard doesn't seem like a good long-term solution.

    Some other puzzling observations: my previous router settings (802.11n, WPA2 with AES) works fine with the Omega 1; also, the Omega 2 works fine when connecting to my mobile phone configured as a hotspot with AES. Seems like an odd corner-case with the Omega 2 and certain APs when using AES. I suspect the 4-way handshake never gets completed since my router never receives the DHCP requests, but verifying/debugging this would require doing some wireless packet captures.



  • I managed to make Omega2 connect my wireless network provided by Mikrotik RB951B and will share my knowledge with you guys. If you find anything wrong, please, correct me.

    Here we go:

    Mikrotik configuration:
    • Wireless
      • Frequency: auto
      • Band: 2GHz-B/G/N
      • Country: no_country_set
    • Wireless/Security Profiles
      • Authentication types: WPA2 PSK
      • Unicast Ciphers: aes ccm
    Build notes:
    • I use official LEDE sources to build the image
      • Target System: MediaTek Ralink MIPS
      • Subtarget: MT7688 based boards
      • Target Profile: Onion Omega2
    • I do not use Omega2 feeds (FTBFS during typing this post)
    Configuration:
    • /etc/config/wireless:
    config wifi-device 'radio0'
            option type 'mac80211'
            option channel 'auto'
            option path 'platform/10300000.wmac'
            option disabled '0'
    
    config wifi-iface 'default_radio0'
            option device 'radio0'
            option network 'wwan'
            option mode 'sta'
            option encryption 'psk2'
            option key 'MyWPA2Key'
            option ssid 'MyWirelessNetworkSSID'
    
    • /etc/config/network:
    config interface 'loopback'                                                     
            option ifname 'lo'                                                         
            option proto 'static'                                                      
            option ipaddr '127.0.0.1'                                                  
            option netmask '255.0.0.0'                                                 
                                                                                       
    config globals 'globals'                                                           
            option ula_prefix 'fd1d:48c4:7633::/48'                                    
                                                                                                                           
    config interface 'default_radio0'                                                  
            option type 'bridge'                                                       
            option ifname 'eth0.1'                                                     
            option proto 'static'                                                      
            option ipaddr '192.168.3.1'                                                
            option netmask '255.255.255.0'                                             
            option ip6assign '60'                                                      
                                                                                       
    config interface 'wan'                                                             
            option ifname 'eth0'                                                       
            option proto 'dhcp'                                                        
                                                                                       
    config interface 'wwan'                                                            
            option proto 'dhcp' 
    

    Having changed those 2 configuration files, I restarted the wireless subsystem by wifi and I could read this:

    [ 1329.657946] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1331.436860] wlan0: authenticate with aa:bb:cc:dd:ee:ff
    [ 1331.459985] wlan0: send auth to aa:bb:cc:dd:ee:ff (try 1/3)
    [ 1331.468056] wlan0: authenticated
    [ 1331.475129] wlan0: associate with aa:bb:cc:dd:ee:ff (try 1/3)
    [ 1331.486320] wlan0: RX AssocResp from aa:bb:cc:dd:ee:ff (capab=0x401 status=0 aid=5)
    [ 1331.494544] wlan0: associated
    [ 1331.497749] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    

    Then I verified that I obtained a network address from DHCP service running on Mikrotik:

    # ip a s dev wlan0
    8: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
        link/ether aa:bb:cc:dd:ee:ff brd ff:ff:ff:ff:ff:ff
        inet 192.168.88.224/24 brd 192.168.88.255 scope global wlan0
           valid_lft forever preferred_lft forever
        inet6 fe80::42a3:6bff:fec0:85e1/64 scope link 
           valid_lft forever preferred_lft forever
    

    The crucial part was to configure the wireless subsystem to use Client/Station (option mode 'sta') mode. The effect of this setting is following: OpenWRT/LEDE spawns a wpa_supplicant daemon for the configured interface which takes care of authentication and assiciation... See:

    $ cat /var/run/wpa_supplicant-wlan0.conf
    network={
            scan_ssid=1
            ssid="MyWirelessNetworkSSID"
            key_mgmt=WPA-PSK
            psk="MyWPA2Key!"
            proto=RSN
    }
    
    Conclusion

    I can now reach my device! :)



  • Hi Guys,

    let me add my 2 cents..

    The way I have solved my wifi issue:

    1. Check if you have issues already solved by the community, like
    • there isn't any collision going on,
    • there are no problems with the channels,
    • or the encryption,
    • or your router!
    1. wifisetup, and follow the guide
    2. vi /etc/config/wireless
    3. Focus on the ApCli settings in the wifi-iface block! It was not updated in my case and was also disabled (option ApCliEnable '0'). Add or update all the relevant ApCli options manually to your file! Like this:
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'US'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ssid 'Omega-XXXX'
            option ApCliSsid 'MyID'
            option ApCliPassWord 'XXXXX'
            option ApCliEncrypType 'AES'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEnable '1'
    
    config wifi-config
            option ssid 'MyID'
            option encryption 'WPA2PSK'
            option key 'XXXXXX'
    
    1. wifi
    2. Enjoy your network! ;)

    Hope this works for you!



  • How do I exit out of the config setup? So after I do the changes, how do I exit out of there to enter a new command? Thanks!



  • @Michelle-Esponda , i propose to install nano and use this instead.

    For now you can check out the manual of vi:
    https://www.cs.colostate.edu/helpdocs/vi.html



  • @Lazar-Demin As with T Lin, I was also only able to get this to work by downgrading my router's encryption to TKIP (and switching it to 802.11g/n mixed mode). Is it a known issue that the Omega 2+ doesn't work with AES?



  • @Narciso-Jaramillo

    as I meitoned in another thread: I can tell for sure that AES/TKIP is NOT an issue, because I was able to connect my Omega2 to my mobile (in hotspot mode) with WPA2PSK and AES. "APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!"
    All default configuration, by the way, no config files changes, etc. - problem is somewhere else (may be more than one place).
    Omega2 does NOT connect to 2 of my WiFi Routers (Mikrotik and ASUS) with the same WPA2PSK/AES



  • @Michael-Smith Same here. I've tried all the suggestions. If anybody figures it out, please let me know.



  • Yep, I also have this issue, i've made a post and gotten no help after going through every thread on this forum trying to find a solution for this issue. This is frustrating and needs to be resolved. Admins need to step up. maybe skip 2-bullet tuesday this week and address this issue.



  • Same problem here. I was unable to connect to an Mikrotik 2011UAS or a Cisco EPR2320R2. I tried everything on this post, change wifi mode, channels, AES, TKIP, no-security, edit the /etc/config/wireless and other files in console, update the module to last version (0.1.10 b160), tried Omega2 and Omega2+, exp-board, change country settings, address collisions, etc.. It works fine with my phone hotspot, but nothing with the routers, even a single DHCP request. What's wrong with this modules?



  • This post is deleted!


  • Admins please fix this issue! Is it even being investigated at all? Please let us know. I'm going to throw this thing in the trash and buy a Rasberry Pi lol



  • This is really frustrating, I have a Ruckus Router, I tried all the configuration combinations I could think of, it didn't work even with an Open Network. I used two different Ruckus Reuters R710 and R600, same result. I tried ESP8266,raspberry pi, phones , laptops..the Router works very well on the 2.4 , Not sure what to do now, should I just give up and get back to it in year or two..hoping the WiFi issues got fixed with Omega10.



  • I have exactly same issue, when connecting to my Android hotspot without any security its ok, when I try to connect it to Cisco router with WPA2PSK/AES its not working. Also LED keeps flashing and my Omega is overheating like hell (wifi-manager is using 100% of CPU). No need to post content of my configs, its the same as guys above.

    I have some ESPs, notebooks, phone etc. Everything connect just fine, but not my Omega. Could you please at least communicate where is the problem, or what are you doing to fix it? This thread is more than 3 months old and there is still problem with one of the main functions of Omega (I bought it especially for on-board WiFi support). Last admin message is 3 months old, I mean come on, guys. You screwed communication on IndieGoGo (and I got letter from you how you are making extra efford to communicate with us, the community) and now this :)



  • @Jakub-Ludwig I solved it by changing router mode from 802.11n only to 802.11b/g/n mixed.
    Also you can play with wifi region especially if your channel on the router above 11.
    Maybe changing channel width between 20mhz and 40mhz can also help.



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.