Omega2+ fails to connect to wifi



  • This is really frustrating, I have a Ruckus Router, I tried all the configuration combinations I could think of, it didn't work even with an Open Network. I used two different Ruckus Reuters R710 and R600, same result. I tried ESP8266,raspberry pi, phones , laptops..the Router works very well on the 2.4 , Not sure what to do now, should I just give up and get back to it in year or two..hoping the WiFi issues got fixed with Omega10.



  • I have exactly same issue, when connecting to my Android hotspot without any security its ok, when I try to connect it to Cisco router with WPA2PSK/AES its not working. Also LED keeps flashing and my Omega is overheating like hell (wifi-manager is using 100% of CPU). No need to post content of my configs, its the same as guys above.

    I have some ESPs, notebooks, phone etc. Everything connect just fine, but not my Omega. Could you please at least communicate where is the problem, or what are you doing to fix it? This thread is more than 3 months old and there is still problem with one of the main functions of Omega (I bought it especially for on-board WiFi support). Last admin message is 3 months old, I mean come on, guys. You screwed communication on IndieGoGo (and I got letter from you how you are making extra efford to communicate with us, the community) and now this :)



  • @Jakub-Ludwig I solved it by changing router mode from 802.11n only to 802.11b/g/n mixed.
    Also you can play with wifi region especially if your channel on the router above 11.
    Maybe changing channel width between 20mhz and 40mhz can also help.



  • @M-S192 Thanks for tip, but unfortunately I have b/g/n already set, I have channel 3 and can't change channel width, because its router from my ISP with some customized firmware :(



  • @M-S192 This worked for me. Thanks! How did changing the router mode fix the issue?



  • @Nilay-Desai Well, I don't know about the mt76 driver from onion firmware but the one in official LEDE builds can disable 11n by setting htmode 'NONE' in wifi-device section. Maybe this is default behavior of onion driver.
    You can try to set htmode 'HT20' (or HT40 depending on your settings) and switch your router to 11n-only mode again.
    If this won't work I've no idea why it happens.



  • I try all solution but don"t work with my router mikrotik RB2011UiAS-2HnD-IN
    On other routers it works



  • @pvadam I had to change my country from US to CAN and that solved this whole thing
    I feel like this should be PINNED somewhere @administrators



  • I am just as disappointed, unhappy and annoyed as you guys.
    Fact is, I could not connect to any MikroTik router.
    (WPA1PSKWPA2PSK/AES, 802 b/g/n) - I am just not in the mood to play around with the settings yet.

    It did connect to my Cisco E2000 (WPA2PSK/AES)



  • This post is deleted!


Looks like your connection to Onion Community was lost, please wait while we try to reconnect.