Omega2+ fails to connect to wifi



  • @Alex-Thow Yay - finally - worked for me. thanks.



  • @Michal-Rok
    I have spent hours on the "Omega2+ fails to connect to Wifi" issue (like many people ...)

    Starting from a fresh Omega2+ (with factory resetting if needed and without using the set up wizard), I have followed your http://community.onion.io/post/13769 post and added the following lines at the end of the /etc/config/wireless file :

    config wifi-config
    option ssid 'xxxxxxxx'
    option encryption 'WPAPSK'
    option key 'xxxxxxx'

    I have also replaced WPA1PSK by WPAPSK (twice in the config file) and removed the 'option country 'US' line (http://community.onion.io/post/13801).

    After rebooting the Omega2+, I have checked that the date and internet access are now correct :

    root@Omega-2771:~# date;ia
    Sun Sep 3 14:35:42 GMT 2017
    apcli0 Link encap:Ethernet HWaddr 42:A3:6B:01:27:71
    inet addr:192.168.0.9 Bcast:192.168.0.255 Mask:255.255.255.0

    Thank you @Michal-Rok and @Ganescu-Theodor for postings your recipes.

    I also thank the people of http://community.onion.io/topic/1149/omega2-fails-to-connect-to-wifi/ for their posts which also helped me in elaborating my own recipe.

    I hope that that my post will be helpful for people having this kind of issue.

    PS : I agree with @Ganescu-Theodor when he writes "This is bad engineering to say the least, and disrespect for the people who bought this device"(http://community.onion.io/post/13794)

    And now I am going to manually install the console.



  • I had to upgrade from 0.1.5 (b130) to 0.1.10 (b160) since uci get system.@led[0].sysfs gave onion:amber:system (wrong answer) instead of the expected answer : omega2p:amber:system.

    What I wrote in my previous post (http://community.onion.io/post/14346) remains valid since the config files (/etc/config/wireless and /etc/rc.local) have been kept unchanged during sys upgrade.



  • @Gerald-Schalek Hi, I've got the same issue with WPA2PSK/AES WiFi router with the password Zyx12abcd%
    It doesn't work on both Omega2 and Omega2+ with the latest firmware. Did you use some workaround to setup the password in /etc/config/wireless (i.e. some quotes or smth like :-) )?



  • By removing country and changing mode to sta in the wireless config and following @michal-Rok i could connect to my MT rb2011, however could not connect to the internet! In frustration i turned my laptop into a hotspot and connected/upgraded etc with few issues.
    I have upgraded to 0.1.10 B160 however that has not helped connection to MT. I too have wasted hours on this and will 'pause' in the hopes the Onion team will actually look into this and come up with a permanent solution.
    Concur with the sentiment about poor engineering/support when a product like this will attract users with MT routers. I'm not an expert on openwrt however would have thought there's a simple solution!



  • 6 months after I posted problem in this thread and its still not resolved. I have my Onion Omega 2+ with latest firmware 0.1.10b160 and LED is still blinking, web console shows directory listing of ".." and "/lib", wifimanager still takze 100% of CPU, Omega is overheating as hell and I can't connect it to any Wi-Fi (secured or android hotspot unsecured). I tried every dirty trick in this thread (sta mode, deleting country, factory reset).

    If I try to configure it from SSH after first reset all data are back (wifi settings etc), poweroff and reboot commands are doing nothing ...

    Any ideas? What is the money-back policy for IndieGOGO campaign? Because right now it is useless piece of hardware, every stupid ESP clone around is far more user friendly than this thing :(

    @administrators Hm?



  • @pvadam wwujjuuu muchas gracias, funciono totalmente



  • After many hours, wasted on Wifi connection problem resolving, find solution for me.
    Shortly:
    manually setup my Omega 2 WiFi network before start setup Omega2 (b160) in web mode after upgrade.

    My home WiFi Ap name is 'dd-wrt'
    Work usually in b/g mode with TKIP encription

    Most successfully variant for me at start point - has been set WEP and 'no password mode' on router for upgrade Omega2 to (b160) version of firmware.
    And I'd set back WPA-Personal mode and TKIP on Wifi router.
    After as I made this, I meet only the troubles with my Omega2 connections.

    My Omega 2 is:
    Firmware 0.1.10 (b160)
    Latest Firmware 0.1.10 (b160)

    Linux Omega-4C77 4.4.46 #0 Thu Feb 2 23:46:03 2017 mips GNU/Linux

    What I do for resolving connection problem:

    1. Made factory reset via web interface (192.168.3.1)

    2. Connect with Putty to 192.168.3.1 (ssh, port 22) as root/onioneer

    3. root@Omega-4C77:~# vi /etc/config/wireless
      change your ssid and password AND COUNTRY! from 'US' to 'CAN'. It is needed for WiFi change channel restrictions (I'm not sure, but... it's work):
      warning: In Bold - options, which I changed from original values, but remember: it's must be in correlation with your wifi router settings. use omega2 linux command aps for router connect information. Something like a
      6 dd-wrt c8:3a:35:ea:29:58 WPAPSK/TKIP 52 11b/g NONE In in my case

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'CAN'
    option disabled '0'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '12345678'
    option ApCliEnable '1'
    option ApCliSsid 'dd-wrt'
    option ApCliAuthMode 'WPAPSK'
    option ApCliEncrypType 'TKIP'
    option ApCliPassWord '0015081975'
    option ssid 'Omega-4C77'

    1. Save your work in vi: <esc> :wq
    2. root@Omega-4C77:~#service network restart, reconnect Putty
    3. check 'root@Omega-4C77:~# ping 8.8.8.8' - it must work now
    4. opkg update
    5. opkg install mc - it is not very important step ;)
    6. go again into web interface (192.168.3.1, btw, after as I connected to my Omega-4C77 AP again, it's already works as router - internet on PC is exists now), and step by step complete setup procedure.
      But do not choose WiFi network setup, it's defined already at step 3. Choose "pass step".

    Sorry for my Martian



  • So here's a good one for y'all couldn't get it to connect tried accessing it several times through web interface then through SSH no luck on either end

    But then right as I was about to give up on it I took a smoke break and came back and low and behold the web interface worked... I really want to beat my head against the screen...



  • I must have read all these messages a hundred times without success and finally bought a new router that uses AES instead of TKIP and that was the breakthrough. So after owning two Omega2+ for 6-8 months and not being able to get past first base I started to build something useful. Then I connected an I2C device to one of them and found that the i2cdetect python command does not work There are many many messages devoted to this topic and again the developers of this product sit on their hands.

    Life is too short to spend playing around with a bug ridden immature device such as the Omega2 so you've lost me Onion Community. Bin your Omega2 and sleep again at night.



  • @David-Lochlin je suis d'accord, dommage sa petite taille été un super avantage mais bon les développeurs on tellement passé de temps a vouloir le vendre a tout prix en dénigrant les autres produits du même genre qu'ils ont oublié de finir leurs propre produit.
    Au suivant!!!



  • @pvadam
    Good. Really good answer. Enable appcli did the trick !



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.