Wifi connection problem with Omega2



  • Hello.

    I'm new to Omega, or linux modules, so perhaps i'm doing a mistake somewhere..I've read docs, and some topics.
    I've just received my Omega2 today and wanted to give a try. i'm more xp with others kind of mcus though but this omega2 looks cute, i wanted to try..

    My problem is i can't connect it to my wifi.
    I use the power dock for my tests.

    • I power on the system, the led lights up ok. Note i've never seen it blinking during my tests.
    • no problem to find the AP at 192.168.3.1
    • at the wifi credentials step, it does not want to connect! I have no fancy typo in my credentials though except an underscore.. My network is like 192.168.0.x
    • I tried multiple times. no luck.
    • So, i decided to try through ssh. juicessh on my android phone for instance. If i list wifi params by doing "wifisetup list". My credentials are well displayed, so settings looks good..
    • I tried wifi remove. and added again my wifi credentials through command line this time.
    • and finally wifi, or wifimanager etc.. for enabling/restarting the connection??
    • looks like it restart.
    • i give a look at Fing (mobile network discovery app), but i don't see anything. Only AP is available again..
    • in wifisetup, my credentials looks ok again.

    Any advice please?

    See you soon



  • @scalz check your WiFi (not Omega's) for encryption type/methods. Omega hates everything excepts WEP/WPA/WPA2(AES).



  • @Maksim-Zhouner
    My wifi already use WPA.
    i've never had any wifi problem with some others mcu (esp8266, esp32..) except a particle board once because of my pass is 32chars ..perhaps this, but not sure.
    Is there a max? I'll shorten my pass to give a try today.

    thx for your help :)



  • @scalz did you manage to solve your problem? Many people face the same problem



  • @Kostas-David
    unfortunately not yet..so i have switched on others mcu projects for the moment.
    i'll retry asap i would like to get it working and design some extension boards...
    I thought that would be a plug&play out of the box thing, for the getting started at least.



  • I am having the same issue. I am using WPA2/AES and have also tried connecting using both the web and the cli. The only thing "special" about my home wifi is it's a DD-WRT setup that has both 2.4GHz and 5GHz on the same SSID. I am well versed in the Linux CLI so I am happy to try anything you want to resolve it.



  • Just had a thought... during first boot it didn't do any of the blinky stuff the guide talks about. The red light came on for a few seconds and then went off. The amber one is on without blinking from the get-go.



  • Try enabling everything in firewall rules at /etc/config/firewall .



  • Will do. FWIW, I have also just finished trying on my second unit. The first is a Omega2+ and this one is the regular Omega2. Both are running firmware 0.1.5 b130.



  • @Zogg-Baubas I took a look at the file and it looks as though everything is already enabled (contents below). Can you be more specific about what I should try?

    root@Omega-7547:~# cat /etc/config/firewall
    
    config defaults
    	option syn_flood '1'
    	option input 'ACCEPT'
    	option output 'ACCEPT'
    	option forward 'REJECT'
    	option disable_ipv6 '1'
    
    config zone
    	option name 'lan'
    	option input 'ACCEPT'
    	option output 'ACCEPT'
    	option forward 'ACCEPT'
    	option network 'wlan'
    
    config zone
    	option name 'wan'
    	option output 'ACCEPT'
    	option forward 'REJECT'
    	option masq '1'
    	option mtu_fix '1'
    	option network 'wwan'
    	option input 'ACCEPT'
    
    config forwarding
    	option src 'lan'
    	option dest 'wan'
    
    config rule
    	option name 'Allow-DHCP-Renew'
    	option src 'wan'
    	option proto 'udp'
    	option dest_port '68'
    	option target 'ACCEPT'
    	option family 'ipv4'
    
    config rule
    	option name 'Allow-Ping'
    	option src 'wan'
    	option proto 'icmp'
    	option icmp_type 'echo-request'
    	option family 'ipv4'
    	option target 'ACCEPT'
    
    config rule
    	option name 'Allow-IGMP'
    	option src 'wan'
    	option proto 'igmp'
    	option family 'ipv4'
    	option target 'ACCEPT'
    
    config rule
    	option name 'Allow-DHCPv6'
    	option src 'wan'
    	option proto 'udp'
    	option src_ip 'fc00::/6'
    	option dest_ip 'fc00::/6'
    	option dest_port '546'
    	option family 'ipv6'
    	option target 'ACCEPT'
    
    config rule
    	option name 'Allow-MLD'
    	option src 'wan'
    	option proto 'icmp'
    	option src_ip 'fe80::/10'
    	list icmp_type '130/0'
    	list icmp_type '131/0'
    	list icmp_type '132/0'
    	list icmp_type '143/0'
    	option family 'ipv6'
    	option target 'ACCEPT'
    
    config rule
    	option name 'Allow-ICMPv6-Input'
    	option src 'wan'
    	option proto 'icmp'
    	list icmp_type 'echo-request'
    	list icmp_type 'echo-reply'
    	list icmp_type 'destination-unreachable'
    	list icmp_type 'packet-too-big'
    	list icmp_type 'time-exceeded'
    	list icmp_type 'bad-header'
    	list icmp_type 'unknown-header-type'
    	list icmp_type 'router-solicitation'
    	list icmp_type 'neighbour-solicitation'
    	list icmp_type 'router-advertisement'
    	list icmp_type 'neighbour-advertisement'
    	option limit '1000/sec'
    	option family 'ipv6'
    	option target 'ACCEPT'
    
    config rule
    	option name 'Allow-ICMPv6-Forward'
    	option src 'wan'
    	option dest '*'
    	option proto 'icmp'
    	list icmp_type 'echo-request'
    	list icmp_type 'echo-reply'
    	list icmp_type 'destination-unreachable'
    	list icmp_type 'packet-too-big'
    	list icmp_type 'time-exceeded'
    	list icmp_type 'bad-header'
    	list icmp_type 'unknown-header-type'
    	option limit '1000/sec'
    	option family 'ipv6'
    	option target 'ACCEPT'
    
    config include
    	option path '/etc/firewall.user'
    
    config rule
    	option src 'wan'
    	option dest 'lan'
    	option proto 'esp'
    	option target 'ACCEPT'
    
    config rule
    	option src 'wan'
    	option dest 'lan'
    	option dest_port '500'
    	option proto 'udp'
    	option target 'ACCEPT'
    


  • @Gene-Liverman Set this couple of options to:

    config defaults
            option forward 'ACCEPT'
    

    and

    config zone
            option forward 'ACCEPT'
    


  • @Zogg-Baubas No change... any other ideas?



  • @Gene-Liverman I'v modified firewall rules, restarted omega, ran wifimanager manually and it started to connect and stay connected with my wifiAP. I have 2nd Omega nearby, I'll do the same and see if the result was not a coincidence.

    I'v tried everything in all the other threads, and nothing helped me. Try your luck with info in other tread: https://community.onion.io/topic/1149/omega2-fails-to-connect-to-wifi



  • I have now updated the firmware on the plus via usb serial to 0.1.7-b140 and tried it with and without the fw rule changes, no luck. Trying the non-plus model now.



  • No luck with this one either. I tried the "fix" in the other thread in /etc/config/wireless but it didn't work either. Below is what I see whey I tell wifimanager to do its thing:

    root@Omega-95D3:/# wifimanager -v
    radio0 is up
    Reading configured networks in station mode...
    "10th-Tardis"
    
    Scanning nearby networks...
    found"10th-Tardis"
    "The-Companion"
    ""
    ""
    "ATTXB4TnQs"
    
    
    
    Current Count: 1
    Number of configured nets: 1
    trying to connect to... "10th-Tardis"
    [  350.930646] br-wlan: port 2(ra0) entered disabled state
    [  351.375425] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  353.849016]  ch1 bssid=a0:63:91:d6:11:20
    [  353.853017]  ch6 bssid=f6:f2:6d:70:58:55
    [  353.856996]  ch6 bssid=f4:f2:6d:70:58:55
    [  353.861008]  ch6 bssid=f2:f2:6d:70:58:55
    [  353.865028]  ch11 bssid=cc:65:ad:ef:76:60
    [  353.869126]  ch11 bssid=8c:7f:3b:4a:76:70
    [  353.873190] =====================================================
    [  353.879388] Channel 1 : Dirty = 70, False CCA = 0, Busy Time = 2675, Skip Channel = FALSE
    [  353.887678] Channel 2 : Dirty = 92, False CCA = 0, Busy Time = 915, Skip Channel = FALSE
    [  353.895898] Channel 3 : Dirty = 100, False CCA = 0, Busy Time = 98, Skip Channel = FALSE
    [  353.904119] Channel 4 : Dirty = 108, False CCA = 0, Busy Time = 1363, Skip Channel = FALSE
    [  353.912516] Channel 5 : Dirty = 116, False CCA = 0, Busy Time = 3800, Skip Channel = FALSE
    [  353.920913] Channel 6 : Dirty = 240, False CCA = 0, Busy Time = 5577, Skip Channel = FALSE
    [  353.929325] Channel 7 : Dirty = 136, False CCA = 0, Busy Time = 3398, Skip Channel = FALSE
    [  353.937704] Channel 8 : Dirty = 132, False CCA = 0, Busy Time = 463, Skip Channel = FALSE
    [  353.946014] Channel 9 : Dirty = 128, False CCA = 0, Busy Time = 847, Skip Channel = FALSE
    [  353.954323] Channel 10 : Dirty = 124, False CCA = 0, Busy Time = 8338, Skip Channel = FALSE
    [  353.962808] Channel 11 : Dirty = 140, False CCA = 0, Busy Time = 5301, Skip Channel = FALSE
    [  353.971287] =====================================================
    [  353.977468] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 1
    [  353.986210] Min Dirty = 70
    [  353.988953] ExChannel = 0 , 0
    [  353.991977] BW        = 20
    [  354.021307] br-wlan: port 2(ra0) entered forwarding state
    [  354.026832] br-wlan: port 2(ra0) entered forwarding state
    [  356.019017] br-wlan: port 2(ra0) entered forwarding state
    [  359.425598] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    ran out of configured networks... no station available
    [  383.899088] br-wlan: port 2(ra0) entered disabled state
    [  384.085441] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [  384.949351] EEPROM:Read from [factory] offset 0x0,length 0x400.
    Current Count: 1
    Number of configured nets: 1
    trying to connect to... "10th-Tardis"
    [  350.930646] br-wlan: port 2(ra0) entered disabled state
    [  351.375425] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  353.849016]  ch1 bssid=a0:63:91:d6:11:20
    [  353.853017]  ch6 bssid=f6:f2:6d:70:58:55
    [  353.856996]  ch6 bssid=f4:f2:6d:70:58:55
    [  353.861008]  ch6 bssid=f2:f2:6d:70:58:55
    [  353.865028]  ch11 bssid=cc:65:ad:ef:76:60
    [  353.869126]  ch11 bssid=8c:7f:3b:4a:76:70
    [  353.873190] =====================================================
    [  353.879388] Channel 1 : Dirty = 70, False CCA = 0, Busy Time = 2675, Skip Channel = FALSE
    [  353.887678] Channel 2 : Dirty = 92, False CCA = 0, Busy Time = 915, Skip Channel = FALSE
    [  353.895898] Channel 3 : Dirty = 100, False CCA = 0, Busy Time = 98, Skip Channel = FALSE
    [  353.904119] Channel 4 : Dirty = 108, False CCA = 0, Busy Time = 1363, Skip Channel = FALSE
    [  353.912516] Channel 5 : Dirty = 116, False CCA = 0, Busy Time = 3800, Skip Channel = FALSE
    [  353.920913] Channel 6 : Dirty = 240, False CCA = 0, Busy Time = 5577, Skip Channel = FALSE
    [  353.929325] Channel 7 : Dirty = 136, False CCA = 0, Busy Time = 3398, Skip Channel = FALSE
    [  353.937704] Channel 8 : Dirty = 132, False CCA = 0, Busy Time = 463, Skip Channel = FALSE
    [  353.946014] Channel 9 : Dirty = 128, False CCA = 0, Busy Time = 847, Skip Channel = FALSE
    [  353.954323] Channel 10 : Dirty = 124, False CCA = 0, Busy Time = 8338, Skip Channel = FALSE
    [  353.962808] Channel 11 : Dirty = 140, False CCA = 0, Busy Time = 5301, Skip Channel = FALSE
    [  353.971287] =====================================================
    [  353.977468] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 1
    [  353.986210] Min Dirty = 70
    [  353.988953] ExChannel = 0 , 0
    [  353.991977] BW        = 20
    [  354.021307] br-wlan: port 2(ra0) entered forwarding state
    [  354.026832] br-wlan: port 2(ra0) entered forwarding state
    [  356.019017] br-wlan: port 2(ra0) entered forwarding state
    [  359.425598] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    ran out of configured networks... no station available
    [  383.899088] br-wlan: port 2(ra0) entered disabled state
    [  384.085441] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [  384.949351] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  387.419016]  ch1 bssid=a0:63:91:d6:11:20
    [  387.423017]  ch6 bssid=f4:f2:6d:70:58:55
    [  387.426995]  ch6 bssid=f6:f2:6d:70:58:55
    [  387.431007]  ch6 bssid=f2:f2:6d:70:58:55
    [  387.434988]  ch11 bssid=8c:7f:3b:4a:76:70
    [  387.439086]  ch11 bssid=d4:04:cd:76:80:60
    [  387.443153]  ch11 bssid=40:c7:29:49:7b:ca
    [  387.447215] =====================================================
    [  387.453415] Channel 1 : Dirty = 70, False CCA = 0, Busy Time = 2070, Skip Channel = FALSE
    [  387.461731] Channel 2 : Dirty = 92, False CCA = 0, Busy Time = 69, Skip Channel = FALSE
    [  387.469864] Channel 3 : Dirty = 100, False CCA = 0, Busy Time = 3639, Skip Channel = FALSE
    [  387.478242] Channel 4 : Dirty = 108, False CCA = 0, Busy Time = 3064, Skip Channel = FALSE
    [  387.486638] Channel 5 : Dirty = 116, False CCA = 0, Busy Time = 2248, Skip Channel = FALSE
    [  387.495034] Channel 6 : Dirty = 240, False CCA = 0, Busy Time = 2436, Skip Channel = FALSE
    [  387.503431] Channel 7 : Dirty = 156, False CCA = 0, Busy Time = 2168, Skip Channel = FALSE
    [  387.511827] Channel 8 : Dirty = 156, False CCA = 0, Busy Time = 983, Skip Channel = FALSE
    [  387.520136] Channel 9 : Dirty = 156, False CCA = 0, Busy Time = 1013, Skip Channel = FALSE
    [  387.528515] Channel 10 : Dirty = 156, False CCA = 0, Busy Time = 12105, Skip Channel = FALSE
    [  387.537086] Channel 11 : Dirty = 210, False CCA = 0, Busy Time = 10746, Skip Channel = FALSE
    [  387.545654] =====================================================
    [  387.551850] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 1
    [  387.560592] Min Dirty = 70
    [  387.563336] ExChannel = 0 , 0
    [  387.566342] BW        = 20
    [  387.595604] br-wlan: port 2(ra0) entered forwarding state
    [  387.601192] br-wlan: port 2(ra0) entered forwarding state
    Wifi manager finished
    root@Omega-95D3:/# [  389.598987] br-wlan: port 2(ra0) entered forwarding state
    [  354.021307] br-wlan: port 2(ra0) entered forwarding state
    [  354.026832] br-wlan: port 2(ra0) entered forwarding state
    [  356.019017] br-wlan: port 2(ra0) entered forwarding state
    [  359.425598] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    ran out of configured networks... no station available
    [  383.899088] br-wlan: port 2(ra0) entered disabled state
    [  384.085441] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [  384.949351] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  387.419016]  ch1 bssid=a0:63:91:d6:11:20
    [  387.423017]  ch6 bssid=f4:f2:6d:70:58:55
    [  387.426995]  ch6 bssid=f6:f2:6d:70:58:55
    [  387.431007]  ch6 bssid=f2:f2:6d:70:58:55
    [  387.434988]  ch11 bssid=8c:7f:3b:4a:76:70
    [  387.439086]  ch11 bssid=d4:04:cd:76:80:60
    [  387.443153]  ch11 bssid=40:c7:29:49:7b:ca
    [  387.447215] =====================================================
    [  387.453415] Channel 1 : Dirty = 70, False CCA = 0, Busy Time = 2070, Skip Channel = FALSE
    [  387.461731] Channel 2 : Dirty = 92, False CCA = 0, Busy Time = 69, Skip Channel = FALSE
    [  387.469864] Channel 3 : Dirty = 100, False CCA = 0, Busy Time = 3639, Skip Channel = FALSE
    [  387.478242] Channel 4 : Dirty = 108, False CCA = 0, Busy Time = 3064, Skip Channel = FALSE
    [  387.486638] Channel 5 : Dirty = 116, False CCA = 0, Busy Time = 2248, Skip Channel = FALSE
    [  387.495034] Channel 6 : Dirty = 240, False CCA = 0, Busy Time = 2436, Skip Channel = FALSE
    [  387.503431] Channel 7 : Dirty = 156, False CCA = 0, Busy Time = 2168, Skip Channel = FALSE
    [  387.511827] Channel 8 : Dirty = 156, False CCA = 0, Busy Time = 983, Skip Channel = FALSE
    [  387.520136] Channel 9 : Dirty = 156, False CCA = 0, Busy Time = 1013, Skip Channel = FALSE
    [  387.528515] Channel 10 : Dirty = 156, False CCA = 0, Busy Time = 12105, Skip Channel = FALSE
    [  387.537086] Channel 11 : Dirty = 210, False CCA = 0, Busy Time = 10746, Skip Channel = FALSE
    [  387.545654] =====================================================
    [  387.551850] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 1
    [  387.560592] Min Dirty = 70
    [  387.563336] ExChannel = 0 , 0
    [  387.566342] BW        = 20
    [  387.595604] br-wlan: port 2(ra0) entered forwarding state
    [  387.601192] br-wlan: port 2(ra0) entered forwarding state
    Wifi manager finished
    root@Omega-95D3:/# [  389.598987] br-wlan: port 2(ra0) entered forwarding state
    root@Omega-95D3:/#
    


  • I'v tried firewall settings on my other Omega2+. FAIL. Just as for you, it did nothing. I'm starting to think that the Omega itself is actually broken.



  • Here is /etc/config/network from a working WiFi-setup:

    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option ifname 'eth0.1'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option proto 'dhcp'
    

    And here is /etc/config/wireless:

    
    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ApCliEnable '1'
    	option ApCliAuthMode 'WPA2PSK'
    	option ApCliEncrypType 'AES'
    	option ssid 'Omega-616B'
    	option ApCliSsid 'PUTYOUROWNSSIDHERE'
    	option ApCliPassWord 'PUTYOURPASSWORDHERE'
    
    config wifi-config
    	option ssid 'PUTYOUROWNSSIDHERE'
    	option encryption 'WPA2PSK'
    	option key 'PUTYOURPASSWORDHERE'
    
    

    Modify your files similarly and hopefully you'll get WiFi working. If your WiFi-network is on a channel higher than 9, you may have to change the channel from auto to whatever channel you're using -- auto didn't work for me when I tested my WiFi on channel 13, even with correct countryregion-settings.



  • @WereCatf Nope, that does nothing either. I'v tried all the suggestions in all the other threads. I can't even flash (manually) firmware on this Omega - the sysupgrade fails to do the job. :(



  • @Zogg-Baubas said in Wifi connection problem with Omega2:

    the sysupgrade fails to do the job. :(

    What do you mean with that?



  • @WereCatf said in Wifi connection problem with Omega2:

    @Zogg-Baubas said in Wifi connection problem with Omega2:

    the sysupgrade fails to do the job. :(

    What do you mean with that?

    Heres the post where I'v put the sysupgrade logs: https://community.onion.io/topic/1149/omega2-fails-to-connect-to-wifi/14


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.