Wifi connection problem with Omega2



  • I have now updated the firmware on the plus via usb serial to 0.1.7-b140 and tried it with and without the fw rule changes, no luck. Trying the non-plus model now.



  • No luck with this one either. I tried the "fix" in the other thread in /etc/config/wireless but it didn't work either. Below is what I see whey I tell wifimanager to do its thing:

    root@Omega-95D3:/# wifimanager -v
    radio0 is up
    Reading configured networks in station mode...
    "10th-Tardis"
    
    Scanning nearby networks...
    found"10th-Tardis"
    "The-Companion"
    ""
    ""
    "ATTXB4TnQs"
    
    
    
    Current Count: 1
    Number of configured nets: 1
    trying to connect to... "10th-Tardis"
    [  350.930646] br-wlan: port 2(ra0) entered disabled state
    [  351.375425] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  353.849016]  ch1 bssid=a0:63:91:d6:11:20
    [  353.853017]  ch6 bssid=f6:f2:6d:70:58:55
    [  353.856996]  ch6 bssid=f4:f2:6d:70:58:55
    [  353.861008]  ch6 bssid=f2:f2:6d:70:58:55
    [  353.865028]  ch11 bssid=cc:65:ad:ef:76:60
    [  353.869126]  ch11 bssid=8c:7f:3b:4a:76:70
    [  353.873190] =====================================================
    [  353.879388] Channel 1 : Dirty = 70, False CCA = 0, Busy Time = 2675, Skip Channel = FALSE
    [  353.887678] Channel 2 : Dirty = 92, False CCA = 0, Busy Time = 915, Skip Channel = FALSE
    [  353.895898] Channel 3 : Dirty = 100, False CCA = 0, Busy Time = 98, Skip Channel = FALSE
    [  353.904119] Channel 4 : Dirty = 108, False CCA = 0, Busy Time = 1363, Skip Channel = FALSE
    [  353.912516] Channel 5 : Dirty = 116, False CCA = 0, Busy Time = 3800, Skip Channel = FALSE
    [  353.920913] Channel 6 : Dirty = 240, False CCA = 0, Busy Time = 5577, Skip Channel = FALSE
    [  353.929325] Channel 7 : Dirty = 136, False CCA = 0, Busy Time = 3398, Skip Channel = FALSE
    [  353.937704] Channel 8 : Dirty = 132, False CCA = 0, Busy Time = 463, Skip Channel = FALSE
    [  353.946014] Channel 9 : Dirty = 128, False CCA = 0, Busy Time = 847, Skip Channel = FALSE
    [  353.954323] Channel 10 : Dirty = 124, False CCA = 0, Busy Time = 8338, Skip Channel = FALSE
    [  353.962808] Channel 11 : Dirty = 140, False CCA = 0, Busy Time = 5301, Skip Channel = FALSE
    [  353.971287] =====================================================
    [  353.977468] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 1
    [  353.986210] Min Dirty = 70
    [  353.988953] ExChannel = 0 , 0
    [  353.991977] BW        = 20
    [  354.021307] br-wlan: port 2(ra0) entered forwarding state
    [  354.026832] br-wlan: port 2(ra0) entered forwarding state
    [  356.019017] br-wlan: port 2(ra0) entered forwarding state
    [  359.425598] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    ran out of configured networks... no station available
    [  383.899088] br-wlan: port 2(ra0) entered disabled state
    [  384.085441] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [  384.949351] EEPROM:Read from [factory] offset 0x0,length 0x400.
    Current Count: 1
    Number of configured nets: 1
    trying to connect to... "10th-Tardis"
    [  350.930646] br-wlan: port 2(ra0) entered disabled state
    [  351.375425] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  353.849016]  ch1 bssid=a0:63:91:d6:11:20
    [  353.853017]  ch6 bssid=f6:f2:6d:70:58:55
    [  353.856996]  ch6 bssid=f4:f2:6d:70:58:55
    [  353.861008]  ch6 bssid=f2:f2:6d:70:58:55
    [  353.865028]  ch11 bssid=cc:65:ad:ef:76:60
    [  353.869126]  ch11 bssid=8c:7f:3b:4a:76:70
    [  353.873190] =====================================================
    [  353.879388] Channel 1 : Dirty = 70, False CCA = 0, Busy Time = 2675, Skip Channel = FALSE
    [  353.887678] Channel 2 : Dirty = 92, False CCA = 0, Busy Time = 915, Skip Channel = FALSE
    [  353.895898] Channel 3 : Dirty = 100, False CCA = 0, Busy Time = 98, Skip Channel = FALSE
    [  353.904119] Channel 4 : Dirty = 108, False CCA = 0, Busy Time = 1363, Skip Channel = FALSE
    [  353.912516] Channel 5 : Dirty = 116, False CCA = 0, Busy Time = 3800, Skip Channel = FALSE
    [  353.920913] Channel 6 : Dirty = 240, False CCA = 0, Busy Time = 5577, Skip Channel = FALSE
    [  353.929325] Channel 7 : Dirty = 136, False CCA = 0, Busy Time = 3398, Skip Channel = FALSE
    [  353.937704] Channel 8 : Dirty = 132, False CCA = 0, Busy Time = 463, Skip Channel = FALSE
    [  353.946014] Channel 9 : Dirty = 128, False CCA = 0, Busy Time = 847, Skip Channel = FALSE
    [  353.954323] Channel 10 : Dirty = 124, False CCA = 0, Busy Time = 8338, Skip Channel = FALSE
    [  353.962808] Channel 11 : Dirty = 140, False CCA = 0, Busy Time = 5301, Skip Channel = FALSE
    [  353.971287] =====================================================
    [  353.977468] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 1
    [  353.986210] Min Dirty = 70
    [  353.988953] ExChannel = 0 , 0
    [  353.991977] BW        = 20
    [  354.021307] br-wlan: port 2(ra0) entered forwarding state
    [  354.026832] br-wlan: port 2(ra0) entered forwarding state
    [  356.019017] br-wlan: port 2(ra0) entered forwarding state
    [  359.425598] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    ran out of configured networks... no station available
    [  383.899088] br-wlan: port 2(ra0) entered disabled state
    [  384.085441] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [  384.949351] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  387.419016]  ch1 bssid=a0:63:91:d6:11:20
    [  387.423017]  ch6 bssid=f4:f2:6d:70:58:55
    [  387.426995]  ch6 bssid=f6:f2:6d:70:58:55
    [  387.431007]  ch6 bssid=f2:f2:6d:70:58:55
    [  387.434988]  ch11 bssid=8c:7f:3b:4a:76:70
    [  387.439086]  ch11 bssid=d4:04:cd:76:80:60
    [  387.443153]  ch11 bssid=40:c7:29:49:7b:ca
    [  387.447215] =====================================================
    [  387.453415] Channel 1 : Dirty = 70, False CCA = 0, Busy Time = 2070, Skip Channel = FALSE
    [  387.461731] Channel 2 : Dirty = 92, False CCA = 0, Busy Time = 69, Skip Channel = FALSE
    [  387.469864] Channel 3 : Dirty = 100, False CCA = 0, Busy Time = 3639, Skip Channel = FALSE
    [  387.478242] Channel 4 : Dirty = 108, False CCA = 0, Busy Time = 3064, Skip Channel = FALSE
    [  387.486638] Channel 5 : Dirty = 116, False CCA = 0, Busy Time = 2248, Skip Channel = FALSE
    [  387.495034] Channel 6 : Dirty = 240, False CCA = 0, Busy Time = 2436, Skip Channel = FALSE
    [  387.503431] Channel 7 : Dirty = 156, False CCA = 0, Busy Time = 2168, Skip Channel = FALSE
    [  387.511827] Channel 8 : Dirty = 156, False CCA = 0, Busy Time = 983, Skip Channel = FALSE
    [  387.520136] Channel 9 : Dirty = 156, False CCA = 0, Busy Time = 1013, Skip Channel = FALSE
    [  387.528515] Channel 10 : Dirty = 156, False CCA = 0, Busy Time = 12105, Skip Channel = FALSE
    [  387.537086] Channel 11 : Dirty = 210, False CCA = 0, Busy Time = 10746, Skip Channel = FALSE
    [  387.545654] =====================================================
    [  387.551850] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 1
    [  387.560592] Min Dirty = 70
    [  387.563336] ExChannel = 0 , 0
    [  387.566342] BW        = 20
    [  387.595604] br-wlan: port 2(ra0) entered forwarding state
    [  387.601192] br-wlan: port 2(ra0) entered forwarding state
    Wifi manager finished
    root@Omega-95D3:/# [  389.598987] br-wlan: port 2(ra0) entered forwarding state
    [  354.021307] br-wlan: port 2(ra0) entered forwarding state
    [  354.026832] br-wlan: port 2(ra0) entered forwarding state
    [  356.019017] br-wlan: port 2(ra0) entered forwarding state
    [  359.425598] !!! APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    wwan network is set up... false,
    ran out of configured networks... no station available
    [  383.899088] br-wlan: port 2(ra0) entered disabled state
    [  384.085441] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [  384.949351] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  387.419016]  ch1 bssid=a0:63:91:d6:11:20
    [  387.423017]  ch6 bssid=f4:f2:6d:70:58:55
    [  387.426995]  ch6 bssid=f6:f2:6d:70:58:55
    [  387.431007]  ch6 bssid=f2:f2:6d:70:58:55
    [  387.434988]  ch11 bssid=8c:7f:3b:4a:76:70
    [  387.439086]  ch11 bssid=d4:04:cd:76:80:60
    [  387.443153]  ch11 bssid=40:c7:29:49:7b:ca
    [  387.447215] =====================================================
    [  387.453415] Channel 1 : Dirty = 70, False CCA = 0, Busy Time = 2070, Skip Channel = FALSE
    [  387.461731] Channel 2 : Dirty = 92, False CCA = 0, Busy Time = 69, Skip Channel = FALSE
    [  387.469864] Channel 3 : Dirty = 100, False CCA = 0, Busy Time = 3639, Skip Channel = FALSE
    [  387.478242] Channel 4 : Dirty = 108, False CCA = 0, Busy Time = 3064, Skip Channel = FALSE
    [  387.486638] Channel 5 : Dirty = 116, False CCA = 0, Busy Time = 2248, Skip Channel = FALSE
    [  387.495034] Channel 6 : Dirty = 240, False CCA = 0, Busy Time = 2436, Skip Channel = FALSE
    [  387.503431] Channel 7 : Dirty = 156, False CCA = 0, Busy Time = 2168, Skip Channel = FALSE
    [  387.511827] Channel 8 : Dirty = 156, False CCA = 0, Busy Time = 983, Skip Channel = FALSE
    [  387.520136] Channel 9 : Dirty = 156, False CCA = 0, Busy Time = 1013, Skip Channel = FALSE
    [  387.528515] Channel 10 : Dirty = 156, False CCA = 0, Busy Time = 12105, Skip Channel = FALSE
    [  387.537086] Channel 11 : Dirty = 210, False CCA = 0, Busy Time = 10746, Skip Channel = FALSE
    [  387.545654] =====================================================
    [  387.551850] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 1
    [  387.560592] Min Dirty = 70
    [  387.563336] ExChannel = 0 , 0
    [  387.566342] BW        = 20
    [  387.595604] br-wlan: port 2(ra0) entered forwarding state
    [  387.601192] br-wlan: port 2(ra0) entered forwarding state
    Wifi manager finished
    root@Omega-95D3:/# [  389.598987] br-wlan: port 2(ra0) entered forwarding state
    root@Omega-95D3:/#
    


  • I'v tried firewall settings on my other Omega2+. FAIL. Just as for you, it did nothing. I'm starting to think that the Omega itself is actually broken.



  • Here is /etc/config/network from a working WiFi-setup:

    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option ifname 'eth0.1'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option proto 'dhcp'
    

    And here is /etc/config/wireless:

    
    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ApCliEnable '1'
    	option ApCliAuthMode 'WPA2PSK'
    	option ApCliEncrypType 'AES'
    	option ssid 'Omega-616B'
    	option ApCliSsid 'PUTYOUROWNSSIDHERE'
    	option ApCliPassWord 'PUTYOURPASSWORDHERE'
    
    config wifi-config
    	option ssid 'PUTYOUROWNSSIDHERE'
    	option encryption 'WPA2PSK'
    	option key 'PUTYOURPASSWORDHERE'
    
    

    Modify your files similarly and hopefully you'll get WiFi working. If your WiFi-network is on a channel higher than 9, you may have to change the channel from auto to whatever channel you're using -- auto didn't work for me when I tested my WiFi on channel 13, even with correct countryregion-settings.



  • @WereCatf Nope, that does nothing either. I'v tried all the suggestions in all the other threads. I can't even flash (manually) firmware on this Omega - the sysupgrade fails to do the job. :(



  • @Zogg-Baubas said in Wifi connection problem with Omega2:

    the sysupgrade fails to do the job. :(

    What do you mean with that?



  • @WereCatf said in Wifi connection problem with Omega2:

    @Zogg-Baubas said in Wifi connection problem with Omega2:

    the sysupgrade fails to do the job. :(

    What do you mean with that?

    Heres the post where I'v put the sysupgrade logs: https://community.onion.io/topic/1149/omega2-fails-to-connect-to-wifi/14



  • @Zogg-Baubas Why did you use --force? You made two mistakes with sysupgrade: 1) move the image to /tmp. It won't work from /, like you noticed. 2) use sysupgrade -n yourimagehere.bin to have it wipe all current settings while upgrading.

    If you do it correctly it'll work.



  • @Zogg-Baubas I upgraded mine by using the serial console over USB. To do this, install the driver from and follow the directions on https://wiki.onion.io/Tutorials/Connecting-to-Omega-via-Serial-Terminal then do the steps below per http://community.onion.io/topic/1154/omega-2-usb-firmware-install-after-brick-resolved/2

    1. Download firmware file to USB flash drive
    2. Rename the file to Omega2.bin (this works for both Omega2 & Omega 2+)
    3. Connect PC to Omega 2 via device supporting USB to serial connectivity.
    4. Hold the reset button down and power on the omega.
    5. Select option #2, install firmware from USB.


  • @WereCatf I'll give your network config a try this weekend, thanks!



  • @WereCatf said in Wifi connection problem with Omega2:

    @Zogg-Baubas Why did you use --force? You made two mistakes with sysupgrade: 1) move the image to /tmp. It won't work from /, like you noticed. 2) use sysupgrade -n yourimagehere.bin to have it wipe all current settings while upgrading.

    If you do it correctly it'll work.

    Thanks, will do once my USB-Serial cable arrives. ;) For now it is bricked.



  • I've done everything I have seen on this community and still have not gotten a single positive result. I'm also running 0.1.8 b145. Still shocked my ESP8266 and ESP32 are connecting to Wi-Fi but this somehow struggles with its superior specs...



  • @legotheboss Have you tried this?



  • i have same issue on mikrotik router and airties router. it seems just connecting on my s7edge's hotspot. i've tried everything in this thread and links but nothing changed.
    have anyone has real fix?
    i also tried to change country to us on my router but seems nothing change too.

    edit1: i also tried fw 0.1.5 to 0.1.8 and result same



  • @mehmet-bozkurt Could you post content of your /etc/config/wireless config file and aps command output?



  • @Mikaël-PIRIO ok here is it.

    /etc/config/wireless
    ~~config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'US'
    option disabled '0'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '12345678'
    option ApCliEncrypType 'AES'
    option ApCliAuthMode 'WPA2PSK'
    option ssid 'Omega-A1AF'
    option ApCliSsid 'WoLFStationLVLm'
    option ApCliPassWord 'xxxxx'
    option ApCliEnable '1'

    config wifi-config
    option ssid 'WoLFStationLVLm'
    option encryption 'WPA2PSK'
    option key 'xxxxx'
    ~~

    aps
    ~~aps
    WRTnode AP scaner.
    Begin scaning APs, pls wait...
    Finished.
    APs available are...
    ra0 get_site_survey:
    Ch SSID BSSID Security Signal(%)W-Mode ExtCH NT
    6 WoLFStationLVLm 4e:66:41:56:b3:53 WPA2PSK/AES 100 11b/g/n NONE In
    6 ZyXEL fc:f5:28:f7:dd:6f WPA2PSK/AES 0 11b/g/n NONE In
    6 123efe e8:94:f6:fb:d9:2a WPA2PSK/AES 0 11b/g/n BELOW In
    7 AgaKa-2 f0:b4:29:59:fe:39 WPA1PSKWPA2PSK/TKIPAES 10 11b/g/n ABOVE In
    7 WoLFStationLVL4 4c:5e:0c:70:fd:b0 WPA2PSK/AES 94 11b/g/n ABOVE In
    10 Fiberhat_Balcioglu a4:2b:b0:fd:d4:12 WPA2PSK/AES 0 11b/g/n BELOW In
    11 Elin ec:08:6b:f0:33:f4 WPA2PSK/AES 0 11b/g/n NONE In
    11 agakax 18:28:61:f8:ab:3d WPA2PSK/AES 24 11b/g/n NONE In
    ~~



  • @mehmet-bozkurt Your config file seems to be OK :pensive: .

    Have you check your subnet: no collision (see here)?

    Perhaps could you try to force option channel to '6'? Run nr command after and check if you get an IP with ia command...



  • @Mikaël-PIRIO no collision. its on different subnet. how can i force channel to 6? on router side ?



  • @mehmet-bozkurt No. In your /etc/config/wireless config file, in the "config wifi-device 'ra0'" section.



  • @Mikaël-PIRIO same result. btw i found my "xiaomi mi router nano" and seems omega2 can connect this router too.
    seems something wrong on omega2 firmware side


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.