Omega2+ unreachable when Wifi shut down



  • This post is deleted!


  • @MookieDog
    Finally!
    I followed MookieDogs's instructions and was able to recover my Omega2+.
    In short:

    1. solder RX0 and TX0 on PowerDock to extend Omega2+ serial0 (console serial) RX and TX lines
    2. cross connect RX0 and TX0 line with respective TX and RX on 3.3v level serial port. I used Raspberry PI serial and minicom.
    3. on Raspberry PI (or another Omega) use serial port with "minicom -b 115200 -D /dev/ttyAMA0" command
    4. now you are able to connect to Omega2+ console and configured it as you wish. I did manual factory reset using info on https://docs.onion.io/omega2-docs/factory-reset.html

    All thanks go to MookieDog.



  • @dgluhak4 OFF
    Excuse me if my post is entirely off-topic.

    Omega2+ v0.1.9-b150 without Dock

    Raspberry Pi 2 Model B V1.1
    up-to-date Raspbian Jessie
    minicom version 2.7 (compiled Jan 12 2014)

    Formerly I also tried this 3.3V logic level 'Null Modem' connection between my O2+ and a RPi .
    (Omega_RX0---RPi_TXD0, Omega_TX0---RPi_RXD0, GND---GND)

    I always got garbaged characters up to the 'console [ttyS0] enabled' line(s):

       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/"
    
    Board: Onion Omega2 APSoC DRAM:  128 MB
    relocate_code Po)‹¥ÉY device id 2°LN¡È•¹‘Ìlash: MX2µÌ²µ¶³MQ¡ø*** Warning - âX-¤(ª(   QÍ¥¹Èefault env©¹Ë««åÑ)
    o628_MP (Port5<->Îïîå©
    C(ªTOOÏÏÏÏϏêêêêêêêR5=¹¥½¹žmega2 UBoot ÖY®®ÖËK¢ršr‚ršR5µµ[------------------­KKKKKKKKKKKKKKKË©©©©©   ¤Ôš%
    AUÌreq = 575 MHÚ
    CQ.W«+E•‘Úemory size = L&RJ•Ñ•Í)Resetting MT7¶™œTRVI¨øInitializé·©Šu²ÂÂ:A%=æystem.C+5¡Æomponent: SPI Flá.–¨ˆѕéžct 18 2016  T5
    
    
    C%%%%%%%%¥IIIIIIIIIIIIIIIIIIII‰RRRRRRRR5©‘old Reset buttïî æﲐ[K•ßptions *
    ***ªªªªªª•••%%%%%%%%%%%%%%%%%%%%¥IIIII¨H¨H¨H¨Hõ½Ñ˜inux from Flash Î
                                                                        %UQ RESSED.
    ## Booté·)«+u•Ât bc050000 ...
                                   R[XVÈ*Օé@  MIPS LED
    ¦Z«áµi.4.42                                                                                   K
       Uncompreó®–ëZ•É¹•±’mage ...
    ݁Çontrol                                          ©Šr’j     )   Load Address: 800°˜˜˜L*¹ÑÉ偠oint:  80°˜˜Ar¢r¢’B’2
    [    0.00°˜˜˜W Të“Ñ
    ± MU set to 跐¬Ë‹É½±5[    0.000°°°Ý “k¢åÁ•é@MediaTek MT·œHW–KŠ*½éd5§tarting kernel ®®®ŠŠÃ[    0.000000] Linu¸»Y®®ÕË         Ë
    [    0.0°˜˜˜LW$¬ë‹½¹Í½±•[early0] enabledp0000000) ———¡h4:¥Ù¥¹Øinux mems©½Y¤-
    [  ˜KLL&&&RAUÁ@revision Z.')ʲªªBj%AMe4KEc)
    [    0.00°˜˜˜W *
                    5¥j
    ¡¥¹•is Onion Omega2+
    [    0.000000] Deteò[Z«Gáhysical RAM m‚‚BªÍ
    ‰±•¥
    ېHL  ‚‚‚‚‚ê@memory: 08°˜˜˜LLH($&           [    ‚‚‚º2™™™™™u5[    0.000°˜˜W¤êË
    ‰±•ôone start foòYX,’ë‹S5[    0.000000ݐQX.+Ûemory node rangr¹
    ѱäegister=000´˜˜˜YC¡+elistsr‚‚‚‚‚‚ꁤeadback ErrCtl råVkѕÉõa004000fpagesº ³²µ±™C¡+r‚‚‚‚‚‚ꁗernel command ìZ«§½¹Í½±•õètyS0,115200 ¹ë‹™ÍÑåÁ•õæq+É
    [    0.000000] Íåíïò¹L¦SS“iê)šŠ‚º’ZÂvailable (3012ː­–˫ŁÆode, 143K rwdata¬“‰Zåodata, 208K init, ±NÓ
                                                                                                              %Íͱ@5520K reserved, °)ÒV+Ւ•Í•Éٕ‘¥
                                                                                                                                                  [    0®°°°
                                              D•Ù¥•Ñɕ•5[    0.00000°W¤(UjŠëk³éA580MHz                                                                   6
    [    0.000°˜˜W¤,ëkµÍ½Õɍ•}Áɽ‰•é@no matching cloã­®«É•ÍÌound                                                                                          1
    [    0.0746³NW¤ê«¹ÑµÆache hash tabìå Y‹É¥•Íé@1024 (orderº °¬ ´˜NJ+ѕͥ¬ [X¯•‘±•}¹Íé@6590553²¶´ î³C¡+r‚‚‚‚Š’êæched_clock: 32 âZ¯.RJʂj!é±@resolutioë
                                                                           [    0.0¸˜Nꁙountpoint-cache ha󴐺X,«*¹ÑÉ¥•Íé@1024 (oräY.'  E‚ʲåѕͥ     6
    [    0.133428] mô““)úÁ¥½b0000600.gpio: òYVkѕɥ¹f2 gpios•Íé@0xffffffff, mἕ‘±•}¹Íé@19112604462750°˜˜[®Hø[    °®±°¦‚êáinctrl core: é·Z¯­,+K•‘àin‹
    [    0.138966] mt762±uÁ¥½c0000600.gpio: regi³ºY®–ëš’:Á¥½Í5[    0®±´´´°˜W¤‹Ýi21_gpio 10000¶°°®ç°ZK’•¥Íѕɥ¹f2 gpios
    [    0.150¹LMW¤-¦¬©‹Ýi21 10000900.i5±½­Í½Õɍ•MIPS re-start ·‹çupport                                                                                 )
    [    0.189000] UÄР´X.WJ‹«*¹ÑÉ¥•ÍéA256 (order: 0¬ ´°¹¶±^®Ö+©Hh‚rŠÊ¢²‚šj©DP-Lite èX.WJ‹«*¹ÑÉ¥•Íé 256 (order: 0, 4096 ±^¯Ö+©Hø[    0.200945§Q+ë
                                                                                                                                                            0
    [    0.2³·°²´®WWj¡™Íé@version 4®° ¨²°˜N       ŠzšŠJ‚¡¥±±¥Á˜ougher
    [    0.2´™SR™™ÍÉt version 2.2 ¨§PŠ–BšU55Ie¥@(LZMA) (RÔRSQJ$¥¨êŠRõ%•{I%Qe¥@(c) 2001-2006 Re䐤X/        ”卹                5¡•‘‚‚‚ª‚‚‚r‚ݵéAError appk
    [    0.2962´MW¤ª–++Ãé@8250/16550 driöY. E‚½ÉÑͱ@IRQ sharing äZ®–«E5[    0.3038±˜W¤¬Ëk½±•¶ttyS0] disablå²C¡+rš‚º’¢¢êc0000c00.uartlite: tô^*R¨ª*ê
    [    r’ºÊª‚‚jät2880-piní].$®•kEɱé@could not reqõY.ìò¥¥¹b8 (io18) from grï].$®W”Ë닁Ålaim for 100°M&&&       ݵ5[    0®²·³´¸NW$.—   ‚j‚¥¹µÕááinctrd
    [    0.316025] console [ttyS0] enabled
    [    0.323020] bootconsole [early0] disabled
    [    0.323020] bootconsole [early0] disabled
    [    0.331702] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2500000) is a 16550A
    [    0.341199] 10000e00.uart2: ttyS2 at MMIO 0x10000e00 (irq = 30, base_baud = 2500000) is a 16550A
    ...
    

    Was your serial communication fully perfect?



  • @György-Farkas Looks like a serial baud rate mismatch. The default setting for the Omega is 115,200. Check the Serial setting in Putty or your terminal program to be sure it is set to the same speed.



  • @Ken-Conrad said in Omega2+ unreachable when Wifi shut down:

    @György-Farkas Looks like a serial baud rate mismatch. The default setting for the Omega is 115,200. Check the Serial setting in Putty or your terminal program to be sure it is set to the same speed.

    Not really. The baud rate is correct in the sense of high level settings, or it wouldn't be "mostly" working. If it is a baud rate problem, it's a problem in the behind-the-scenes divider settings used to achieve the desired baud rate, or the clock source - of one device or the other. Devices with slightly wrong baud rates may work fine, until they encounter a device with a baud rate that is slightly wrong in the other direction. But if the baud rate were wrong enough to be a different user-level setting like 57600 or 115200, you wouldn't see any correct characters at all.

    But it also could be electrical noise - I've seen this type of issue more often with long cables, including long power cables where some of the supply ground current may actually end up flowing in the serial cable's ground.

    Or (less likely with the observed patterns, but still possible) it could be a buffer servicing problem - software on one end or the other not dealing with things in time.



  • @Chris-Stratton - Although it sounds like you disagreed, I think we agree that a mismatched baud rate setting in the communication program can cause this problem. Yes, it happens most often at lower speeds that are close but not the same. Yes, György Farkas's data does show that the hardware link is working, the UART is working, there is evidence of transmitting and receiving, etc, all true, but little comfort when he wants a readable command line. Checking Puttys' baud rate setting is easily done and in my experience, most often the cause of this garbage data.

    Another possible cause for this problem is a miss setting in the Operating system for the serial port, which should be the same as the device's settings - Baud rate - 115,200, data bits- 8, parity - 8, stop bits - 1, and flow control - None.

    I appreciate your explanation for other causes for the garbage data. Thankfully, in normal practice those are far less common.



  • No, again, user level baud rate and line settings cannot cause this problem.

    What could would be having a serial device that when commanded to 115200 produced due to implementation issues perhaps 105000 instead; but that's only something that can be fixed in the hardware or driver software, not by changing a user setting (user baud rate setting are not actual numbers that can be fine tuned, they are enumerations from a limited set of defined choices)



  • @Chris-Stratton - Ok, we disagreed. Rather than trying to parse out if I misspoke or used some word or term that you disagree with, lets try to help György Farkas use the command line.

    I looked again at his data. It isn't all consistently garbage, so perhaps it is a problem in flaky wiring or UART. I would ask if the same RP serial port, connection is reliable with other serial connections.



  • It seems I was not precise enough. ;-)

    Omega2+ v0.1.9-b150 without Dock

    Raspberry Pi 2 Model B V1.1
    up-to-date Raspbian Jessie
    minicom version 2.7 (compiled Jan 12 2014)
    minicom -b 115200 -o -D /dev/ttyAMA0

    3.3V logic level direct connection
    Omega_RX0---RPi_TXD0, Omega_TX0---RPi_RXD0, GND---GND

    Only from the start to the 'bootconsole [early0] disabled' lines I got this:

    
    BusyBox v1.25.1 () built-in shell (ash)
    
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
     -----------------------------------------------------
       Ω-ware: 0.1.9 b150
     -----------------------------------------------------
    root@Omega-5BE1:/# reboot
    root@Omega-5BE1:/# [  135.015295] br-wlan: port 2(ra0) entered disabled state
    [  135.020744] br-wlan: port 1(eth0.1) entered disabled state
    [  135.039429] device eth0.1 left promiscuous mode
    [  135.044041] device eth0 left promiscuous mode
    [  135.048560] br-wlan: port 1(eth0.1) entered disabled state
    [  135.069356] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
    [  135.087561] device ra0 left promiscuous mode
    [  135.092079] br-wlan: port 2(ra0) entered disabled state
    [  135.287781] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [  139.372738] Removing MTD device #6 (rootfs_data) with use count 1
    [  139.404146] reboot: Restarting system
    
    
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/"
    
    Board: Onion Omega2 APSoC DRAM:  128 MB
    relocate_code Pointer at: 87f60000
    ******************ª•••%%%%%%%¥!hõ™ÑÝ
    ɕŠystem Reset Occµ¹¹Y-¡HIIIIIIIIIIII‰RRRRRRRRRRRRRRRÒ)5™±
    Í¡manufacture id: ã²¬ €YWkUÕd 20 19
    find ³¶X.•jaÉjL25635E
    *** Warning - bad ƒ©(	UÍ¥¹Èefault environ­Y‹)
    =================œOOOOOOOOOOOOOOOÏÏÏÏϏêêêR5=¹¥œ¹žmega2 UBoot VerséËK¢ršr‚ršR4µµY---------­KKKKKKKKKKKKKKKË©©©©©©©©©©©©©©	€Ôš%m628_MP šÐïòŽM§Érœ¹•¥DRAM compïîåîôºL&&šJ—Ñ́ˆDR, width 16
    DRAM bõ.'R“J+‹)Total memory: ±™œSšWÖKšÈÅ
    Í¡Æomponent: SPI Flash
    ¢X¯–zÑb8 2016  Time:17º™N'S“ššêêêêêêêêêêêêêêêõõõz===========œOOOOOOOOOOOO$¡(k¡•é@sets:512, ÷áù󺎖¶Z«5ééf2 ,total:6µM&“šˆ5
    ¡•é@sets:256, waù.'	Å¥¹•Íééf2 ,total:327¶œ
    C(RÊK•Å} 575 MHZ
    EóºZ[X¯ª«ÓœÉåæize = 128 S¬WÖKšHU͕ÑÑ¥¹MT7628 PHY.
    Initializing ͪ“Â:A%=æystem.
    
    
    *ª•••%%%%%%%%%%%%%%%%%%%%¥IIIIIIIIIIIIšH	„õ±‘¥eset button fïò íï²Y€Ñ¥œ¹ÍT
    *******ª•••J%%%%%%%%%%%¥IIIIIIIIIIIIIIšÈÔ€ÔRjœœÑ˜inux from Flash NO RŪ	%UšM¹## Booting é[XV)‹Äc050000 ...
       É[XVÉ*Օé@  MIPS LEDE Li®]®‰r¢r¢’R4AImage Type: SRª**˫ၕernel Éíáç堔¶œ[X ¬«É•Í͕‘¥   Data Size:  L&–ÓŠåѕ́z  1.2 MBŠC$$$ê+E‚ddress: 8000000°
    C$$€”‹É偠oint:  800000°˜
    à   Verifying ƒŽY¬­®WárrþOK
       Uncoíž¹Y®®•ëZ•É¹•±’mage ... OK
    No iniŽ¹²
    C€$•+Ëk™•ÉÉ¥¹Çontrol to Liîõø š¡ºX,–«ḱp0000000) ®——
    C€$ÔTË¥¹Øinux memsiúY€-Õ%ÅŠ’ÂR5)5§tarting ëY.«Ç]..
    
    [    0.000000] Linux »Y®®ÖËEr¢r¢’B’œœÑÉd72a3272872) (gc㐻Y®®ÕËQr¢r‚BbŽCC 5.4.0 r3009-9¶œ³XMŠR	1‚jœ¹”an 16 19ºš˜L%$&RÓSHh‚r‚‚‚‚ÁÁu„oard has D„©™C¡+r‚‚‚‚‚‚ê
    nalog PMU set ôï è·¬Ë‹Éœ±5[    0.000°˜˜W$Të•Ñ
    ± MU set to hw ¬Ë‹Éœ±5[    0.000000] Sï(UÁ•éAMediaTek MT7688 v幝L€ÖêK’j(mA  0.000000] ±ë‹œ¹Íœ±•¶early0] enab¬Y­Hh‚r‚‚‚‚‚‚ê
    PU0 revision is: °°˜LNSS©*
    5’¢Z¥
       0.000000] Rª*'R+5¡¥¹•is Onioî Ïíå§XŠ¥Hø[    0.00000°W$TW–µ¥¹•‘àhysical RAM [X.§Hh‚r‚‚‚‚‚‚êAmemory: 08000000  ˜LLL&&&©Í
    ‰±•¥
       0.0°°°°°R+‹É‘Ùot found or åíðô¹K$Vk
    ‰±¥¹initrd
    [    0.00000°W$«Ë«’
    ¹•Íé
    [    0.00°˜˜˜W$$$êKµ
    ±@ [mem 0x00°˜˜˜LLL&&&«	ÂÁa00000007ffffff]
    [   ˜—LLL&&ŠjœÙ
    ‰±•õone start for each ·‹U5[    0.000000] Åáò칐[Y[KåÙode rangesŠÛ    ˜—LLL&Šrœ‘•@ 0: [mem 0x0000°˜˜˜LLL&&&S	ÂÁ`00000007fæ³³³YWC¡+	r‚‚‚‚‚‚ꁒnitmem setup noäY$&€««Õ`x00000000000000°˜K&/&‚‚‚º2™™™™™u5[    0.000000] Pri­X®RËkÑÉՍѥœ¹Æache 64k‚–«R,	Ajº
    å±Alineséúå ³²±^®ÖË©Hh‚r‚‚‚‚‚‚j¡rimary dáºX€¬Ô«š’Z	±@4-way, PIPԖ·±¥
    ͕ͱ@linesize 32 ±^¯Ö«Hø[    0.000°°°Ý ‚]Z-(Òœ¹•±¥ÍÑ́Òn Zone order, mï±Z­-WÍrouping on.  Tota쐞XVÖKš’ªŠ’j)mA  0.000000] Kernel cï[[X‹b¥¹•é@console=ttyS0¬LLM&’ç닙ÍÑåÁ•usquashfs,jffs2
    [    0.0°˜˜˜LW ª)	+5¡éable åîôò©Y.'RSIBzɑ•ÉéA-1, ²°Žž ¢^®Ö+©Hø[    0.0000°˜W$T–‹ÉåÆache hash tabl¥Y‹É¥•Íé@16384 (order: 4¬M&H+ѕͥ
    [    0.000000] Inode­¬Ö«B
    Í¡èable entries: œLN&éK‘•Éé@3, 32768 bùô¥®UHø[    0.000000] WriŽZë*ÉÉѱäegister=00000°˜œC¡+
    r‚‚‚‚‚‚ꁡeadback ErrCtì òåç©.W–«‚‚‚‚‚‚‚Âj)ÿ[    0.000000] MeíKåéA125552K/131072K avaiìX,«Bš‚Š’ZÕernel code, ±šŠ)’×VŠ
    ±@724K rodata, ²˜œ)RË+‹±@196K bss, µµ²°Ë ¹Y®–Ë•‘±@0K cma-resåò»Y­¥Hx+r‚‚‚‚‚‚ꁧLUB: HWalign=32, Oò²Y®‚jšbj¥¹=‰©•ÑÍõa, CPUs=1, Nodes=1
    +r‚‚‚‚‚‚ꁝR_IÒÑÓº²µá[    0.000000] intcº]®–ë’•¥ÍѕɁÚap from €YWkUÑɕ•5[    0.000000] CPU ök·éA580MHz
    [    0.000000] ,ëkµÍœÕɍ•}ÁÉœ‰•i no matching clocksoµ¹¬ÖÉ뫹‘5[    0.0°°°°°,ëkµÍœÕɍ•é MIPS: íX®-'™™™™™™™™Úax_cycle󝐘^–––––––	Õ
    á}¥‘±•}¹Íé@6590553264 î®Hh‚ò‚‚‚‚ÊÉuçched_clock: 32 bits X/$ŠS
    J±@resolution 3ns¬—+́Ívery 7405115902ns
    [    0.0°S“iꁇalibrating delay lï¹]. 385.84 BogoMIPS (lpêOLNŠ—S“S©Hh‚r‚º‚‚šÊjáid_max: defá]-—š’º²Âj¥¹¥µÕµi 301
    [    0.074¶³¹Ý «¹ÑµÆache hash tablåY‹É¥•Íé@1024 (order: 0, š˜NJ+ѕͥ
    [    0.08097¹W€ê«¹ÑÁœ¥¹ÑµÆache hash tᱶY€–‹É¥•Íé@1024 (order: ˜–MLNH+ѕͥ
    [    0.094335] cloã­®«É•é@jiffies: mask: 0ø³³³Y–––ª+
    }å±•Íé 0xffffffff, max_iä¶YåÍéA19112604462750000 î®Hø[    0.103980] pinctò¶¬K•éAinitialized pinctò¶®—jåÍѕµ5[    0.109720ݐ§Q+'UÖVkѕɕ‘àrotocol family 16
    [    0.133Ž™œW€‹Ým21_gpio 10000600.çžZK’•¥Íѕɥ¹f2 gpios
    [    0.138966] [¯““)úÁ¥œb0000600.gpioº¹YVkѕɥ¹f2 gpios
    [    0.144400] mt7¶™LuÁ¥œb0000600.gpio: re§Z.W–+Ë뚒:Á¥œÍ5[    ˜—LMŠ§ŠSJÉÅ-mt7621 1000°N&&)Ké@clock 100KHz, re­.WKсÝot support
    [    0.158442] cloã­®«É•é@Switched to cloc뮫ɍ•PS
    [    °®±¶ŽœLMW$ªE¥’•¥Íѕɕ‘àrotocol famé¶^$ŠHø[    0.169921] TCP eóºX,+k¡•‘Ðash table entréY.'R“‹Bzɑ•Éé@0, 4096 â^¯Ö+©Hh‚rŠº²²Š’ꁚCP bind hash taâ¶Y€–‹É¥•Íé@1024 (order: °–šLNH+ѕͥ
    [    °®±ž²·NS¢AéAHash tables ãïîæ©V—«‹‰*ÍÑ
    ‰±¥Í¡•‘ 1024 bind 1024©Cá[    0.188999] Õ¢šZX.WJ‹«*¹ÑÉ¥•Íé@256 (order: 0, Ž˜NI+ѕͥ
    [    0.194602ݐU)ª‰*‹•Ðash table entréY.'’S“éK‘•Éé@0, 4096 b¹ºY®RHø[    0.200¹ššW$ªD¥’•¥Íѕɕ‘protocol family 1Š[    0.210689] futex ŽX.WJ‹«*¹ÑÉ¥•Íé 256 (order: -1, 30·™±^¯Ö+©Hø[    0.2166³NW€(®Ô‹ëë
    ±±œ
    ѕ‘€AM at address 0ø&	‚‚‚j)ÿ[    0.23702ŽÝ óñµX.–ÖK²•ÉÍ¥œ¹4.0 (2009/01/31) PèZ-+™ougher
    [    0.24267·W$-–ÖKÒ²•ÉÍ¥œ¹d.2 (NAND) (SUMMARY) šŠ­SPJ$%*Uªª•B5=}AI%=I%Qe¥@(c) 2001-2006 Red Haô–Rkåj*ÿ[    0.254844] io s£ŽY­«%Ùoop registeòå䍊[    0.258644] Z5¡•‘Õ±•ÉÈeadline regé.W–«‹„"•™
    ձѥ
    [    0.264408] ²º™œNLK¬-««ááinctrlº ðéî Z+Â
    ±É•
    ‘årequest岐±^$®-kCɱíAcannot clai퐳Ka0005000.pwm
    [    0.273490] rt288°K®-««áàinctrl: pin-18 (±˜˜˜M$&&	ݵ¥@status -22
    HLIºÊª‚Šêåt2880-piníµŒžZkEɱé@could not òåñõ¥.
    ¥¹c8 (io18) fro퐖ë«Ááwm0  on device rt²œœ˜K®-««á5[    0.288904ݐ[¯­	ݵb0005000.pwm: EròKÃpplying óY/WËëÅ’•Ù•É͕èhings baã­Hø[    0.²¹¶²Ž¶W€ª–++Åé@8250/16550 äòéö¥¹–MH\KÑͱ@IRQ sharé·‰+k
    ‰±•‘5[    0.303811] ãËkœ±•·ttyS0] disabled
    ېHLi‚º’¢¢êb0000c00.uaòº¶Z¯–¢ÑåMÁ@at MMIO 0x10°˜˜,)KŁz 28, base_âáõ€O$Š	‚‚‚JJ́Á 165µ°ÁŠ[    0.316025] console [ttyS0] enabled
    [    0.316025] console [ttyS0] enabled
    [    0.323020] bootconsole [early0] disabled
    [    0.323020] bootconsole [early0] disabled
    
    

    instead of this:

    
    BusyBox v1.25.1 () built-in shell (ash)
    
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
     -----------------------------------------------------
       Ω-ware: 0.1.9 b150
     -----------------------------------------------------
    root@Omega-5BE1:/# reboot
    root@Omega-5BE1:/# [   77.894509] br-wlan: port 2(ra0) entered disabled state
    [   77.899957] br-wlan: port 1(eth0.1) entered disabled state
    [   77.918568] device eth0.1 left promiscuous mode
    [   77.923282] device eth0 left promiscuous mode
    [   77.927812] br-wlan: port 1(eth0.1) entered disabled state
    [   77.949699] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
    [   77.970409] device ra0 left promiscuous mode
    [   77.974933] br-wlan: port 2(ra0) entered disabled state
    [   78.169603] !!! APCLI LINK DOWN - IF(apcli0)!!!
    [   82.254834] Removing MTD device #6 (rootfs_data) with use count 1
    [   82.286182] reboot: Restarting system
    
    
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/"
    
    Board: Onion Omega2 APSoC DRAM:  128 MB
    relocate_code Pointer at: 87f60000
    ******************************
    Software System Reset Occurred
    ******************************
    flash manufacture id: c2, device id 20 19
    find flash: MX25L25635E
    *** Warning - bad CRC, using default environment
    
    ============================================
    Onion Omega2 UBoot Version: 4.3.0.3
    --------------------------------------------
    ASIC 7628_MP (Port5<->None)
    DRAM component: 1024 Mbits DDR, width 16
    DRAM bus: 16 bit
    Total memory: 128 MBytes
    Flash component: SPI Flash
    Date:Oct 18 2016  Time:17:29:05
    ============================================
    icache: sets:512, ways:4, linesz:32 ,total:65536
    dcache: sets:256, ways:4, linesz:32 ,total:32768
    CPU freq = 575 MHZ
    Estimated memory size = 128 Mbytes
    Resetting MT7628 PHY.
    Initializing MT7688 GPIO system.
    
    
    **************************************
    * Hold Reset button for more options *
    **************************************
    
    
    
    Boot Linux from Flash NO RESET PRESSED.
    ## Booting image at bc050000 ...
       Image Name:   MIPS LEDE Linux-4.4.42
       Image Type:   MIPS Linux Kernel Image (lzma compressed)
       Data Size:    1306381 Bytes =  1.2 MB
       Load Address: 80000000
       Entry Point:  80000000
       Verifying Checksum ... OK
       Uncompressing Kernel Image ... OK
    No initrd
    ## Transferring control to Linux (at address 80000000) ...
    ## Giving linux memsize in MB, 128
    
    Starting kernel ...
    
    [    0.000000] Linux version 4.4.42 (root@2272a3272872) (gcc version 5.4.0 (LEDE GCC 5.4.0 r3009-968fa53) ) #0 Mon Jan 16 19:40:14 2017
    [    0.000000] Board has DDR2
    [    0.000000] Analog PMU set to hw control
    [    0.000000] Digital PMU set to hw control
    [    0.000000] SoC Type: MediaTek MT7688 ver:1 eco:2
    [    0.000000] bootconsole [early0] enabled
    [    0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
    [    0.000000] MIPS: machine is Onion Omega2+
    [    0.000000] Determined physical RAM map:
    [    0.000000]  memory: 08000000 @ 00000000 (usable)
    [    0.000000] Initrd not found or empty - disabling initrd
    [    0.000000] Zone ranges:
    [    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
    [    0.000000] Movable zone start for each node
    [    0.000000] Early memory node ranges
    [    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
    [    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
    [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
    [    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
    [    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
    [    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
    [    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
    [    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
    [    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
    [    0.000000] Writing ErrCtl register=0003f4c0
    [    0.000000] Readback ErrCtl register=0003f4c0
    [    0.000000] Memory: 125552K/131072K available (3012K kernel code, 143K rwdata, 724K rodata, 208K init, 196K bss, 5520K reserved, 0K cma-reserved)
    [    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
    [    0.000000] NR_IRQS:256
    [    0.000000] intc: using register map from devicetree
    [    0.000000] CPU Clock: 580MHz
    [    0.000000] clocksource_probe: no matching clocksources found
    [    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
    [    0.000012] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
    [    0.007522] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
    [    0.070038] pid_max: default: 32768 minimum: 301
    [    0.074639] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.080978] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.094334] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
    [    0.103980] pinctrl core: initialized pinctrl subsystem
    [    0.109719] NET: Registered protocol family 16
    [    0.133428] mt7621_gpio 10000600.gpio: registering 32 gpios
    [    0.138966] mt7621_gpio 10000600.gpio: registering 32 gpios
    [    0.144400] mt7621_gpio 10000600.gpio: registering 32 gpios
    [    0.150915] i2c-mt7621 10000900.i2c: clock 100KHz, re-start not support
    [    0.158442] clocksource: Switched to clocksource MIPS
    [    0.164815] NET: Registered protocol family 2
    [    0.169920] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.176612] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
    [    0.182796] TCP: Hash tables configured (established 1024 bind 1024)
    [    0.188999] UDP hash table entries: 256 (order: 0, 4096 bytes)
    [    0.194602] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
    [    0.200944] NET: Registered protocol family 1
    [    0.210688] futex hash table entries: 256 (order: -1, 3072 bytes)
    [    0.216639] Crashlog allocated RAM at address 0x3f00000
    [    0.237022] squashfs: version 4.0 (2009/01/31) Phillip Lougher
    [    0.242675] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
    [    0.254842] io scheduler noop registered
    [    0.258642] io scheduler deadline registered (default)
    [    0.264407] rt2880-pinmux pinctrl: pin io18 already requested by pinctrl; cannot claim for 10005000.pwm
    [    0.273488] rt2880-pinmux pinctrl: pin-18 (10005000.pwm) status -22
    [    0.279500] rt2880-pinmux pinctrl: could not request pin 18 (io18) from group pwm0  on device rt2880-pinmux
    [    0.288902] mtk-pwm 10005000.pwm: Error applying setting, reverse things back
    [    0.296244] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
    [    0.303809] console [ttyS0] disabled
    [    0.307242] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
    [    0.316022] console [ttyS0] enabled
    [    0.316022] console [ttyS0] enabled
    [    0.323017] bootconsole [early0] disabled
    [    0.323017] bootconsole [early0] disabled
    
    

    I was wondering I am the only one or not, so I asked dgluhak4 what was his/her experience with the same serial connection.
    BTW I have a quite solid, error-free serial communication / console via MAX3232.

    Thank you to all.



  • Only from the start to the 'bootconsole [early0] disabled' lines I got this:

    That suggests that the issue is with U-Boot's configuration of the UART, rather than the configuration Linux eventually establishes when it starts using the serial port in the way it will when fully booted.

    As I've said before, slight innacuracy serial baud rate may be the issue, especially if it shows up with some things on the other end of the serial cable and not others. There are various ways of configuring baud rate generation in the MT7688 UART, some of which will give more accurate results than others.

    Other suspects include loose connections, or power situations where some of the supply return current is flowing through the serial connection's ground, introducing a voltage drop there and thus difference in effective ground levels. The observed early vs. ultimate console difference would seemingly point away from that possibility, but then power consumption is different at different points during boot.



Looks like your connection to Community was lost, please wait while we try to reconnect.