We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Ethernet Expansion Config



  • Can anyone point me in the right direction on configuring the Ethernet expansion?

    Thanks



  • Did you try udhcpc -i eth0 ?

    I don't have the expansion, but the device is showing up, so I assume you just need to plug it in for it to work.
    For network config in general look at the config file /etc/config/network



  • Hi @Mason-McElroy, you don't need to configure the Ethernet Expansion. You just need to edit the /etc/config/network to enable it. Can you paste the content of /etc/config/network here? We can teach you how to edit it.



  • Hi @Boken-Lin ... I was wondering the same about the ethernet expansion. Here are the contents of /etc/config/network:

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'
    
    #config globals 'globals'
    #   option ula_prefix 'fd28:1f13:5b38::/48'
    
    #config interface 'lan'
    #   option ifname 'eth0'
    #   option type 'bridge'
    #  option proto 'static'
    #   option ipaddr '192.168.3.1'
    #   option netmask '255.255.255.0'
    #   option ip6assign '60'
    
    #config interface 'wan'
    #   option ifname 'eth0'
    #   option proto 'dhcp'
    
    #config interface 'wan6'
    #   option ifname '@wan'
    #   option proto 'dhcpv6'
    
     #config switch
     #   option name 'switch0'
     #   option reset '1'
     #   option enable_vlan '1'
    
    #   config switch_vlan
    #   option device 'switch0'
    #   option vlan '1'
    #   option ports '0 1 3'
    
        config interface 'wwan'
        option proto 'dhcp'
        option hostname 'OnionOmega'
    
        config interface 'wlan'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
    
    
     #config interface 'wlan'
     #   option ifname 'wlan0-1 wlan0'
     #   option type 'bridge'
     #   option proto 'static'
    
     #   option ipaddr '192.168.3.1'
     #   option netmask '255.255.255.0'
     #   option ip6assign '60'


  • @Nayan You simply need to uncomment the following lines:

    #config interface 'lan'
    #   option ifname 'eth0'
    #   option type 'bridge'
    #  option proto 'static'
    #   option ipaddr '192.168.3.1'
    #   option netmask '255.255.255.0'
    #   option ip6assign '60'
    

    then you need to restart the network service with the following command:

    /etc/init.d/network restart
    


  • Thanks @Boken-Lin ... Also looking forward to your tutorial on using the Omega as a router/extender



  • @Nayan Yup, that's almost done. Just need a little bit more time before we post it on the Wiki.



  • @Boken-Lin
    Thanks. I looked at the network config before, but somehow I completely missed that commented out section....


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.