omega2+ flash omega2p-v0.1.10-b162.bin - break



  • @Przemyslaw-Downar

    Thanks!!! Working again. Will wait until they fix the latest firmware now.



  • I'm really new in this. Just got the omega2+, updated to the latest firmware and it stopped working. How can I get the serial console running with Power Dock?

    This is so disappointing. How could they release a firmware that makes the hardware unusable. I want my money back!!



  • @Artur-Grabowski

    Starting from 1$ you can buy one of these USB to serial CP2102 adapters, always comes in handy having one in the drawer.

    Anyway, without any way to use a keyboard with the omega, I don't see any solution. See this.

    Also, every firmware upgrade has its risks. Even on production routers where OpenWRT is mostly used, you can end with an ugly paperweight. Every solution for this uses in some point a serial to USB adapter, even having to weld some pins.

    Also try this to reset the omega2. Even try to add the firmware file named omega2p.bin in a FAT32 pendrive and connect to the omega2 while pressing the reset button. It needs a serial connection to choose option 2 from uboot, but trying is better than nothing.



  • Thanks for replying!
    Mine is dead too...
    This is really bad!!

    To the "onion people" read the forums!? That firmware should have been pulled!
    Ny hardware is now unusable until I find a usb to serial adapter of some sorts...

    :angry: :PISSED OFF:



  • I can confirm that b162 is not working and had to connect thru serial to fix it. Also Console-Base has been updated to 0.3.1 and there is no Terminal or Editor working.



  • b163 is not working either. Keeps wanting to reboot.



  • @Paul-Kourany it's always useful to post the kernel panic log to help debugging. If you have serial connection, open an issue with all the info you can.



  • FWIW, I tried b163 and also get constant reboot.

    Attached is the serial output from the manual firmware upgrade process and subsequent restart as requested.

    0_1489031869386_Omega2p_b163_maunal_install_COM3_20170309_145254.txt



  • I recently bricked my Omega2+ flashing the same firmware as well. Sigh. Gotta wait like a month for the CP2102 adapter to arrive then, I guess. I hope there's a working firmware by then :)



  • Also came back after a few weeks and bricked mine. Wish I'd read the forums first :D I guess I'd hoped the issues with the Omega2+ would be over and done with after ~4 months of grappling with it. I clearly guessed wrong =/

    I figured "fine, I'll recover it back to an old firmware." Or maybe not. I have an "EXP DOCK" with pinout silk for the original Omega, but noticed the USB pins are the same. But for love nor money I can't get the Omega2+ to see any USB mass storage device. I've tried 5-6 separate devices now from microSD cards in readers, to USB thumb drives, but... nada.

    Just attempt after attempt resulting in:

           Scanning bus for storage devices...
    
    =================================================
    1: Hub,  USB Revision 0.2
     - u-boot EHCI Host Controller
     - Class: Hub
     - PacketSize: 64  Configurations: 1
     - Vendor: 0x0000  Product 0x0000 Version 0.1
    USB_STORAGE: 0 Storage Device(s) found
    No USB Storage found. No F/W upgrade from USB Storage will be attempted.
    


  • just received 2 omega2+, both wont boot.
    all with same kernel panic:
    [ 31.208771] Kernel panic - not syncing: stack-protector: Kernel stack is corrupted in: 8771d944

    tried upgrading to b159, not working: kernel panic.
    upgrading to b160. not working: kernel panic.
    upgrading to b162, not working: kernel panic.
    upgrading to b163, not working: kernel panic.



  • @Chris-H got a solution?



  • @Tiago-Couto said in omega2+ flash omega2p-v0.1.10-b162.bin - break:

    just received 2 omega2+, both wont boot.
    all with same kernel panic:
    [ 31.208771] Kernel panic - not syncing: stack-protector: Kernel stack is corrupted in: 8771d944

    tried upgrading to b159, not working: kernel panic.
    upgrading to b160. not working: kernel panic.
    upgrading to b162, not working: kernel panic.
    upgrading to b163, not working: kernel panic.

    Most likely you did not successfully load b159, or at least not the correct version for your board.



  • @Chris-Stratton im pretty sure it loaded right...
    http://repo.onion.io/omega2/images/omega2p-v0.1.9-b157.bin
    here is the log (now trying with b157): 0_1490201328023_screenlog.0



  • @Tiago-Couto I looked over your log file. Your kernel panic is happening ~31 seconds, just as the Wifi is turning on - this is at the time of the Omega's highest power load. How are you powering the Omega2+, ie what is your power source and how is the Omega2+ wired to the source?


Log in to reply