openvpn-openssl_2.4.0-3 - Kernel Panic



  • Hi Everyone

    I am looking for a little assistance with my updated Omega2+.

    I am able to install openvpn-openssl from http://downloads.lede-project.org/snapshots/packages/mipsel_24kc/base/ after uncommenting the distfeeds.conf file. It only allowed me to install it after using the --force-depends command as there is a kernel mismatch (clue here I think!)

    It appears to install fine albeit with the kernel mismatch error, however when it connects to the VPN server I get an instant kernel panic caused by Openvpn.

    The ovpn profile I am using has autologin, the profile has been tested on Android and Windows.

    Has anyone managed to get Openvpn client working on the Omega2+ yet? Are there any suggestions on how I can get this working?

    If there is any additional information I can provide then please let me know.
    Many Thanks
    Freddy



  • From my other post you can see it's not the only package with problems due to kernel mismatch.
    Using --force-* is not usually a good idea if you want things to work. I think openssl works fine until you use VPN because the VPN must interact with the IP stack and that is kernel stuff.

    Right now I see 3 options:

    • Find a package compiled for the kernel version the Omega2 firmware uses (uname -ra I think).
    • Compile your own firmware using the LEDE SDK (in my signature there is a Docker project for that, or you can use @WereCatf 's github source repository with a script that automates everything). Problem with this option, the wifi is shit without the onion ralink driver, and it, of course, kernel panics in custom firmwares with most recent kernel. Note too that I did not try enough compiling a custom firmware with lower kernel version, and that should be the way to go.
    • Wait until onion releases their SDK configuration and then everybody should be able to build a custom decent firmware with all their needs.


  • Hi Jose

    Thanks for taking the time to reply.

    I have identified that the omega2p-v0.1.10-b160.bin version of the firmware contains kernel 4.4.46
    On the LEDE-Project website for supported hardware, it states that the Omega2+ is supported on LEDE 17.01 which has kernel 4.4.50.
    https://lede-project.org/toh/start?dataflt[Brand*~]=onion

    There were a number of issues fixed for openvpn / openssl for the 4.4.50 kernels.
    https://lede-project.org/releases/17.01/notes-17.01.0

    I am not sure why b160 is still using 4.4.46 while the supported version of LEDE contains 4.4.50.
    The openvpn-openssl package is based on a snapshot of kernel 4.4.50.
    https://lede-project.org/packages/start?dataflt[Name_pkg-page*~]=openvpn-openssl

    I am going to wait in the hope that the kernel is brought up to version 4.4.50 and then the install may be successful.
    As an aside, there is a SDK package available for LEDE 17.01.
    https://downloads.lede-project.org/releases/17.01.0/targets/ramips/mt7688/

    Cheers
    Freddy


Log in to reply