Omega2+ wifi setup problems on multiple fresh-from-the-box devices (Mikrotik)



  • I have a few Omega 1s that work just fine on my network, but each Omega2+ that i've tried absolutely will not connect (I've tried three now, one of which just arrived in the mail yesterday). Going through the initial setup i'm able to connect as a client of the device, but on the networking section of the web interface it will either hang up right off the bat or actually list ssids and then hangs up when trying to connect.

    SSHing in 192.168.3.1 to try wifisetup yields the same results. I had hoped it was a firmware issue, but scp-ing over 0.1.9 b159 and flashing with -n didn't change anything.

    I've tried to connect to three different routers, each a mikrotik running routeros. Is there a known issue with these routers? I've checked and they are not using TKIP.

    Does anyone have any suggestions? I would love for these to work, they are incredible devices, but I'm totally out of ideas here.

    Thank you in advance!
    Travis

    Edit:
    Just tried with a freshly-reset d-link, no security, no password, both wifisetup and web client, still no dice. "Unable to connect to dlink. Please try again."

    Edit2:
    I am able to get an IP address and ping the internet when using the ethernet expansion.

    Edit3:
    Here's my /etc/config/wireless

    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode '9'
    	option channel 'auto'
    	option txpower '100'
    	option ht '20'
    	option country 'US'
    	option disabled '0'
    
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option encryption 'psk2'
    	option key '12345678'
    	option ApCliEncrypType 'AES'
    	option ssid 'Omega-2C11'
    	option ApCliEnable '1'
    	option ApCliSsid 'MySSID'
    	option ApCliPassWord '******'
    	option ApCliAuthMode 'WPA2PSK'
    
    config wifi-config
    	option ssid 'MySSID'
    	option encryption 'WPA2PSK'
    	option key '******'
    
    

    and /etc/config/network

    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option ifname 'eth0.1'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option proto 'dhcp'
    
    


  • Hey Travis,

    I hope you good.

    I had the same issue with network which pissed me off like for 5 hrs of trying. then i decided to try reset my router to default settings. i only changed my ssid name and put the network security to open.
    then tried login in from the onion setup and it recognised my wifi network then afterwards i changed my security of my wifi and everything worked smoothly.



  • Eek, I have a massive custom configuration on my 'tik and there's no way I'm restoring factory settings.

    Any other suggestions?



  • Does seem to be something from the Mikrotik side, I can connect to my phone hotspot just fine. Trying to work through the Mikrotik settings to see which one it is.



  • you can try setting up guest with very basic security