boot loop

  • Nothing, Actually I try many combination. Not any work now.

    1. Omega + Dock + Relay Module (only 1st day work)
    2. Omega + Dock + Relay Module + 8G USB storage (Ext4)
    3. Omega + Dock
    4. Omega + Mini Dock

  • @Hong-Chen Have you tried to install opkg on a USB drive? Sometimes, if that's not done properly it will lead to a boot loop. If nothing else works the only way to fix it might be to re-flash the firmware using Ethernet expansion. If you don't have an ethernet expansion, might want to try building your own ethernet expansion, which is outlined in this post:

  • Yes, I follow the links tried to Using-USB-Storage-as-Rootfs but can't mount and not continue,
    because I try to plug USB storage in but nothing happen. not found any under /dev/sd*

    I don't have an ethernet expansion, neither 2nd Omega.
    I do have Raspberry Pi B, if it help building my own ethernet expansion...

  • @Hong-Chen The technique should work even if you don't have a second Omega. Please take a look at this post: This is connecting from Omega to another computer.

    For the USB extroot setup, i'm not really sure why your USB storage device isn't detected. Once you debrick the Omega, we will work together to find out if we can resolve that problem.

    Please let me know if you need any help with re-flashing the Omega using what's outlined in that tutorial.


  • Thank you so mach.
    I just order breadboard and jumper... kit, I will let you know once debrick the Omega.

  • @Hong-Chen No problem! Good luck!

  • I try building my own Ethernet expansion, it look good, PC LAN port LED start blinking.
    but httpd command not work, I try reconnect the Ethernet cable and try again. It still same.
    any way I can make sure the connect ?

    Omega> httpd
    Link down: eth0
    Link down: eth1
    Link down: eth0
    Link down: eth1
    Link down: eth0
    Link down: eth1
    Link down: eth0
    Link down: eth1
    Link down: eth0
    Link down: eth1
    Link down: eth0
    Link down: eth1
    Link down: eth0
    Link down: eth1
    Link down: eth0
    Link down: eth1
    Link down: eth0
    Link down: eth1
    Link down: eth0
    Link down: eth1
    ## Error: couldn't initialize eth (cable disconnected?)!



  • Hi @Hong-Chen TX+ needs to be twisted with TX-, and RX+ with RX- (they are twisted pairs). You twist them together like the following picture:

    And you also need to separate TX+TX- with RX+RX- (right now they are stuck together). After this is done, disconnect the wifi on your computer and try again.

    Twisted Pairs


  • I try it, still can't start httpd.
    Also it is stranger, why ping self-ipaddr got

    Error: ping failed, host is not alive!

    Omega> printenv
    bootcmd=bootm 0x9F020000
    uboot_upg=if ping $serverip; then tftp $loadaddr $uboot_name && if itest.l $filesize == $uboot_size; then erase $uboot_addr +$filesize && cp.b $loadaddr $uboot_addr $filesize && echo OK!; else echo ERROR! Wrong file size!; fi; else ERROR! Server not reachable!; fi
    firmware_upg=if ping $serverip; then tftp $loadaddr $firmware_name && erase $firmware_addr +$filesize && cp.b $loadaddr $firmware_addr $filesize && echo OK!; else ERROR! Server not reachable!; fi
    Environment size: 779 bytes
    Omega> ping
    Link down: eth0
    Link down: eth1
    ## Error: ping failed, host is not alive!

  • @Hong-Chen Hmmm, why are you trying to ping from the Omega? should be the Omega itself. Can you try pinging it from your computer?

  • @Boken-Lin because I can't start httpd. so I try to find problem.
    what is "serverip=" meaning? the Omega ip?
    I set PC ip to and ping, .100, both no reach.
    than I try ping from Omega self, and found it "not alive".

    how can I make Omega work. is it any way to use USB serial to make a solution?

  • @Hong-Chen Hi Hong, I was reading over your TTL output once again, and it seems that your Omega reboots whenever it's trying to start the wifi. So it could be that the power supply you are supplying the Omega with doesn't have enough current. Can you try connecting the Omega to another power source? perhaps a powered USB hub or a phone charger? Let's see if the wifi is able to come online.

    the serverip you are trying to set is for tftp server, which isn't directly related to the httpd service that you are trying to start. Let's try this out. If it doesn't work out we'll send you an ethernet expansion so you can reflash the firmware.


  • @Boken-Lin Thank for replay.
    I was initially use a phone charger, I check the current only 30-100 mA.
    but 2nd day I can't browse and ssh into Onion and can't find it on LAN with tool "fing".
    so I trying serial connect to see what happen.
    the TTL output reboot was on the case using serial connect, it connected Notebook PC USB and OMEGA micro USB.
    Today I try use powered USB hub (HUB with 2.5A power supply ), unfortunate I still can't start httpd.
    I think if only current 30-100 mA, Notebook PC USB power is enough.

    Thanks! & Merry Christmas!

  • Hi @Hong-Chen, in that case I am not sure what the issue is. Your ethernet setup seems to be fine. We will send you an ethernet expansion so you can reflash the Omega. Is your shipping address still the same?

  • @Boken-Lin My address still the same. Thank you so mach.

  • @Boken-Lin Sorry, about how long to get "ethernet expansion"?

  • Hi @Hong-Chen,

    Sorry for the delay, I've created a shipment request for the Expansion Dock. It should get to you within 2-3 weeks.

  • @Gabriel-Ongpauco Thank you so mach.

  • @Gabriel-Ongpauco I still not get the Expansion Dock, is it still on the way?
    or any other new way to debrick the Omega?

  • Hong Chen, the award for patience goes to you 6 months and waiting!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.