Relay always on



  • Hi. I've been using the Relay Expansion to switch the pump for my garden pond on at off at an interval.
    The other week I noticed that it was on constantly. I assumed it was a software problem, but after investigating, realised that the relay still seemed to be switching on and off, but somehow the circuit is remaining closed.
    I rewired to used the other channel on the Relay Expansion and that was working fine for a week or so, but the same thing has just happened. The electricity is constantly on, even when the relay appears to be switched off.

    Has anyone experienced this before?

    Thanks,

    Jonathan



  • This is probably the inductive load of the pump that welds the relais contacts.

    There's a lot of information about that in this somewhat older thread



  • @luz Hmm, thanks. That thread seems pretty inconclusive, though. The original poster said that he hit it and it eventually started working again, which doesn't seem ideal.

    @Gabriel-Ongpauco Is the Relay Expansion faulty?



  • @Jonathan-Jefferies

    The original poster said that he hit it and it eventually started working again, which doesn't seem ideal.

    Maybe not ideal, but better than a nonworking relay. When the relay contacts are stuck together because of only a bit of micro-welding, a mechanical shock has a chance to unstick them. But of course, that's not a fix for the missing contact protection, so…

    [...] Is the Relay Expansion faulty?

    Probably not - it's just that relay contacts can't just switch any load, even when nominal voltage and current seem in range.

    If the load is not purely resistive (few are), there are always current and voltage spikes you need to take care of to protect the relay contacts. And because the needed measures depend on what you connect (AC or DC - see my attempt to explain it in that lengthy thread referenced above), that can't be part of a generic relay expansion.

    If the relay specs are far above your actual load, you usually get away without any protection. But a pump for a pond sounds more like it could be near the specs, so there's probably no wide margin left for the contacts to "swallow" spikes without damage.



  • The pump is 40w. I can't really tell from the schematic if that is within the expansion spec.

    I also haven't managed to unstick the relay.



  • i bought a relay expansion also and from my reading of the various documentation i decided that i would not run more than 1.5 amps current continuously because it looks like 2A is max. i'm guessing we have the standard relay module. IM03.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.