Omega2+ Not working out of box!



  • I have a new Omega2+ that I just connected to the main dock. I powered it up, the amber LED blinked for a while, then went solid, then turned off.

    There is No WiFi network coming up on the device, and yes I did try rebooting it a few times with the same result...

    Do I have a dead Omega2+

    -Tony



  • I entered command line mode from the USB terminal, during bootup I get this message:

    Kernel panic - not syncing: stack-protector: Kernel stack is corrupted in: 8771d944

    Now what?

    -Tony



  • @Tony-Contrada You could try flashing the latest firmware 'b160' manually by following the instructions here: Firmware Flashing from USB storage

    Alternatively, or if that doesn't work, I'd suggest opening a ticket on Onion's helpdesk which is their preferred method of providing customer support.



  • I just did the firmware update - and again, I get the same Kernel stack is corrupted!
    Must be a bad Omega2+ module... Not good, fresh out of the box!!

    -Tony



  • @Tony-Contrada Agree, sounds dodgy.
    Please let us know how you get on with the Helpdesk, or if they propose alternative solutions that end up working, so that we can assist any others with the same problem.

    The Helpdesk support is a closed loop between Onion and customer, so unfortunately from the community perspective we don't learn anything unless someone passes new knowledge gained from there back to here.



  • I submitted a ticket yesterday. I purchased from Sparkfun, not sure if they will replace it?

    I may just have to order another. :-(



  • @Tony-Contrada
    The firmware (the Wifi subsystem) of Omega2(+) has a BUG.
    If there is an AP in its neighborhood with a "bad" SSID then Omega will crash at boot time.

    For example my Omega2+:

    ...
    [   17.154192] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [   20.579238]  ch1 bssid=e8:40:f2:f7:40:15
    [   20.583238]  ch1 bssid=9c:74:1a:ea:17:cc
    [   20.587215]  ch1 bssid=34:a2:a2:a2:ac:60
    [   20.591236]  ch1 bssid=78:54:2e:10:3a:3e
    [   20.595216]  ch2 bssid=00:27:19:d8:96:34
    [   20.599196]  ch10 bssid=04:27:58:33:44:60
    [   20.603279]  ch11 bssid=32:cd:a7:bb:90:88
    [   20.607345]  ch11 bssid=e8:de:27:d5:da:88
    [   20.611421] =====================================================
    [   20.617606] Channel 1 : Dirty = 322, False CCA = 0, Busy Time = 8646, Skip Channel = FALSE
    [   20.625999] Channel 2 : Dirty = 198, False CCA = 0, Busy Time = 9562, Skip Channel = FALSE
    [   20.634394] Channel 3 : Dirty = 144, False CCA = 0, Busy Time = 5270, Skip Channel = FALSE
    [   20.642788] Channel 4 : Dirty = 124, False CCA = 0, Busy Time = 3104, Skip Channel = FALSE
    [   20.651178] Channel 5 : Dirty = 104, False CCA = 0, Busy Time = 2560, Skip Channel = FALSE
    [   20.659572] Channel 6 : Dirty = 40, False CCA = 0, Busy Time = 2037, Skip Channel = FALSE
    [   20.667862] Channel 7 : Dirty = 64, False CCA = 0, Busy Time = 7737, Skip Channel = FALSE
    [   20.676167] Channel 8 : Dirty = 76, False CCA = 0, Busy Time = 22762, Skip Channel = FALSE
    [   20.684562] Channel 9 : Dirty = 88, False CCA = 0, Busy Time = 30515, Skip Channel = FALSE
    [   20.692957] Channel 10 : Dirty = 134, False CCA = 0, Busy Time = 28978, Skip Channel = FALSE
    [   20.701528] Channel 11 : Dirty = 172, False CCA = 0, Busy Time = 3165, Skip Channel = FALSE
    [   20.710000] =====================================================
    [   20.716180] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 6 
    [   20.724919] Min Dirty = 40
    [   20.727663] ExChannel = 0 , 0
    [   20.730676] BW        = 20
    [   20.900878] device eth0.1 entered promiscuous mode
    [   20.905758] device eth0 entered promiscuous mode
    [   20.940478] br-wlan: port 1(eth0.1) entered forwarding state
    [   20.946310] br-wlan: port 1(eth0.1) entered forwarding state
    [   22.939289] br-wlan: port 1(eth0.1) entered forwarding state
    [   24.809528] Kernel panic - not syncing: stack-protector: Kernel stack is corrupted in: 8701d944
    [   24.809528] 
    [   24.823293] Rebooting in 3 seconds..
    

    which isn't actually a Reboot, it's a frozen state. (This is an Omega2+.)

    A "bad" SSID has got some non printable (Unicode) character(s), for example Chinese character(s).


    I think your issue is same. So

    • if your AP has got this "bad" SSID then modify it. A "good" (Omega2 friendly;-) SSID is not too long and contains letters of the English alphabet and numbers only.
    • if that AP is not yours then try to find a place for your Omega2(+) where the "bad" AP's signal is weak and your AP's signal is strong.

    Unfortunately these mods do not really solve this bug - but maybe help you.
    BTW another (eg. a replacement one) Omega2(+) in the same Wifi environment will produce the same issue.

    See also: Kernel panic - not syncing: stack-protector: Kernel stack is corrupted in: ... and a possible reason

    Good luck!


    @Lazar-Demin wrote earlier in this year here:

    We are working on a new implementation of the WiFi driver, will be arriving in Q3 2017! Stay tuned!

    I think the Q3 may be true but the 2017 is a typo ;-)



  • yes, that pledge by Lazar-Demin was before the news of the alarm clock which gets its time from the internet being placed on kickstarter. i would think if the new driver is done and working well to release it to omega2 would be a plus for campaign likewise if they still have problems the release would not be so good for the campaign. just speculation on my part, though.



  • I got a replacement Omerga2+ today and it seems to work fine. I'll consider the previous one as a bad device...

    Thanks



  • Unbelievable!!!
    So Onion has a solution for this BUG issue.

    @Tony-Contrada said in Omega2+ Not working out of box! 2017-12-05:

    I entered command line mode from the USB terminal, during bootup I get this message:
    Kernel panic - not syncing: stack-protector: Kernel stack is corrupted in: 8771d944

    @Tony-Contrada said in Omega2+ Not working out of box! 2017-12-07:

    I got a replacement Omerga2+ today and it seems to work fine. I'll consider the previous one as a bad device...

    Dear @Lazar-Demin please let us know what is the difference between these two Omegas.
    Firmware??? Hardware???


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.