Flash boot loader via flashrom, image doesn't match the flash chip's size



  • I'm trying to flash compiled from here https://github.com/OnionIoT/omega2-bootloader the new bootloader via flashrom.

    Flashrom recognised my spi flash
    root@pine64:~# sudo flashrom -p linux_spi:dev=/dev/spidev0.0 flashrom v0.9.9-rc1-r1942 on Linux 3.10.105-0-pine64-longsleep (aarch64) flashrom is free software, get the source code at https://flashrom.org Calibrating delay loop... OK. Found Winbond flash chip "W25Q128.V" (16384 kB, SPI) on linux_spi. No operations were specified.

    But when I try to upload uboot.bin I get an error:
    root@pine64:~# flashrom -w /home/ubuntu/uboot.bin -p linux_spi:dev=/dev/spidev0.0 flashrom v0.9.9-rc1-r1942 on Linux 3.10.105-0-pine64-longsleep (aarch64) flashrom is free software, get the source code at https://flashrom.org Calibrating delay loop... OK. Found Winbond flash chip "W25Q128.V" (16384 kB, SPI) on linux_spi. Error: Image size (173544 B) doesn't match the flash chip's size (16777216 B)!

    How to resolve it?



  • maybe go to pine64 forum and ask there?



  • @Douglas-Kryder for what? Pine is just simple dev board, ok, raspberry shows the same error, should I go to raspberry forum? I use flashrom, pine64 is connected by spi, and is used for communication only

    upd: I resized uboot.bin up to required size and flashed it without errors, tomorrow I will solder it back to omega2 and test it



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.