Fedora 26 System Setup for CC



  • Hi everyone I'm trying to do a Cross Compilation, and my current host is running a fedora 26 release, i've cloned the official repository https://github.com/OnionIoT/source.git and when i tried to
    $make menuconfig
    i get a make error:

    Checking 'working-make'... ok.
    Checking 'case-sensitive-fs'... ok.
    Checking 'proper-umask'... ok.
    Checking 'gcc'... ok.
    Checking 'working-gcc'... ok.
    Checking 'g++'... ok.
    Checking 'working-g++'... ok.
    Checking 'ncurses'... ok.
    Checking 'zlib'... ok.
    Checking 'perl-thread-queue'... ok.
    Checking 'tar'... ok.
    Checking 'find'... ok.
    Checking 'bash'... ok.
    Checking 'patch'... failed.
    Checking 'diff'... ok.
    Checking 'cp'... ok.
    Checking 'seq'... ok.
    Checking 'awk'... ok.
    Checking 'grep'... ok.
    Checking 'getopt'... ok.
    Checking 'stat'... ok.
    Checking 'unzip'... ok.
    Checking 'bzip2'... ok.
    Checking 'wget'... ok.
    Checking 'perl'... ok.
    Checking 'python'... ok.
    Checking 'git'... ok.
    Checking 'file'... ok.
    Checking 'ldconfig-stub'... ok.

    Build dependency: Please install GNU 'patch'

    Prerequisite check failed. Use FORCE=1 to override.
    make: *** [/home/prac/Omega2_src_official/source/include/toplevel.mk:153: staging_dir/host/.prereq-build] Error 1

    I don't know what is the GNU patch that the script is looking for...
    Does anyone knows what is the patch that it is required ?
    Does anyone knows where is the prereq script source? maybe if could read the script source i can figure out what is this GNU patch...
    Tahnkyou!



  • @Miguel-Miranda maybe it needs the GNU patch application installed on the build machine?
    http://savannah.gnu.org/projects/patch/



  • Thanks for the reply @Douglas-Kryder.
    I've already installed the GNU patch app

    $patch -v
    GNU patch 2.7
    Copyright (C) 2003, 2009-2012 Free Software Foundation, Inc.
    Copyright (C) 1988 Larry Wall

    License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html.
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.

    Written by Larry Wall and Paul Eggert

    But I get the same error... :(
    BR,



  • @Miguel-Miranda
    Could it be that it needs a later version?
    The patch in my ubuntu build environment is 2.7.5:

    $ patch -v
    GNU patch 2.7.5
    Copyright (C) 2003, 2009-2012 Free Software Foundation, Inc.
    Copyright (C) 1988 Larry Wall
    
    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.
    
    Written by Larry Wall and Paul Eggert
    

    Or re-run make with -j1 V=s parameters which will give you more verbose output that could identify what is going wrong.



  • Hi @cas thanks for the reply, i've changed my patch version to 2.7.5 but still the error


    $make -j1 V=s
    ...
    Build dependency: Please install GNU 'patch'

    Prerequisite check failed. Use FORCE=1 to override.
    make[2]: *** [/home/prac/Omega2_src_official/source/include/toplevel.mk:153: staging_dir/host/.prereq-build] Error 1
    make[1]: *** [/home/prac/Omega2_src_official/source/include/toplevel.mk:80: prepare-tmpinfo] Error 2
    make: *** [/home/prac/Omega2_src_official/source/include/toplevel.mk:198: world] Error 2

    I think there is a problem with my toplevel.mk
    #153 : @$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/pre req-build.mk prereq 2>/dev/null || {
    echo "Prerequisite check failed. Use FORCE=1 to override." ;
    false;
    #80; @+$(MAKE) -r -s staging_dir/host/.prereq-build $(PREP_MK)
    #198: @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq]


    it is a little weird though, because in the repository of https://github.com/WereCatf/source.git i don't have this error, instead i've a Download fail errors


    SHELL= flock /home/prac/Omega2_src/source/tmp/.sed-4.4.tar.xz.flock -c ' /home/prac/Omega2_src/source/scripts/download.pl "/home/prac/Omega2_src/source/dl" "sed-4.4.tar.xz" "cbd6ebc5aaf080ed60d0162d7f6aeae58211a1ee9ba9bb25623daa6cd942683b" "" "@GNU/sed" '

    Download failed.

    Download failed.

    Download failed.

    Download failed.

    Download failed.

    ...
    Download failed.
    No more mirrors to try - giving up.
    make[3]: *** [Makefile:46: /home/prac/Omega2_src/source/dl/sed-4.4.tar.xz] Error 2
    make[3]: Leaving directory '/home/prac/Omega2_src/source/tools/sed'
    make[2]: *** [tools/Makefile:150: tools/sed/compile] Error 2
    make[2]: Leaving directory '/home/prac/Omega2_src/source'
    make[1]: *** [tools/Makefile:146: /home/prac/Omega2_src/source/staging_dir/target-mips_24kc_musl/stamp/.tools_compile_yyyyyyyyynyyyyynyynnyyyyyyyyyyyyyyyyyyyynyynynyyyynny] Error 2
    make[1]: Leaving directory '/home/prac/Omega2_src/source'
    make: *** [/home/prac/Omega2_src/source/include/toplevel.mk:209: world] Error 2


    I'm not sure why, but i'm keep looking... as i said before the weird think is that i didn't get stuck in the third party repo with the prereq script...
    git log of the official repo i'm using
    HEAD -> lede-17.01, origin/lede-17.01, origin/HEAD



Looks like your connection to Community was lost, please wait while we try to reconnect.