Disabling Wifi Scan



  • Hello everyone,

    I have an Omega 2+, and I am using it as a kind of wireless controller for a robot. I do this by plugging an XBox 360 controller into the Omega (with the dock) and having the robot connect to the Omega's wifi AP. It works great! However, there is a problem.

    It only works when the Omega is connected to wifi itself. If it is not connected to some network, it lags horribly (still works, but 5 second control lag or so - unusable!)
    The lag happens in regular intervals. I assume this is due to the Omega scanning for wifi networks. This system needs to be portable, so having to connect to a wifi network just so it doesn't lag is pretty annoying!

    How can I disable this scanning, or disable regular wifi altogether and keep the AP? Any ideas?

    Thanks!



  • Bump

    I still have not found a solution.


  • administrators

    You need to edit the file /etc/config/wireless
    Under config wifi-iface sta
    set option disabled '0' to option disabled '1'

    reboot your omega2+ and it will not try to scan or connect to any WiFi.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.