I can not restore the factory image



  • Hello, I have installed openwrt in my Onion 2+ and after playing a bit I can not return to the system by default.

    • The factory restoration does not work
    • I can not mount the USB device or SD card
    • I can not enable the Wifi Network
      I hope to connect to the Internet, download the image and restore it

    /etc/network/interfaces.
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid "RED"
    wpa-psk "password123_"



  • root@OpenWrt:/# /etc/init.d/network restart
    'radio0' is disabled
    [ 6999.685352] br-lan: port 1(eth0) entered disabled state
    [ 6999.805741] device eth0 left promiscuous mode
    [ 6999.810277] br-lan: port 1(eth0) entered disabled state
    [ 6999.831425] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    root@OpenWrt:/# [ 7004.216667] br-lan: port 1(eth0) entered blocking state
    [ 7004.221984] br-lan: port 1(eth0) entered disabled state
    [ 7004.227718] device eth0 entered promiscuous mode
    [ 7004.244550] br-lan: port 1(eth0) entered blocking state
    [ 7004.249866] br-lan: port 1(eth0) entered forwarding state
    [ 7004.255602] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
    [ 7005.213283] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

    root@OpenWrt:/# /etc/init.d/dnsmasq restart
    udhcpc: started, v1.28.4
    udhcpc: sending discover
    udhcpc: no lease, failing
    root@OpenWrt:/#



  • root@OpenWrt:/# ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UNKNOWN qlen 1000
    link/ether 40:a3:6b:c1:e1:8b brd ff:ff:ff:ff:ff:ff
    3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 40:a3:6b:c1:e1:89 brd ff:ff:ff:ff:ff:ff
    5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 40:a3:6b:c1:e1:8b brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
    valid_lft forever preferred_lft forever
    inet6 fdbd:c8a:d1d4::1/60 scope global
    valid_lft forever preferred_lft forever
    inet6 fe80::42a3:6bff:fec1:e18b/64 scope link
    valid_lft forever preferred_lft forever



  • br-lan Link encap:Ethernet HWaddr 40:A3:6B:C1:E1:8B
    inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::42a3:6bff:fec1:e18b/64 Scope:Link
    inet6 addr: fdbd:c8a:d1d4::1/60 Scope:Global
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:2132 (2.0 KiB)

    eth0 Link encap:Ethernet HWaddr 40:A3:6B:C1:E1:8B
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:51 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:8943 (8.7 KiB)
    Interrupt:5

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:1024 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1024 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:69632 (68.0 KiB) TX bytes:69632 (68.0 KiB)



  • @fandres-*
    I would suggest that you return to the Onion firmware manually.

    Either by Manual Firmware Installation if you have access to sysupgrade, or Firmware Flashing from USB Storage if you have a mini or expansion dock.



  • Hi @cas,
    I worked on Firmware Flashing from USB Storage

    Thank you


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.