Omega 2+ Wifi unstable and slow



  • You are completly right ahah,
    here are the result when I ping my router:

    root@Omega-4305:~/DomoHome/OmegaWebServer# ping 192.168.0.1
    PING 192.168.0.1 (192.168.0.1): 56 data bytes
    64 bytes from 192.168.0.1: seq=3 ttl=64 time=2140.563 ms
    64 bytes from 192.168.0.1: seq=4 ttl=64 time=1141.855 ms
    64 bytes from 192.168.0.1: seq=6 ttl=64 time=98.246 ms
    64 bytes from 192.168.0.1: seq=7 ttl=64 time=30.148 ms
    64 bytes from 192.168.0.1: seq=8 ttl=64 time=30.203 ms
    64 bytes from 192.168.0.1: seq=9 ttl=64 time=25.562 ms
    64 bytes from 192.168.0.1: seq=10 ttl=64 time=13.283 ms
    64 bytes from 192.168.0.1: seq=11 ttl=64 time=28.967 ms
    64 bytes from 192.168.0.1: seq=12 ttl=64 time=20.664 ms
    64 bytes from 192.168.0.1: seq=13 ttl=64 time=24.341 ms
    64 bytes from 192.168.0.1: seq=14 ttl=64 time=32.039 ms
    64 bytes from 192.168.0.1: seq=15 ttl=64 time=39.736 ms
    64 bytes from 192.168.0.1: seq=16 ttl=64 time=23.557 ms
    64 bytes from 192.168.0.1: seq=17 ttl=64 time=35.133 ms
    64 bytes from 192.168.0.1: seq=18 ttl=64 time=18.750 ms
    64 bytes from 192.168.0.1: seq=19 ttl=64 time=27.330 ms
    64 bytes from 192.168.0.1: seq=20 ttl=64 time=14.212 ms
    64 bytes from 192.168.0.1: seq=21 ttl=64 time=29.913 ms
    64 bytes from 192.168.0.1: seq=22 ttl=64 time=33.677 ms
    64 bytes from 192.168.0.1: seq=23 ttl=64 time=18.044 ms
    64 bytes from 192.168.0.1: seq=25 ttl=64 time=1101.344 ms
    64 bytes from 192.168.0.1: seq=27 ttl=64 time=148.011 ms
    ^C
    --- 192.168.0.1 ping statistics ---
    31 packets transmitted, 22 packets received, 29% packet loss
    round-trip min/avg/max = 13.283/230.708/2140.563 ms
    

    I'm 1 metter away from the wifi router



  • @Alexy-Torres @Douglas-Kryder I would be interested to know what your wifi configuration is.

    I would also run another test. Place your Omega next to the wifi router you are connected to and try ping again. I have found that some of my Omega2+ seem to be effected by some interference, I think it is my B&O TV but not sure. When I move the Omega away from that TV they work just fine. I can take the same Omega to my office and it works perfectly anywhere in my office. Not sure if this is your issue but I think it is worth looking at.



  • @crispyoz Thanks for the reply!

    Do you have a specific command in mind? I also put the omega right next to the router and get the same result. I also tried connecting the omega to my cell phone AP and get the same issue.

    Here are my wifi settings:

    config wifi-device 'radio0'
            option type 'ralink'
            option variant 'mt7628'
            option country 'US'
            option hwmode '11g'
            option htmode 'HT40'
            option channel 'auto'
            option disabled '0'
            option device_mode 'apsta'
            option op_mode 'preference'
    
    config wifi-iface 'ap'
            option device 'radio0'
            option mode 'ap'
            option network 'wlan'
            option ifname 'ra0'
            option encryption 'psk2'
            option key '12345678'
            option disabled '0'
            option ssid 'Omega-4305'
    
    config wifi-iface 'sta'
            option device 'radio0'
            option mode 'sta'
            option ifname 'apcli0'
            option encryption 'psk2'
            option network 'wwan'
            option disabled '0'
            option ssid 'Torres 2.4GHz'
            option key 'REDACTED'
            option led 'omega2p:blue:wifi'
    
    config wifi-config
            option ssid 'Torres 2.4GHz'
            option encryption 'psk2'
            option key 'REDACTED'
    
    config wifi-config
            option ssid 'AlexyAPS'
            option encryption 'psk2'
            option key 'REDACTED'
    


  • @Alexy-Torres That looks pretty normal. My first thought is that it seems some users have had issues with their wifi due to some differences with US configuration. Try removing "option country ''US"



  • @crispyoz I tried that but unfortunately I still have the same results. If that could help someone, the issue appeared like 3 days ago and wasn't present 1 week ago.



  • @Alexy-Torres that is interesting. It suggests something has changed. If this happened to me I would do as follows:

    1. Factory reset
    2. Use wifisetup to configure wifi
    3. oupdate


  • @crispyoz I already did. At first I factory reset the omega, then updated the firmware (that was a pain in the ass with this connection issue ahah) and nothing changed.



  • @Alexy-Torres How are you powering your Omega?



  • @crispyoz Through the dock, plugged by USB on my computer, I also tried to plug it to a usb charger directly



  • Just an update, I used the omega today and everything was fine, I don't know what happened...



  • @Alexy-Torres Something I noticed is that the AP mode is using the same channel as my home router so big and random interference might happen from time to time.

    Can you check with any wifi scanner if the AP wifi or your Onion is using the same channel as your home router?

    Regards



Looks like your connection to Community was lost, please wait while we try to reconnect.