Can't get wifi working.



  • I don't know what I'm missing, but I can't seem to get my Omega2+ connected to anything.

    I tried in the browser, via CLI. Both my home network and my phone's hotspot. Nothing works.
    The browser just says "Something went wrong".

    The CLI restarts the wifi stack, and doesn't connect.

    I included my /etc/config/wireless, ifconfig and dmesg. Is there anywhere else I can look for troubleshooting?

    dmesg
    [ 0.000000] Linux version 4.14.81 (root@c186a31677d3) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7397-75ccc36)) #0 Sun Dec 9 19:49:41 2018
    [ 0.000000] Board has DDR2
    [ 0.000000] Analog PMU set to hw control
    [ 0.000000] Digital PMU set to hw control
    [ 0.000000] SoC Type: MediaTek MT7688 ver:1 eco:2
    [ 0.000000] bootconsole [early0] enabled
    [ 0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
    [ 0.000000] MIPS: machine is Onion Omega2+
    [ 0.000000] Determined physical RAM map:
    [ 0.000000] memory: 08000000 @ 00000000 (usable)
    [ 0.000000] Initrd not found or empty - disabling initrd
    [ 0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
    [ 0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
    [ 0.000000] Zone ranges:
    [ 0.000000] Normal [mem 0x0000000000000000-0x0000000007ffffff]
    [ 0.000000] Movable zone start for each node
    [ 0.000000] Early memory node ranges
    [ 0.000000] node 0: [mem 0x0000000000000000-0x0000000007ffffff]
    [ 0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
    [ 0.000000] On node 0 totalpages: 32768
    [ 0.000000] free_area_init_node: node 0, pgdat 80494bc0, node_mem_map 81000040
    [ 0.000000] Normal zone: 256 pages used for memmap
    [ 0.000000] Normal zone: 0 pages reserved
    [ 0.000000] Normal zone: 32768 pages, LIFO batch:7
    [ 0.000000] random: get_random_bytes called from start_kernel+0x8c/0x474 with crng_init=0
    [ 0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=132768
    [ 0.000000] pcpu-alloc: [0] 0
    [ 0.000000] Built 1 zonelists, mobility grouping on. Total pages: 32512
    [ 0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
    [ 0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
    [ 0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
    [ 0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
    [ 0.000000] Writing ErrCtl register=00044427
    [ 0.000000] Readback ErrCtl register=00044427
    [ 0.000000] Memory: 124712K/131072K available (3613K kernel code, 198K rwdata, 900K rodata, 208K init, 202K bss, 6360K reserved, 0K cma-reserved)
    [ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
    [ 0.000000] NR_IRQS: 256
    [ 0.000000] intc: using register map from devicetree
    [ 0.000000] CPU Clock: 580MHz
    [ 0.000000] timer_probe: no matching timers found
    [ 0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6590553264 ns
    [ 0.000012] sched_clock: 32 bits at 290MHz, resolution 3ns, wraps every 7405115902ns
    [ 0.007539] Calibrating delay loop... 385.84 BogoMIPS (lpj=1929216)
    [ 0.073497] pid_max: default: 32768 minimum: 301
    [ 0.078197] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [ 0.084543] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
    [ 0.098637] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
    [ 0.108133] futex hash table entries: 256 (order: -1, 3072 bytes)
    [ 0.114078] pinctrl core: initialized pinctrl subsystem
    [ 0.119646] NET: Registered protocol family 16
    [ 0.152473] mt7621_gpio 10000600.gpio: registering 32 gpios
    [ 0.158076] mt7621_gpio 10000600.gpio: registering 32 gpios
    [ 0.163679] mt7621_gpio 10000600.gpio: registering 32 gpios
    [ 0.170173] i2c-mt7621 10000900.i2c: clock 100 kHz
    [ 0.179622] clocksource: Switched to clocksource MIPS
    [ 0.185861] NET: Registered protocol family 2
    [ 0.191044] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
    [ 0.197735] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
    [ 0.203923] TCP: Hash tables configured (established 1024 bind 1024)
    [ 0.210170] UDP hash table entries: 256 (order: 0, 4096 bytes)
    [ 0.215769] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
    [ 0.222132] NET: Registered protocol family 1
    [ 0.226319] PCI: CLS 0 bytes, default 32
    [ 0.230069] Crashlog allocated RAM at address 0x3f00000
    [ 0.236640] workingset: timestamp_bits=30 max_order=15 bucket_order=0
    [ 0.248842] squashfs: version 4.0 (2009/01/31) Phillip Lougher
    [ 0.254465] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
    [ 0.274204] io scheduler noop registered
    [ 0.277935] io scheduler deadline registered (default)
    [ 0.283952] Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
    [ 0.291298] console [ttyS0] disabled
    [ 0.294736] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
    [ 0.303509] console [ttyS0] enabled
    [ 0.310501] bootconsole [early0] disabled
    [ 0.319253] 10000d00.uart1: ttyS1 at MMIO 0x10000d00 (irq = 29, base_baud = 2500000) is a 16550A
    [ 0.328850] 10000e00.uart2: ttyS2 at MMIO 0x10000e00 (irq = 30, base_baud = 2500000) is a 16550A
    [ 0.338352] cacheinfo: Failed to find cpu0 device node
    [ 0.343604] cacheinfo: Unable to detect cache hierarchy for CPU 0
    [ 0.350586] spi-mt7621 10000b00.spi: sys_freq: 193333333
    [ 0.361661] m25p80 spi0.0: mx25l25635e (32768 Kbytes)
    [ 0.366844] 5 fixed-partitions partitions found on MTD device spi0.0
    [ 0.373349] Creating 5 MTD partitions on "spi0.0":
    [ 0.378213] 0x000000000000-0x000000030000 : "u-boot"
    [ 0.384202] 0x000000030000-0x000000040000 : "u-boot-env"
    [ 0.390495] 0x000000040000-0x000000050000 : "factory"
    [ 0.396432] 0x000000050000-0x000001f80000 : "firmware"
    [ 0.471006] 2 uimage-fw partitions found on MTD device firmware
    [ 0.477034] 0x000000050000-0x0000001cfee4 : "kernel"
    [ 0.483044] 0x0000001cfee4-0x000001f80000 : "rootfs"
    [ 0.488869] mtd: device 5 (rootfs) set to be root filesystem
    [ 0.496140] 1 squashfs-split partitions found on MTD device rootfs
    [ 0.502480] 0x000000960000-0x000001f80000 : "rootfs_data"
    [ 0.508893] 0x000001f80000-0x000002000000 : "user"
    [ 0.515635] libphy: Fixed MDIO Bus: probed
    [ 0.531644] rt3050-esw 10110000.esw: link changed 0x00
    [ 0.538520] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
    [ 0.547216] i2c /dev entries driver
    [ 0.552637] NET: Registered protocol family 10
    [ 0.561626] Segment Routing with IPv6
    [ 0.565461] NET: Registered protocol family 17
    [ 0.570092] 8021q: 802.1Q VLAN Support v1.8
    [ 0.583885] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
    [ 0.592232] Freeing unused kernel memory: 208K
    [ 0.596738] This architecture does not have kernel memory protection.
    [ 1.513288] init: Console is alive
    [ 1.516971] init: - watchdog -
    [ 2.242587] random: fast init done
    [ 5.012382] kmodloader: loading kernel modules from /etc/modules-boot.d/

    [ 5.307852] usbcore: registered new interface driver usbfs
    [ 5.313600] usbcore: registered new interface driver hub
    [ 5.319105] usbcore: registered new device driver usb
    [ 5.330874] exFAT: Version 1.2.9
    [ 5.369735] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    [ 5.386160] SCSI subsystem initialized
    [ 5.395755] ehci-platform: EHCI generic platform driver
    [ 5.411453] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
    [ 5.418254] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
    [ 5.423592] ehci-platform 101c0000.ehci: EHCI Host Controller
    [ 5.429453] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
    [ 5.437642] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
    [ 5.469671] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
    [ 5.477131] hub 1-0:1.0: USB hub found
    [ 5.481401] hub 1-0:1.0: 1 port detected
    [ 5.491496] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
    [ 5.499382] ohci-platform: OHCI generic platform driver
    [ 5.505075] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
    [ 5.512047] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
    [ 5.520195] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
    [ 5.594693] hub 2-0:1.0: USB hub found
    [ 5.598968] hub 2-0:1.0: 1 port detected
    [ 5.618013] MTK MSDC device init.
    [ 5.679855] mtk-sd: MediaTek MT6575 MSDC Driver
    [ 5.689079] sdhci: Secure Digital Host Controller Interface driver
    [ 5.695422] sdhci: Copyright(c) Pierre Ossman
    [ 5.701261] sdhci-pltfm: SDHCI platform and OF driver helper
    [ 5.711714] usbcore: registered new interface driver usb-storage
    [ 5.721564] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
    [ 5.739425] init: - preinit -
    [ 7.135170] rt3050-esw 10110000.esw: link changed 0x00
    [ 7.336349] random: procd: uninitialized urandom read (4 bytes read)
    [ 10.585164] mount_root: loading kmods from internal overlay
    [ 10.657202] kmodloader: loading kernel modules from //etc/modules-boot.d/*
    [ 10.670682] kmodloader: done loading kernel modules from //etc/modules-boot.d/*
    [ 11.775762] jffs2: notice: (432) jffs2_build_xattr_subsystem: complete building xattr subsystem, 18 of xdatum (2 unchecked, 15 orphan) and 113 of xref (9 dead, 78 orphan) found.
    [ 11.792558] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
    [ 11.805097] block: extroot: not configured
    [ 11.941087] jffs2: notice: (430) jffs2_build_xattr_subsystem: complete building xattr subsystem, 18 of xdatum (2 unchecked, 15 orphan) and 113 of xref (9 dead, 78 orphan) found.
    [ 11.958606] mount_root: loading kmods from internal overlay
    [ 12.031095] kmodloader: loading kernel modules from /tmp/overlay/upper/etc/modules-boot.d/*
    [ 12.041659] kmodloader: done loading kernel modules from /tmp/overlay/upper/etc/modules-boot.d/*
    [ 12.665412] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab
    [ 12.675481] block: extroot: not configured
    [ 12.681173] mount_root: switching to jffs2 overlay
    [ 12.754564] overlayfs: upper fs does not support tmpfile.
    [ 12.765369] urandom-seed: Seeding with /etc/urandom.seed
    [ 12.905910] procd: - early -
    [ 12.908945] procd: - watchdog -
    [ 13.654209] procd: - watchdog -
    [ 13.657709] procd: - ubus -
    [ 13.754357] random: ubusd: uninitialized urandom read (4 bytes read)
    [ 13.952240] random: ubusd: uninitialized urandom read (4 bytes read)
    [ 13.959243] random: ubusd: uninitialized urandom read (4 bytes read)
    [ 13.966842] procd: - init -
    [ 14.528984] kmodloader: loading kernel modules from /etc/modules.d/*
    [ 14.697503] RPC: Registered named UNIX socket transport module.
    [ 14.703588] RPC: Registered udp transport module.
    [ 14.708355] RPC: Registered tcp transport module.
    [ 14.713132] RPC: Registered tcp NFSv4.1 backchannel transport module.
    [ 14.732048] ntfs: driver 2.1.32 [Flags: R/O MODULE].
    [ 14.823898] ip6_tables: (C) 2000-2006 Netfilter Core Team
    [ 15.441708]
    [ 15.441708]
    [ 15.441708] === pAd = c062b000, size = 1178064 ===
    [ 15.441708]
    [ 15.453023] mt7628_init(FW(8a00), HW(8a01), CHIPID(7628))
    [ 15.602972] Linux video capture interface: v2.00
    [ 15.620453] hidraw: raw HID events driver (C) Jiri Kosina
    [ 15.649910] ledchain: pwm_base=0xB0005000
    [ 15.654129] ledchain: v2 - Device: /dev/ledchain2
    [ 15.658898] ledchain: - PWM channel : 2
    [ 15.663091] ledchain: - PWM buffer size: 12
    [ 15.667329] ledchain: - Number of LEDs : 1
    [ 15.671501] ledchain: - Inverted : 0
    [ 15.675651] ledchain: - LED type : WS2812
    [ 15.680254] ledchain: - Max retries : 3
    [ 15.684403] ledchain: - Max Tpassive : 10000 nS
    [ 15.847579] Bluetooth: Core ver 2.22
    [ 15.851393] NET: Registered protocol family 31
    [ 15.855899] Bluetooth: HCI device and connection manager initialized
    [ 15.862382] Bluetooth: HCI socket layer initialized
    [ 15.867333] Bluetooth: L2CAP socket layer initialized
    [ 15.872500] Bluetooth: SCO socket layer initialized
    [ 15.880349] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [ 15.885747] Bluetooth: BNEP filters: protocol multicast
    [ 15.891105] Bluetooth: BNEP socket layer initialized
    [ 15.903847] usbcore: registered new interface driver btusb
    [ 15.931231] usbcore: registered new interface driver cdc_acm
    [ 15.936982] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
    [ 15.974130] Bluetooth: HCI UART driver ver 2.3
    [ 15.978651] Bluetooth: HCI UART protocol H4 registered
    [ 15.983924] Bluetooth: HCI UART protocol BCSP registered
    [ 15.993882] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
    [ 15.999990] Bluetooth: HIDP socket layer initialized
    [ 16.011149] ip_tables: (C) 2000-2006 Netfilter Core Team
    [ 16.039177] nf_conntrack version 0.5.0 (2048 buckets, 8192 max)
    [ 16.137952] rt2880-pinmux pinctrl: pin io18 already requested by pinctrl; cannot claim for 10005000.pwm
    [ 16.147575] rt2880-pinmux pinctrl: pin-18 (10005000.pwm) status -22
    [ 16.153945] rt2880-pinmux pinctrl: could not request pin 18 (io18) from group pwm0 on device rt2880-pinmux
    [ 16.163843] mtk-pwm 10005000.pwm: Error applying setting, reverse things back
    [ 16.178317] Bluetooth: RFCOMM TTY layer initialized
    [ 16.183356] Bluetooth: RFCOMM socket layer initialized
    [ 16.188596] Bluetooth: RFCOMM ver 1.11
    [ 16.209555] usbcore: registered new interface driver ums-alauda
    [ 16.218797] usbcore: registered new interface driver ums-cypress
    [ 16.228276] usbcore: registered new interface driver ums-datafab
    [ 16.237473] usbcore: registered new interface driver ums-freecom
    [ 16.246866] usbcore: registered new interface driver ums-isd200
    [ 16.256376] usbcore: registered new interface driver ums-jumpshot
    [ 16.265710] usbcore: registered new interface driver ums-karma
    [ 16.275810] usbcore: registered new interface driver ums-sddr09
    [ 16.285181] usbcore: registered new interface driver ums-sddr55
    [ 16.294977] usbcore: registered new interface driver ums-usbat
    [ 16.308204] usbcore: registered new interface driver usbhid
    [ 16.313934] usbhid: USB HID core driver
    [ 16.322249] usbcore: registered new interface driver usblp
    [ 16.337748] usbcore: registered new interface driver usbserial
    [ 16.343834] usbcore: registered new interface driver usbserial_generic
    [ 16.350601] usbserial: USB Serial support registered for generic
    [ 16.370174] Driver for 1-wire Dallas network protocol.
    [ 16.399483] xt_time: kernel timezone is -0000
    [ 16.406495] usbcore: registered new interface driver ch341
    [ 16.412267] usbserial: USB Serial support registered for ch341-uart
    [ 16.421844] usbcore: registered new interface driver cp210x
    [ 16.427594] usbserial: USB Serial support registered for cp210x
    [ 16.437644] usbcore: registered new interface driver ftdi_sio
    [ 16.443703] usbserial: USB Serial support registered for FTDI USB Serial Device
    [ 16.465308] usbcore: registered new interface driver pl2303
    [ 16.471148] usbserial: USB Serial support registered for pl2303
    [ 16.483104] PPP generic driver version 2.4.2
    [ 16.490939] NET: Registered protocol family 24
    [ 16.510449] usbcore: registered new interface driver snd-usb-audio
    [ 16.533714] usbcore: registered new interface driver uvcvideo
    [ 16.539551] USB Video Class driver (1.1.1)
    [ 16.550821] usbcore: registered new interface driver option
    [ 16.556579] usbserial: USB Serial support registered for GSM modem (1-port)
    [ 16.569241] kmodloader: done loading kernel modules from /etc/modules.d/*
    [ 17.446051] urandom_read: 5 callbacks suppressed
    [ 17.446062] random: jshn: uninitialized urandom read (4 bytes read)
    [ 24.433152] jffs2: notice: (1068) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
    [ 28.631206] IPv6: ADDRCONF(NETDEV_UP): br-wlan: link is not ready
    [ 29.283733]
    [ 29.283733] _ _____ ___ ___ _________ ___ ____
    [ 29.283733] | | /| / / _ | / _ / _ \ / / __ / _ / / V1.1
    [ 29.283733] | |/ |/ / __ |/ , / / / // // / , / /
    [ 29.283733] |
    /|
    /
    / |
    /
    /|
    // _/_//|/___/
    [ 29.283733] Onion Enhanced MT7688 WiFi Driver
    [ 29.283733]
    [ 29.669724] DMA Scheduler Mode=0(LMAC)
    [ 29.673555] efuse_probe: efuse = 10000012
    [ 29.677679] 1. Phy Mode = 14
    [ 29.923832] 2. Phy Mode = 14
    [ 29.926807] 3. Phy Mode = 14
    [ 29.948224] WTBL Segment 1 info:
    [ 29.951697] MemBaseAddr/FID:0x28000/0
    [ 29.955591] EntrySize/Cnt:32/128
    [ 29.959037] WTBL Segment 2 info:
    [ 29.962414] MemBaseAddr/FID:0x40000/0
    [ 29.966299] EntrySize/Cnt:64/128
    [ 29.969755] WTBL Segment 3 info:
    [ 29.973111] MemBaseAddr/FID:0x42000/64
    [ 29.977085] EntrySize/Cnt:64/128
    [ 29.980542] WTBL Segment 4 info:
    [ 29.983899] MemBaseAddr/FID:0x44000/128
    [ 29.987959] EntrySize/Cnt:32/128
    [ 48.616147] br-wlan: port 1(ra0) entered blocking state
    [ 48.621596] br-wlan: port 1(ra0) entered disabled state
    [ 48.627320] device ra0 entered promiscuous mode
    [ 48.632147] br-wlan: port 1(ra0) entered blocking state
    [ 48.637451] br-wlan: port 1(ra0) entered forwarding state
    [ 48.644214] IPv6: ADDRCONF(NETDEV_CHANGE): br-wlan: link becomes ready
    [ 50.829735] Interface apcli0 link up! (WPA2PSK AES)
    [ 81.974925] random: crng init done
    root@Omega-7EA4:~# ifconfig
    apcli0 Link encap:Ethernet HWaddr 40:A3:6B:C4:7E:A6
    inet6 addr: fe80::42a3:6bff:fec4:7ea6/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    br-wlan Link encap:Ethernet HWaddr 40:A3:6B:C4:7E:A4
    inet addr:192.168.3.1 Bcast:192.168.3.255 Mask:255.255.255.0
    inet6 addr: fe80::42a3:6bff:fec4:7ea4/64 Scope:Link
    inet6 addr: fd1d:48c4:7633::1/60 Scope:Global
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:730 errors:0 dropped:0 overruns:0 frame:0
    TX packets:407 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:151730 (148.1 KiB) TX bytes:61101 (59.6 KiB)

    eth0 Link encap:Ethernet HWaddr 40:A3:6B:C4:7E:A5
    inet6 addr: fe80::42a3:6bff:fec4:7ea5/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:20689 (20.2 KiB)
    Interrupt:5

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:136 errors:0 dropped:0 overruns:0 frame:0
    TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:8816 (8.6 KiB) TX bytes:8816 (8.6 KiB)

    ra0 Link encap:Ethernet HWaddr 40:A3:6B:C4:7E:A4
    inet6 addr: fe80::42a3:6bff:fec4:7ea4/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:878 errors:0 dropped:0 overruns:0 frame:0
    TX packets:376 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:181334 (177.0 KiB) TX bytes:49592 (48.4 KiB)
    Interrupt:6

    root@Omega-7EA4:~# cat /etc/wc
    root@Omega-7EA4:~# cat /etc/con
    root@Omega-7EA4:~# cat /etc/config/w
    root@Omega-7EA4:~# cat /etc/config/wireless

    config wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'US'
    option hwmode '11g'
    option htmode 'HT40'
    option channel 'auto'
    option disabled '0'
    option device_mode 'apsta'
    option op_mode 'preference'

    config wifi-iface 'ap'
    option device 'radio0'
    option mode 'ap'
    option network 'wlan'
    option ifname 'ra0'
    option encryption 'psk2'
    option key '12345678'
    option disabled '0'
    option ssid 'Omega-7EA4'

    config wifi-iface 'sta'
    option device 'radio0'
    option mode 'sta'
    option ifname 'apcli0'
    option encryption 'psk2'
    option network 'wwan'
    option led 'omega2p:blue:wifi'
    option disabled '0'
    option key '********'
    option ssid 'SpalossGuest'

    config wifi-config
    option key '********'
    option ssid 'SpalossGuest'
    option encryption 'psk2'

    config wifi-config
    option key '*********'
    option ssid 'Convex-PAN'
    option encryption 'psk2'

    root@Omega-7EA4:~#



  • @James-Spaloss

    I didn't have time to look at the whole post right now but some users have resolved similar issues by commenting out the country setting: option country 'US' in /etc/config/wireless

    Also note that Omega support 2.4GHz not 5Ghz


  • administrators



  • Thanks for your help.

    I have option country 'US' in my /etc/config/wireless
    iwconfig shows that I am associated with my AP, but ifconfig shows no IP address and no traffic.

    I tried running dhclient on the interface, but the dhclient command is not available.



  • I also configured the interface with a static ip.
    I tried pinging the gateway (nothing), and even after the ping attempts, ifconfig still shows no traffic in or out.



  • @James-Spaloss did you comment out the "option country us" ?
    What firmware version are you using?



  • I did try commenting out the option country 'US'.

    Firmware is 0.3.2 b320



  • Is there a way of flashing a different firmware over the AP interface?



  • @James-Spaloss If I were you I'd simply

    • restart the host PC
    • perform a Factory Reset / Restore on Omega2+
    • repeat the Initial Setup
    • and try to connect with wifisetup '1) Scan for Wifi networks' to the host PC's AP to 'SpalossGuest' (???).

    The outputs of cat /etc/config/wireless, ifconfig, logread | tail -n 50 are useful info.



  • @James-Spaloss
    I wrote "and try to connect with wifisetup ... to the host PC's AP to 'SpalossGuest' (???)".
    Most probably I was wrong because 'SpalossGuest' is not a WiFi AP on your host PC.

    What is 'SpalossGuest'? Is it your Internet gateway, a WiFi router, a standalone WiFi AP or ...?



  • Thanks for the help.

    I'm on my 3rd, factory reset.

    SpalossGuest is an SSID on on my home wifi setup. There are 2 Unifi AC Pro APs serving the wifi.

    I also tried using my phone as a Wifi hotspot with the same results.

    iwconfig shows that I am associated, but ifconfig shows no traffic sent or received. If I am really associated, shouldn't there at least be some outboud traffic for the DHCP requests? I'll post configs.



  • @James-Spaloss Unfortunately Omega2's ifconfig doesn't show the WiFi network traffic - RX bytes and TX bytes of apcli0 and ra0 are always 0 (0.0 B). :-(

    Search our forum (keyword: Ubiquiti) - some Omega2 users have similar issues with these devices.
    Sorry, I don't have any Ubiquiti device so I can't help to solve these problems.



  • Thanks.
    I will.



  • Ok. After some hunting and trying, I'm still not able to connect to the Unifi, bit I can connect to my phone's hotspot with no security. Not ideal, bimut I can start working on other things.

    Ultimately, the device will need to work from the phone's hotspot as a proof of concept, so for now, it's good enough.
    I have access to crappy old routers, so that should hold me over until what seems like a firmware bug gets resolved, or. I figure out how to get an older firmware flashed. (others are reporting that older firmware works)

    Thanks!



  • @James-Spaloss I use unifi in several locations including my apartment where i have 20+ Omega2+ and 2S+, I have had some issues previous but these are easily resolved by upgrading the firmware. What version of the unifi firmware are you using on your AP?

    Other things you can do to help resolve the issue are in the Unifi controller UI. In settings under the services section disable "Enable Advanced Feature" also disable connectivity monitor. You may need to restart the AP in order for these to have effect, Ubiquiti tells me this is not required but my experience differs.

    Next you can enable Remote Logging, the devices will publish a lot of useful information including diagnostics/debugging logging which provides quite detailed information about clients attempting to connect to the AP(s) and the handshaking etc tat is taking place. I expect your answer is in this log.



  • Thanks, I'll give it a try.
    Sorry about the lag. I'm juggling several projects this weekend.



  • Ive read through about 2 years worth of posts with people not being able to connect to wifi.
    THe main problem i find is that the kernel is only good for USA. I use channel 14 for my wifi as most routers only use up to 11 as default so i have pretty clear comms where i live.

    I have the same problems with RPI gui but not the none GUI version. I never have any problems with esp.

    whats the easiest way to connect to regular UK wifi channels?


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.