We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Using Omega as WiFi range extender (Dumb Access Point)



  • I am using Omega as Wi-Fi extender to get the signal around particularly stubborn concrete walls.

    Let's say, computers A and B are connecting to Omega AP, and Omega AP is connected to my home router. My LAN router is itself running OpenWrt, and has DHCP service and firewall rules.

    However, now that A and B are connecting via the Omega, the LAN router sees just Omega's IP address, and it is not possible to distinguish the traffic, hence rendering the router rules ineffective.

    Ideally, I'd like the A and B assigned their IP addresses by LAN router, and their traffic be identifiable on the router to make the firewall rules effective. The Omega should serve as just dumb AP. There are some instructions here on the openwrt page, but I am worried I could mess up the network config as editing those files takes some understanding what you are doing. I'd be grateful for some guidance here.



  • Looks like you need to disable DHCP on the omega and let it act as just an access point without creating a separate network.

    My experimental setup is similar to yours:
    ADSL Router --> WIFI 1 --> Onion A --> WIFI 2 --> Computer and Onion B

    I've considered in disabling DHCP on Onion A, but didn't because sometimes I find myself in a situation without internet or main router, but still wanting to hack on the Onions. Having Onion A be my router and access point is quite helpful in those situations.



  • Disabling DHCP on the Omega doesn't seem to be a trivial matter. I must be very cautious, as careless config might result in difficulties to reach the Omega via network (don't want to reach for that serial connection).

    From what I can understand in those openwrt instructions, I need to make changes in /etc/config/network and /etc/config/wireless files.

    In the /etc/config/network there even sits a commented-out configuration for bridging the wlan0-1 wlan0 interfaces:

    #config interface 'wlan'
    #   option ifname 'wlan0-1 wlan0'
    #   option type 'bridge'
    #   option proto 'static'
    #   option ipaddr '192.168.3.1'
    #   option netmask '255.255.255.0'
    #   option ip6assign '60'
    

    I think I need to uncomment it and change the proto to dhcp, to let the LAN router to assign Omega its IP address automatically:

    config interface 'wlan'
        option ifname 'wlan0-1 wlan0'
        option type 'bridge'
        option proto 'dhcp'
    

    There is also this section

    config interface 'wwan'
        option proto 'dhcp'
        option hostname 'OnionOmega'
    

    but I think I need to leave this one alone, as it's the inferface for connecting to the LAN Wi-Fi.

    However, I am not sure how should I change the /etc/config/wireless. Currently it looks like this:

    config wifi-iface
    	option device 'radio0'
    	option network 'wlan'
    	option mode 'ap'
    	option ssid 'OmegaAP'
    	option encryption 'psk2'
    	option key 'verystrongpassword1'
    
    config wifi-iface
    	option device 'radio0'
    	option mode 'sta'
    	option network 'wwan'
    	option ssid 'LANssid'
    	option encryption 'psk2'
    	option key 'verystrongpassword2'
    

    Omega needs to know both how to connect to the LAN router (wwan), and, I think, it needs also have separate wi-fi interface for the dumb AP. Well, all this is kind of guess made by semi-competent person. I'd be happy if someone more competent would correct me.



  • Looks like you're on the right track.
    Here's a bit more info. https://wiki.openwrt.org/doc/recipes/dumbap
    This doc also talks about disabling DHCP and the firewall.

    I played with it last night but couldn't get it to work yet. Was configuring it over serial and trying to connect my computer to Omega acting as Dumb AP. Will try again later.





  • Unfortunately I am not competent in this config. The example is still for another device, what might mean that it does not apply to Omega that has just one Wi-Fi interface, and no Ethernet interface. Editing those config files with trial-and-error does not seem like good idea.

    I wonder if there is nobody in the Onion team who reads this and can come up with simple instructions how the config files should be adjusted in order to make dumb AP that does not create new subnet and lets the connected computers get their IP address via DHCP on the LAN router.



  • @Pavils-Jurjans Did you ever get this working?



  • You'd be better off installing luci from opkg, I think, and configuring the onion via lan like you would if it were an openWRT enabled router. . . Which it is.



  • @Theodore-Borromeo I am in the process of trying to learn more about configuration, especially the bridging part of the omega. This sounds, from the very little I have read, that it might help simplify the setup. Have you worked with LUCI on the omega? In a few will try and download and work with it but am sure it in itself has a learning curve.



  • @Theodore-Borromeo said

    You'd be better off installing luci from opkg, I think, and configuring the onion via lan like you would if it were an openWRT enabled router. . . Which it is.

    Could not get this to load.
    opkg update ran successfully

    Unknown package 'luci'.
    Collected errors:
     * opkg_install_cmd: Cannot install package luci.
    
    

    or

    opkg install luci-ssl # enable https for luci

    # opkg install luci-ssl
    Unknown package 'luci-ssl'.
    Collected errors:
     * opkg_install_cmd: Cannot install package luci-ssl.

Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.