Wireless setup



  • Never mind got it working.



  • @Guest said:

    Never mind got it working.

    Would be nice if you share your learning curve with other newbies, in the spirit of open-source!



  • Now for the cleaning up of the procedure, more to come.



  • Hi @Guest,

    I have done the Ethernet Bridge Tutorial (https://wiki.onion.io/Tutorials/Using-Omega-As-Wifi-Ethernet-Bridge) and enabled Internet access on my laptop (with its wireless radios turned off) via an Ethernet cable and the Ethernet Expansion. I am actually using the forum and writing this post using only said Ethernet connection. This procedure takes about 5 minutes.

    Full example /etc/config/network and /etc/config/firewall files are available in their modified and "ready" state here: https://gist.github.com/gbo-actual/ac79e9345a477b0024b368b292d4492b. The link to these files have been added to the tutorial above.

    Once you have updated the files, run the two commands in this specific order (or reboot the Omega):

    /etc/init.d/firewall restart
    /etc/init.d/network restart
    

    And wait until it has finished (the command prompt will reappear). You can now plug in an Ethernet-capable device to the Omega (if it's your computer, disconnect from any wireless networks first).

    When acting as an Ethernet bridge, this disables the Omega's WiFi AP.

    Gabe



  • @Gabriel-Ongpauco Thank you Gab, dropped your configuration files over mine (rebooted) and the connection continued to function. Would you post the wireless configuration file?
    Held off posting my solution due to one problem. When connecting laptop all works fine no problems can be found.
    But when I connect my Mole camera as the only device entering the ethernet expansion port it does not work.
    The Mole camera functions fine when I bypass the Omega and connect directly in my LAN switch.
    One test involved turning off the firewall but still no go.

    Agreed concerning turning off the wireless radio on laptop so to avoid alternative wifi connection screwing up the testing. Only using the hardwired ethernet connection on the laptop. As a test I unplug to make sure I am not getting signal from wifi as opposed to hardwired ethernet.



  • @Guest said in Wireless setup:

    But when I connect my Mole camera as the only device entering the ethernet expansion port it does not work.

    Does the cam not have a fix ip in a other range than the Omega?? If yes change it to something like 192.168.3.xx (xx) means a number outside of your DHCP range. Otherwise you can get difficulties when you have duplicated IP's.



  • My laptop automatically receives all the settings needed to connect via DHCP setting on the laptop. The same settings were configured on the camera as stated before it handled the DHCP connection flawlessly while bypassing the Omega, connected to my LAN. So no, it does not have a fixed or static IP address.



  • @Guest,

    The wireless file (I assume you mean /etc/config/wireless) was not changed during the tutorial and it should be fine to use from a factory reset if you need a fresh one. This is also where wifi login info is stored, so I cannot post mine.

    I suggest playing around more with your camera's setup and settings since as far as we can tell, the Omega is providing network access through the Ethernet Expansion and functioning normally.



  • @Gabriel-Ongpauco Your assumption was correct the /etc/config/wireless file. FYI if you are stating your 'login info' is exposed I just comment over the top of it like:
    And one last request could you post the results from ifconfig -a from your setup? Thank you appreciate your help.

    config wifi-device 'radio0'
            option type 'mac80211'
            option hwmode '11g'
            option path 'platform/ar933x_wmac'
            option htmode 'HT20'
            option disabled '0'
            option channel '9'
            option txpower '30'
            option country 'US'
    
    config wifi-iface
            option device 'radio0'
            option network 'wlan'
            option mode 'ap'
            option ssid 'Omega-1234'
            option encryption 'psk2'
            option key 'just comment over it'
            option disabled '0'
    
    config wifi-iface
            option device 'radio0'
            option ssid 'mine'
            option encryption 'psk2'
            option network 'wwan'
            option mode 'sta'
            option key 'not shown'
            option disabled '0'


  • @None-None With little or no knowledge dicided to try verbatim your suggestion.
    Started with a FACTORY RESET Omega.
    Then checked out the names of the interfaces which would be needed with the brctl command.

    Ran the ifconfig -a command and got the following:

    
    /# ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 40:A3:6B:C1:17:0B
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:6 errors:0 dropped:3 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:583 (583.0 B)  TX bytes:0 (0.0 B)
              Interrupt:4
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:144 errors:0 dropped:0 overruns:0 frame:0
              TX packets:144 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:9792 (9.5 KiB)  TX bytes:9792 (9.5 KiB)
    
    wlan0     Link encap:Ethernet  HWaddr 40:A3:6B:C1:17:0C
              inet addr:192.168.3.1  Bcast:192.168.3.255   Mask:255.255.255.0
              inet6 addr: fe80::42a3:6bff:fec1:170c/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:9272 (9.0 KiB)
    

    Then ran ….

    # brctl addbr br-lan
    
    # brctl addif br-lan eth0 wlan0
    [  485.950000] device eth0 entered promiscuous mode
    brctl: invalid argument 'wlan0' to 'brctl'
    

    config -a after running the brctl command:

    # ifconfig -a
    br-lan    Link encap:Ethernet  HWaddr 40:A3:6B:C1:17:0B
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    eth0      Link encap:Ethernet  HWaddr 40:A3:6B:C1:17:0B
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:6 errors:0 dropped:3 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:583 (583.0 B)  TX bytes:0 (0.0 B)
              Interrupt:4
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:2064 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2064 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:140352 (137.0 KiB)  TX bytes:140352 (137.0 KiB)
    
    wlan0     Link encap:Ethernet  HWaddr 40:A3:6B:C1:17:0C
              inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
              inet6 addr: fe80::42a3:6bff:fec1:170c/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:9272 (9.0 KiB)
    

    Seems like the wlan is not the correct entry, maybe at this point you can see what it is leading me astray?


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.