Hello,
I have a strange issue. I configured both AP and STA wireless interfaces.
AP works fine. I can connect my devices to Omega2.
The apcli0
interface cannot obtain an ip address from a 2.4GHz wifi router (other 2.4GHz devices work fine).
apcli0
is associated. I can see the following log lines:
kern.info ap_client: 'apcli0' assoc: yes, mac: 30:23:03:e0:dd:49
The command iwinfo apcli0 info
correctly reports the ESSID and the mac address of the access point:
apcli0 ESSID: "MySSID"
Access Point: 30:23:03:E0:DD:49
...
The dhcp request is sended:
daemon.notice netifd: wwan (18106): udhcpc: sending discover
On the router (Openwrt too) I have log messages like the following:
daemon.info hostapd: wlan1: STA 40:a3:6b:c5:8a:cc IEEE 802.11: authenticated
daemon.notice hostapd: wlan1: AP-STA-POSSIBLE-PSK-MISMATCH 40:a3:6b:c5:8a:cc
I don't know if the AP-STA-POSSIBLE-PSK-MISMATCH
notice is relevant. I did not find any significant information on internet about it.
Some check I did:
- association with another router (not Openwrt)
- flushing of firewall rules (
fw3 stop; fw3 flush
)
- I changed options
radio0.country
and radio0.htmode
Any suggest? How can I do more debugging?
Best regards
Alberto
This is my configuration:
- Omega2p
- Openwrt 0.3.2 b246
My /etc/config/wireless
config wifi-device 'radio0'
option type 'ralink'
option variant 'mt7628'
option hwmode '11g'
option channel 'auto'
option disabled '0'
option device_mode 'apsta'
option op_mode 'preference'
option country 'IT'
option htmode 'HT20'
config wifi-iface 'ap'
option device 'radio0'
option mode 'ap'
option network 'wlan'
option ifname 'ra0'
option encryption 'psk2'
option key '12345678'
option disabled '0'
option ssid 'Omega-8ACA'
config wifi-iface 'sta'
option device 'radio0'
option mode 'sta'
option ifname 'apcli0'
option network 'wwan'
option led 'omega2p:blue:wifi'
option disabled '0'
option encryption 'psk2'
option key 'MyPassword'
option ssid 'MySSID'
config wifi-config
option key 'MyPassword'
option ssid 'MySSID'
option encryption 'psk2'
My /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd1d:48c4:7633::/48'
config interface 'wlan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wwan'
option ifname 'apcli0'
option proto 'dhcp'
option hostname 'Omega-8ACA'
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'