We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[Resolved] Memory full - No WiFi & unable to access

  • Hi guys

    I have an Omega2+ with the expansion dock. The device was working fine until I tried to install Home Assistant. I switched to the LEDE repos and then I ran this commands:

    opkg install python3
    opkg install python3-pip
    opkg install python3-dev
    pip3 install homeassistant

    Halfway through the installation process of this last package, I ran out of disk space (I didn't configured an SD card or USB key as external storage until that point). So I did it following the guide, but when I restarted the device I couldn't connect to it and I don't even see the Omega WiFi network. The LEDs flash as usual.

    My guess is the ROM is still out of space so the OS can't fully boot (and / or I made a mistake with the USB configuration). Following an advice found here in the forums I copied the firmware to the USB, renamed it to omega2.bin and powered the device while pressing the reset button with the hope to do a manual firmware upgrade. Nothing. I can't access it.

    If somebody can help me, I'll be eternally thankful.

  • It is quite unlikely that your device is "bricked" and even fairly unlikely that you need to upgrade or replace the firmware.

    All you really need to do is perform a factory reset which will wipe out the partition containing your customizations, putting you back to a factory fresh state.

    You can follow the instructions for doing that with the button or a wire having the same effect.

    That said, on any customization-oriented system of this type, life will be easy with a logic-level USB serial adapter hooked up, so that you can see what U-Boot, kernel boot messages, etc are saying, rather than having only LEDs to go on until the point where wifi comes up.

  • You're right. I overlooked the factory reset function.
    My device is very much alive. Sorry for the false alarm.

  • @Lucas-Godoy , you may could change the title to "memory full" instaed of bricked and mark it as resolved (inkl. add tag resolved).

Looks like your connection to Community was lost, please wait while we try to reconnect.