We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ ethernet bridge not working



  • I have a Onion Omega2+ that I had previously set up Octoprint on, due to performance issues I decided to re-purpose it to provide Wifi to a BeagleBone Black Rev C. So I got the Ethernet Expansion and plugged it into the Expansion Dock already attached to my Omega2+.

    I attempted to follow the instructions I could find online for setting up an ethernet bridge, but it appears to either be incorrect or out of date as nothing works.

    https://docs.onion.io/omega2-docs/ethernet-bridge.html
    Which says:

    Connect your Ethernet Expansion to your Expansion Dock, and then plug in an Ethernet cord to set up the hardware.

    What we need to do next is change the following code block located in /etc/config/network:

    config interface 'wlan'
            option type 'bridge'
            option ifname 'eth0.1'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    

    Change option ifname 'eth0.1' to option ifname 'eth0'

    Restart the network service by running the follow command:

    /etc/init.d/network restart

    First off, that line is not present in my default configuration. After a factory reset I get:

    config interface 'wlan'
            option type 'bridge'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    

    Adding that line does nothing for the situation either.
    I can access the Onion Console through ethernet, but cannot access the internet.

    No updates available, I am on the latest versions:
    Onion OS version 1.0 Kernel 4.4.74
    BusyBox v1.25.1
    Omega-ware 0.2.2 b201

    The Omega2+ is connected to my home's wifi and is receiving internet. When connected to OnionOS via the Omega2+'s wifi hotspot, I have no flashing warning in the bottom left. When connected to OnionOS via ethernet, the little orange no internet symbol appears and flashes.

    Any help is greatly appreciated, I was thinking this should be pretty straightforward...



  • Was really in a crunch on this one and needed to get it working, so I ditched OnionOS all together in favor of vanilla OpenWRT 18.06.5
    I followed the first two steps here https://yoursunny.com/t/2019/omega2pro-openwrt/
    I removed the -F from the command as it is not needed in my situation. I then had to locate and specify the correct file path.
    Within minutes, OpenWRT was running flawlessly on the Omega2+
    I connected to my home network Wifi AP and disabled the Omega2+'s access point by selecting "replace current wireless etc etc"
    I then followed instructions here https://www.circuidipity.com/openwrt-bridged-repeater/ for bridging the wifi through ethernet which worked flawlessly upon the reboot.

    I now have the BeagleBone Black (powered via 5v adapter) connected to a USB hub, which powers the Omega2+ as well as connects the Beaglebone to the webcam and 3D printer.
    Test print is running now to see if the timelapse renders, which was the issue with running Octoprint on the Omega2+ directly; the timelapse would be captured and visible in unrendered timelapses but would crash the Octoprint server at any attempt to render.
    The other motivation for switching was to get away from the baud rate limit on the Omega2+ which required me to run custom firmware on my TAZ6 as default firmware all runs 250k baudrate due to performance issues with 115.2k.

    Hopefully this helps someone else in a similar scenario.

    tl;dr for Onion developers: Your documentation is inaccurate and/or out of date. Had I been able to use the Onion Omega2+ as a Wifi to Ethernet bridge as described by your documentation I would not have had to ditch OnionOS/firmware entirely.
    Please update your documentation so that a person could, if desired, use the Onion Omega2+ as described, out of box.

    After working around the shortcomings of the device & documentation, I am pleased with the performance of the hardware using plain OpenWRT 18.06.5

    Cheers!



Looks like your connection to Community was lost, please wait while we try to reconnect.