Mh, sounds like the same problem. My normal ethernet connections were stable though. The documentation: says that i need a different subnet for my home network. The omega has 192.168.3.x and i have 192.168.1.x, so thats not the problem. I will try to setup the Omega with mobile internet and disable the hotspot when it's done. Thanks for your reply!