i think restart is mandatory, try adding:
restart()
{
stop
start
}

at the end of the file, chmod it you didn't already, enable and reboot