[OpenWRT] Onion's openwrt repo



  • Hi! I'm trying to compile "arduino-dock" package from openwrt feed, but source code can't be retrieved from github. Here's the error:

    Checking out files from the git repository...
    Cloning into 'arduino-dock'...
    ERROR: Repository not found.
    fatal: Could not read from remote repository.
    Please make sure you have the correct access rights
    and the repository exists.

    Here's url of package read from package/feeds/onion/arduino-dock/Makefile:

    git@github.com:OnionIoT/arduino-dock.git that's equal to https://github.com/OnionIoT/arduino-dock.git

    This page doesn't exist, but this problem is common to other packages. Can you fix it?

    I tried to install the ipk from your repository, but binaries are compiled with uclibc and newest openwrt version uses musl, so I receive this error:

    /usr/bin/run-avrdude: line 31: twidude: not found

    Also, sending arduino sketch from the Arduino app, I have this error:

    > Flashing application '/tmp/sketch.hex' ...
    Error: Could not open file '/dev/i2c-0' or '/dev/i2c/0': No such file or directory

    I compiled kmod-i2c-core and loaded i2c-dev module and sent the command

    mknode /dev/i2c-0 c 89 0

    but it doesn't solve the problem. How can I solve it?

    EDIT 1:

    Solved the problem with i2c: omega (1) doesn't have hardware i2c, so it uses gpio pin 21 (SDA) and 20 (SCL). You have to compile kmod-i2c-gpio-custom and execute on boot (or put in /etc/init.d/boot)

    insmod i2c-gpio-custom bus0=0,21,20



  • @pma61 said in [OpenWRT] Onion's openwrt repo:

    Hi! I'm trying to compile "arduino-dock" package from openwrt feed, but source code can't be retrieved from github. Here's the error:
    Checking out files from the git repository...
    Cloning into 'arduino-dock'...
    ERROR: Repository not found.
    fatal: Could not read from remote repository.
    Please make sure you have the correct access rights
    and the repository exists.

    Hi, I have recently been revisiting building system images for the Omega and get exactly the same error if I include arduino-dock and similar for some other packages.

    Yet another reason why we need access to a clean repository complete with .config file for Omega system images as covered in https://community.onion.io/topic/921/kernel-driver-version-mismatch and other posts



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.