Python install not working



  • Hi,

    I am having problems with the openwrt opkg site where bad checksums are appearing. This makes installs very flakey. is anybody else experiencing problems with opkg?

    I haven't in the past and I have used two different Omega's..

    Does anybody have the same problem? How can this be fixed? Is there a mirror site?

    The error is right at the bottom of this post and you can see that I have issued an opkg update at the start.

    Another odd thing is that I had to install PHP to get over a dependency problem. Python stopped when it was looking for libbz2...

    root@Omega-16FE:/www/php# opkg update
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/base/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_base.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/base/Packages.sig.
    Signature check passed.
    Downloading http://repo.onion.io/omega/packages/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_onion.
    Downloading http://repo.onion.io/omega/packages/Packages.sig.
    Signature check passed.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/Packages.gz.
    Updated list of available packages in /var/opkg-lists/chaos_calmer_packages.
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/Packages.sig.
    Signature check passed.
    root@Omega-16FE:/www/php# opkg install python
    Installing python (2.7.9-6) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/python_2.7.9-6_ar71xx.ipk.
    Installing python-light (2.7.9-6) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/python-light_2.7.9-6_ar71xx.ipk.
    Installing python-base (2.7.9-6) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/python-base_2.7.9-6_ar71xx.ipk.
    Installing libffi (3.0.13-1) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/libffi_3.0.13-1_ar71xx.ipk.
    Installing libbz2 (1.0.6-2) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/base/libbz2_1.0.6-2_ar71xx.ipk.
    Installing python-codecs (2.7.9-6) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/python-codecs_2.7.9-6_ar71xx.ipk.
    Installing python-compiler (2.7.9-6) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/python-compiler_2.7.9-6_ar71xx.ipk.
    Installing python-ctypes (2.7.9-6) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/python-ctypes_2.7.9-6_ar71xx.ipk.
    Installing python-db (2.7.9-6) to root...
    Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/python-db_2.7.9-6_ar71xx.ipk.
    Configuring python-base.
    Configuring libffi.
    Configuring libbz2.
    Configuring python-light.
    Configuring python-codecs.
    Configuring python-ctypes.
    Configuring python-compiler.
    Collected errors:
     * opkg_install_pkg: Package python-db sha256sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
     * opkg_install_cmd: Cannot install package python.
    root@Omega-16FE:/www/php#
    

    Thanks..



  • OK - I have fixed this...

    Odd though this may seem, I had someone else do a sanity check on my install (thanks..) and they did not have any problems at all..!

    This led me to believe that the problem was local, but I had used two different Omega's. The problem was local. I happened to notice that my PC was constantly downloading at about 1 or 2 mb/s so I disabled the photo sync in the ICloud settings on the PC. Now it works.

    Strange but true - wifi interference. But I thought TCP was an end to end connection...

    Curiouser and curiouser.. :-/



  • With other unrelated hardware, I think I experienced WiFi failures once or twice when a cellular phone (it's WiFi off) was in use. They are not on the same frequencies, but I suspect a bad WiFi frequency filter on the WiFi equipment as the culprit. Would that make any sense?


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.