Arduino Dock guide is up

  • I have a couple of questions in relation to all of this.
    First so you understand what I am currently doing:

    • I don't have an Expansion Dock I only have a Mini Dock and an Arduino Dock
    • I have an Adafruit PowerBoost Shield with 2000mAh Lithium battery
    • I plug the Omega in to the Arduino Dock
    • I plug the PowerBoost Shield in to the Arduino Dock
    • I only ever communicate with the Omega using WiFi
      Thus, always have power that can be switched on and off as required and no mess of cables everywhere:-)
      This all works without any problems and implies to me that the Omega is powered by the 3.3v from the Arduino Dock.

    First question:

    • Is this OK and safe?

    Next, I note in the instructions that once the Arduino Dock is set up, a sketch can be loaded on to the Arduino Dock using:

    • sh /usr/bin/arduino-dock flash <hex file>

    but for I note that for the initial set up:

    • this is basically the same as what we initially need to do to initially set up the Arduino Dock, i.e.:sh /usr/bin/arduino-dock flash bootloader
    • and there is no other communication between the two for setup

    These two together imply to me that when the Omega is plugged in to the Arduino Dock they are already connected as covered in the wiring instructions and that consequently no additional wiring is required and the whole procedure can be carried out without the separate wiring.
    So my second question:

    • Am I correct about this, or have I missed something?

  • administrators

    @Kit-Bishop Yep, what you're doing is safe and ok. You can also power the Omega + Arduino Dock with a micro usb. And when using the Arduino Dock you can only communicate with the Omega via WiFi (ssh and console) even when the micro usb is plugged in.

    The extra wires are only needed for the Inital Setup (now on it's own wiki page). Once you complete that, there is no need for any extra wires.

    The Omega can then use the Arduino Dock to flash the ATmega chip with Sketches. You can use the command you have above or you can use the Arduino IDE to wirelessly have the Omega flash the ATmega chip (probably the quicker option).

  • @Lazar-Demin Cool :-) Thanks for the quick response

  • I'm getting a failure when I try to enter the password to upload the sketch. Error message is ash: merge-sketch-with-bootloader.lua: not found. I flashed the board and I thought is said it was ok. Ideas?


  • I try to burn the bootloader, all my connections seems OK but I always have this message:

    root@onion:~# sh /usr/bin/arduino-dock flash bootloader
    Flashing bootloader...
    avrdude: AVR device not responding
    avrdude: initialization failed, rc=-1
    Double check connections and try again, or use -F to override
    this check.

    I double check connections, everything is fine. What can I do?

  • @Lazar-Demin just tried flashing the dock and it worked for one of the docks :) one of the docks continued to display the error.


    For the dock that did work:
    I wired the dock as you suggested with 3.3v and GND wired to the dock.

    Function SPI MISO -> Mini Dock and Omega Pin 1 -> Arduino Dock Pin 12

    Function SPI SCK -> Mini Dock and Omega Pin 6 -> Arduino Dock Pin 13

    Function SPI RESET -> Mini Dock and Omega Pin 7 -> Arduino Dock Pin Reset

    Function SPI MOSI -> Mini Dock and Omega Pin 19 -> Arduino Dock Pin 11

    Function VCC -> Mini Dock and Omega Pin 3.3V -> Arduino Dock Pin 3.3V

    Function GND -> Mini Dock and Omega Pin GND -> Arduino Dock Pin GND

    Here are some photos of the wiring.

    14482301031241.jpg 14482301031190.jpg 14482301031612.jpg

    I then powered the minidock which and ran the script on the Omega via ssh terminal.




    So for me. One of the Arduino Docks works but but it looks like the other one does accept the bootloader (might be fried.)

  • administrators

    @Russ-Terrell Yeah, that message will show up but the flash should still work. Try enabling Upload verbosity in the Arduino IDE settings and posting the message.

  • administrators

    @Tchernobil Are you using an Expansion Dock? Can you post some photos of the setup?

  • administrators

    @Maurice glad that it worked and sorry to hear that one of the Docks is non-responsive :cry:

  • I use the Espansion Dock. You can see a video of my setup here:
    How can I test if my arduino dock is defective?

  • administrators

    @Tchernobil Can you try following the 'Using the Omega + Expansion Dock with the Arduino Dock ICSP Header' procedure from the Arduino Dock Initial Setup Guide?

    Let me know how it goes.

  • It's working!
    Thank you very much. Now I can use Arduino IDE to flash a sketch to the Arduino Dock.

  • administrators

    @Tchernobil awesome! glad to hear it worked
    @Maurice can you try following the same procedure on your non-cooperative Dock? (Might take a little more wire wrangling with the Mini Dock)

  • I still can't get the password to work. I reflashed the board using ICSP connector. Looks like it flashed ok.

    I was going to do the resync, but I'm not seeing blink2.ino.hex in the temp folder, only blink2.cpp.hex as listed in the Verbose list.

    X:\arduino-1.6.5\Arduino\hardware\tools\avr/bin/avr-objcopy -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 D:\Users\Russ\AppData\Local\Temp\build8175480600231811290.tmp/blink2.cpp.elf D:\Users\Russ\AppData\Local\Temp\build8175480600231811290.tmp/blink2.cpp.eep
    X:\arduino-1.6.5\Arduino\hardware\tools\avr/bin/avr-objcopy -O ihex -R .eeprom D:\Users\Russ\AppData\Local\Temp\build8175480600231811290.tmp/blink2.cpp.elf D:\Users\Russ\AppData\Local\Temp\build8175480600231811290.tmp/blink2.cpp.hex


  • administrators

    @Russ-Terrell Yeah, that should be good as well, the name might depend on the Arduino IDE version.

    Which password are you using in the Arduino IDE? It should be your Omega password which is onioneer by default

  • That's the one I'm using.


  • @Lazar-Demin just tested it using the ICSP header procedure and it appears to work.


    Although I suspect that I may have fried the board during one of my tests last week (I plugged in a power source directly on the header pins and this may have fried one of the components between pins 7 and 8. Maybe too much voltage :s ). Note to self don't try plugging in a 9V battery on the header pins lol.

    The reason I suspect there's like a fried capacitor or something is because the Omega on the Dock doesn't power up when both GND and 3.3v is connected to the Arduino Dock. Unplugging either GND or 3.3v allows the Omega and minidock to power up. (This issue did not occur on the other Arduino Dock which was flashed successfully in the previous posts).

    So in this ICSP header test I only kept the GND plugged in and left the 3.3v out while plugging in a micro USB into the Arduino Dock.

    Here's a few pictures of the dock and mini dock wired up without power.

    14485002677262.jpg 14485002677171.jpg 14485002676750.jpg

  • Also just tested the uploading of a sketch via WiFi through the Omega using Arduino IDE 1.66 and it works. The Blink2 example sketch works flawlessly on the working Arduino Dock.

  • My dock is now working. I upgraded to 1.6.6 and loaded the library manually. I was able to compile and run the Blink2 example. :smile:

  • @Russ-Terrell I got the same error message "ash: merge-sketch-with-bootloader.lua: not found"
    After that, it goes on writing the flash....
    Is this error message normal??

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.