Arduino Dock guide is up

  • It's working!
    Thank you very much. Now I can use Arduino IDE to flash a sketch to the Arduino Dock.

  • administrators

    @Tchernobil awesome! glad to hear it worked
    @Maurice can you try following the same procedure on your non-cooperative Dock? (Might take a little more wire wrangling with the Mini Dock)

  • I still can't get the password to work. I reflashed the board using ICSP connector. Looks like it flashed ok.

    I was going to do the resync, but I'm not seeing blink2.ino.hex in the temp folder, only blink2.cpp.hex as listed in the Verbose list.

    X:\arduino-1.6.5\Arduino\hardware\tools\avr/bin/avr-objcopy -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 D:\Users\Russ\AppData\Local\Temp\build8175480600231811290.tmp/blink2.cpp.elf D:\Users\Russ\AppData\Local\Temp\build8175480600231811290.tmp/blink2.cpp.eep
    X:\arduino-1.6.5\Arduino\hardware\tools\avr/bin/avr-objcopy -O ihex -R .eeprom D:\Users\Russ\AppData\Local\Temp\build8175480600231811290.tmp/blink2.cpp.elf D:\Users\Russ\AppData\Local\Temp\build8175480600231811290.tmp/blink2.cpp.hex


  • administrators

    @Russ-Terrell Yeah, that should be good as well, the name might depend on the Arduino IDE version.

    Which password are you using in the Arduino IDE? It should be your Omega password which is onioneer by default

  • That's the one I'm using.


  • @Lazar-Demin just tested it using the ICSP header procedure and it appears to work.


    Although I suspect that I may have fried the board during one of my tests last week (I plugged in a power source directly on the header pins and this may have fried one of the components between pins 7 and 8. Maybe too much voltage :s ). Note to self don't try plugging in a 9V battery on the header pins lol.

    The reason I suspect there's like a fried capacitor or something is because the Omega on the Dock doesn't power up when both GND and 3.3v is connected to the Arduino Dock. Unplugging either GND or 3.3v allows the Omega and minidock to power up. (This issue did not occur on the other Arduino Dock which was flashed successfully in the previous posts).

    So in this ICSP header test I only kept the GND plugged in and left the 3.3v out while plugging in a micro USB into the Arduino Dock.

    Here's a few pictures of the dock and mini dock wired up without power.

    14485002677262.jpg 14485002677171.jpg 14485002676750.jpg

  • Also just tested the uploading of a sketch via WiFi through the Omega using Arduino IDE 1.66 and it works. The Blink2 example sketch works flawlessly on the working Arduino Dock.

  • My dock is now working. I upgraded to 1.6.6 and loaded the library manually. I was able to compile and run the Blink2 example. :smile:

  • @Russ-Terrell I got the same error message "ash: merge-sketch-with-bootloader.lua: not found"
    After that, it goes on writing the flash....
    Is this error message normal??

  • @Russ-Terrell NEVERMIND! I just read
    This is a normal issue. Just disregard the LUA error message...

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.