Connecting the Omega2+ to WiFi (channels 12 to 14) for non-US users.



  • Is it possible to add a country selection screen to the setup wizard (to choose the WiFi regulatory domain)?

    If you live outside of the US, it is possible to connect to your WiFi network which might reside at channel 12, 13 or 14, which are not available in the US and therefore the Omega2+ doesn't see those.

    I was unable to find my own network because it ran at channel 13 and I had to change it to a fixed channel between 1 and 11.

    Could this be fixed in a future update?



  • @Rick-Hogervorst I opened an issue on their github. The Onion-devs don't seem to visit their own forums, or at least I haven't seen any of them here.



  • @Rick-Hogervorst
    Try
    vi /etc/config/wireless

    You should see

    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'FI'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option ApCliEnable '1'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEncrypType 'AES'
            option ApCliSsid 'REMOVED'
            option ApCliPassWord 'REMOVED'
            option ssid 'REMOVED'
            option key 'REMOVED'
    
    config wifi-config
            option ssid 'REMOVED'
            option encryption 'WPA2PSK'
            option key 'REMOVED'
    
    

    Edit country and save & reboot may be solve



  • @WereCatf Thanks for the submission to GitHub.

    @Senol9000 I have actually tried that. But it didn't update properly.

    Changing this value in the /etc/config/wireless by adding a line also did not work. So that's why I added it to the script file itself.

    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'NL'
            option countryregion '1'  // This one I tried to add (hoping it would be picked up by ralink.sh)
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEncrypType 'AES'
            option ssid 'SSID1'
            option ApCliSsid 'SSID2'
            option ApCliPassWord 'SECRETPASS'
            option key 'SECRETPASS'
            option ApCliEnable '1'
    
    config wifi-config
            option ssid 'SSID2'
            option encryption 'WPA2PSK'
            option key 'SECRETPASS'
    

    I had to change the /overlay/upper/lib/wifi/ralink.sh script to also update the CountryRegion value:

    #The word of "Default" must not be removed
    Default
    CountryRegion=${countryregion:-1} // This one, it was a hardcoded  0.
    

    According to the docs from Ralink CountryRegion needs to be set like this for the following channel configs.

    @> CountryRegion=value                                 
    	value
    		0: use 1 ~ 11 Channel
    		1: use 1 ~ 13 Channel
    		2: use 10 ~ 11 Channel
    		3: use 10 ~ 13 Channel
    		4: use 14 Channel
    		5: use 1 ~ 14 Channel
    		6: use 3 ~ 9 Channel
    		7: use 5 ~ 13 Channel
    		31: use 1 ~ 14 Channel (ch1-11:active scan, ch12-14 passive scan)
    

    Now I have changed the value, I can verify after reboot to see that dmesg output actually shows it is using all channels up to 13 (in my case). And I can connect to channels above 11.

    [   29.920511] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [   32.729270]  ch1 bssid=e2:69:95:xx:xx:39
    [   32.733270]  ch1 bssid=20:aa:4b:xx:xx:ee
    [   32.737248]  ch1 bssid=e0:69:95:xx:xx:38
    [   32.741258]  ch1 bssid=60:02:92:xx:xx:1f
    [   32.745237]  ch3 bssid=ac:22:0b:xx:xx:c0
    [   32.749216]  ch6 bssid=5c:dc:96:xx:xx:d9
    [   32.753218]  ch6 bssid=5c:f6:dc:xx:xx:41
    [   32.757196]  ch6 bssid=d8:b6:b7:xx:xx:ec
    [   32.761196]  ch6 bssid=c4:f0:81:xx:xx:64
    [   32.765177]  ch11 bssid=4c:72:b9:xx:xx:6b
    [   32.769261]  ch11 bssid=20:25:64:xx:xx:14
    [   32.773329]  ch12 bssid=54:fa:3e:xx:xx:8f
    [   32.777396]  ch13 bssid=c4:71:30:xx:xx:9d
    [   32.781473] =====================================================
    [   32.787727] Channel 1 : Dirty = 328, False CCA = 0, Busy Time = 2637, Skip Channel = FALSE
    [   32.796145] Channel 2 : Dirty = 240, False CCA = 0, Busy Time = 1232, Skip Channel = FALSE
    [   32.804553] Channel 3 : Dirty = 278, False CCA = 0, Busy Time = 1170, Skip Channel = FALSE
    [   32.812950] Channel 4 : Dirty = 240, False CCA = 0, Busy Time = 283, Skip Channel = FALSE
    [   32.821259] Channel 5 : Dirty = 236, False CCA = 0, Busy Time = 1127, Skip Channel = FALSE
    [   32.829656] Channel 6 : Dirty = 304, False CCA = 0, Busy Time = 2989, Skip Channel = FALSE
    [   32.838034] Channel 7 : Dirty = 188, False CCA = 0, Busy Time = 1062, Skip Channel = FALSE
    [   32.846432] Channel 8 : Dirty = 180, False CCA = 0, Busy Time = 244, Skip Channel = FALSE
    [   32.854741] Channel 9 : Dirty = 196, False CCA = 0, Busy Time = 197, Skip Channel = FALSE
    [   32.863050] Channel 10 : Dirty = 196, False CCA = 0, Busy Time = 259, Skip Channel = FALSE
    [   32.871452] Channel 11 : Dirty = 200, False CCA = 0, Busy Time = 2062, Skip Channel = FALSE
    [   32.879937] Channel 12 : Dirty = 166, False CCA = 0, Busy Time = 2305, Skip Channel = FALSE
    [   32.888432] Channel 13 : Dirty = 168, False CCA = 0, Busy Time = 1414, Skip Channel = FALSE
    [   32.896927] =====================================================
    [   32.903124] Rule 1 CCA value : Min Dirtiness (Include extension channel) ==> Select Channel 12 
    

    Maybe this can help someone else in the future until this issue has been resolved.



  • Try this ?

    root@Omega-WWWW:/# uci set wireless.ra0.country='JP'
    root@Omega-XXXX:/# uci set wireless.ra0.channel='14'
    root@Omega-YYYY:/# uci commit
    root@Omega-ZZZZ:/# wifi
    cat /etc/config/wireless

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option txpower '100'
    option ht '20'
    option disabled '0'
    option country 'JP'
    option channel '14'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '12345678'
    option ApCliEnable '1'
    option ApCliSsid 'yourwifissid'
    option ApCliAuthMode 'WPA2PSK'
    option ApCliEncrypType 'AES'
    option ApCliPassWord 'yourpassword'
    option ssid 'Omega-4321'



  • @Larry-Pinney Yes, changing country-region from CLI works fine, but the problem is the web-UI, which doesn't support changing country-region. Neither the initial setup-wizard or the Onion Console-thingamabob support non-US WiFi-channels.



  • @WereCatf

    What? There is a web-UI? How does that work?



  • @Larry-Pinney Yes, the web-based setup wizard and, if you check the checkbox at the end of the setup wizard or install onion-console-base manually from CLI, then that.



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.