Omega2+ fails to connect to wifi



  • @Narciso-Jaramillo

    as I meitoned in another thread: I can tell for sure that AES/TKIP is NOT an issue, because I was able to connect my Omega2 to my mobile (in hotspot mode) with WPA2PSK and AES. "APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!"
    All default configuration, by the way, no config files changes, etc. - problem is somewhere else (may be more than one place).
    Omega2 does NOT connect to 2 of my WiFi Routers (Mikrotik and ASUS) with the same WPA2PSK/AES



  • @Michael-Smith Same here. I've tried all the suggestions. If anybody figures it out, please let me know.



  • Yep, I also have this issue, i've made a post and gotten no help after going through every thread on this forum trying to find a solution for this issue. This is frustrating and needs to be resolved. Admins need to step up. maybe skip 2-bullet tuesday this week and address this issue.



  • Same problem here. I was unable to connect to an Mikrotik 2011UAS or a Cisco EPR2320R2. I tried everything on this post, change wifi mode, channels, AES, TKIP, no-security, edit the /etc/config/wireless and other files in console, update the module to last version (0.1.10 b160), tried Omega2 and Omega2+, exp-board, change country settings, address collisions, etc.. It works fine with my phone hotspot, but nothing with the routers, even a single DHCP request. What's wrong with this modules?



  • Another "cool" thing ist that the MAC-address printed on my Omega2+ has nothing to do with its real MAC address :-)



  • Admins please fix this issue! Is it even being investigated at all? Please let us know. I'm going to throw this thing in the trash and buy a Rasberry Pi lol



  • This is really frustrating, I have a Ruckus Router, I tried all the configuration combinations I could think of, it didn't work even with an Open Network. I used two different Ruckus Reuters R710 and R600, same result. I tried ESP8266,raspberry pi, phones , laptops..the Router works very well on the 2.4 , Not sure what to do now, should I just give up and get back to it in year or two..hoping the WiFi issues got fixed with Omega10.



  • I have exactly same issue, when connecting to my Android hotspot without any security its ok, when I try to connect it to Cisco router with WPA2PSK/AES its not working. Also LED keeps flashing and my Omega is overheating like hell (wifi-manager is using 100% of CPU). No need to post content of my configs, its the same as guys above.

    I have some ESPs, notebooks, phone etc. Everything connect just fine, but not my Omega. Could you please at least communicate where is the problem, or what are you doing to fix it? This thread is more than 3 months old and there is still problem with one of the main functions of Omega (I bought it especially for on-board WiFi support). Last admin message is 3 months old, I mean come on, guys. You screwed communication on IndieGoGo (and I got letter from you how you are making extra efford to communicate with us, the community) and now this :)



  • @Jakub-Ludwig I solved it by changing router mode from 802.11n only to 802.11b/g/n mixed.
    Also you can play with wifi region especially if your channel on the router above 11.
    Maybe changing channel width between 20mhz and 40mhz can also help.



  • @M-S192 Thanks for tip, but unfortunately I have b/g/n already set, I have channel 3 and can't change channel width, because its router from my ISP with some customized firmware :(



  • @M-S192 This worked for me. Thanks! How did changing the router mode fix the issue?



  • @Nilay-Desai Well, I don't know about the mt76 driver from onion firmware but the one in official LEDE builds can disable 11n by setting htmode 'NONE' in wifi-device section. Maybe this is default behavior of onion driver.
    You can try to set htmode 'HT20' (or HT40 depending on your settings) and switch your router to 11n-only mode again.
    If this won't work I've no idea why it happens.



  • I try all solution but don"t work with my router mikrotik RB2011UiAS-2HnD-IN
    On other routers it works



  • @pvadam I had to change my country from US to CAN and that solved this whole thing
    I feel like this should be PINNED somewhere @administrators



  • I am just as disappointed, unhappy and annoyed as you guys.
    Fact is, I could not connect to any MikroTik router.
    (WPA1PSKWPA2PSK/AES, 802 b/g/n) - I am just not in the mood to play around with the settings yet.

    It did connect to my Cisco E2000 (WPA2PSK/AES)



  • This post is deleted!


Looks like your connection to Onion Community was lost, please wait while we try to reconnect.