nano and joe fail install libncursesw.so.6



  • My omega 2+ works fine... I can ssh in via wifi using my iPad and a SSH app, and install python3 ok and use it interactively.

    I cannot use nano or joe. They will install and "configure" with opkg but when I run them I get a long list of errors starting with a failure in libncursesw.so.6

    < BLOCKQUOTE >root@Omega-5EA1:~# nano
    Error loading shared library libncursesw.so.6: No such file or directory (needed by /usr/bin/nano)
    Error relocating /usr/bin/nano: raw: symbol not found
    Error relocating /usr/bin/nano: napms: symbol not found
    Error relocating /usr/bin/nano: key_defined: symbol not found
    Error relocating /usr/bin/nano: doupdate: symbol not found
    Error relocating /usr/bin/nano: nodelay: symbol not found
    Error relocating /usr/bin/nano: waddch: symbol not found
    Error relocating /usr/bin/nano: wscrl: symbol not found
    Error relocating /usr/bin/nano: curs_set: symbol not found
    Error relocating /usr/bin/nano: waddnstr: symbol not found
    Error relocating /usr/bin/nano: wattr_off: symbol not found
    Error relocating /usr/bin/nano: wmove: symbol not found
    Error relocating /usr/bin/nano: wrefresh: symbol not found
    Error relocating /usr/bin/nano: scrollok: symbol not found
    Error relocating /usr/bin/nano: beep: symbol not found
    Error relocating /usr/bin/nano: initscr: symbol not found
    Error relocating /usr/bin/nano: nonl: symbol not found
    Error relocating /usr/bin/nano: tigetstr: symbol not found
    Error relocating /usr/bin/nano: wnoutrefresh: symbol not found
    Error relocating /usr/bin/nano: isendwin: symbol not found
    Error relocating /usr/bin/nano: noecho: symbol not found
    Error relocating /usr/bin/nano: wgetch: symbol not found
    Error relocating /usr/bin/nano: delwin: symbol not found
    Error relocating /usr/bin/nano: wattr_on: symbol not found
    Error relocating /usr/bin/nano: newwin: symbol not found
    Error relocating /usr/bin/nano: set_escdelay: symbol not found
    Error relocating /usr/bin/nano: keypad: symbol not found
    Error relocating /usr/bin/nano: endwin: symbol not found
    Error relocating /usr/bin/nano: LINES: symbol not found
    Error relocating /usr/bin/nano: curscr: symbol not found
    Error relocating /usr/bin/nano: stdscr: symbol not found
    Error relocating /usr/bin/nano: COLS: symbol not found
    root@Omega-5EA1:~#
    </BLOCKQUOTE >



  • For now I did a dirty hack of making a symbolic link of libncursesw.so.6 to libncurses.so in /usr/lib

    /usr/lib/ln -s libncurses.so libncursesw.so.6

    It seems there are a bunch of libncurses references all linked to libncursesw.so.5

    Nano works now



  • Good! Thanks! I much prefer nano compared to vi ...


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.