[SOLVED] Omega can't connect to WiFi



  • Output:

    post2.PNG



  • Hi @Eoin-O'Dowd, is there a chance that your router and phone hotspot are outputting 5GHz frequency? The Omega doesn't support WiFI AC yet. Also, are you able to access Omega's own WiFI AP? Let's first try to rule out the possibility that WiFi interface on the Omega might be broken.



  • As far as i can see the wifi is broken, i can't see the AP on any of my devices it just simply has no means of connecting to the wifi, how do i get a refund/replacement?



  • i just bought a relay shield + ethernet shield can you please send me a replacement onion with that aswell,?



  • Hi @Eoin-O'Dowd, I figured out what the issue is. It seems that the ART partition on your Omega wasn't flashed properly. This partition contains the WiFi calibration data. However, to fix this you will need the Ethernet expansion. Would you like to wait for Ethernet expansion or would you like us to show you how to hack it with resistors and capacitors?



  • please tell me how, i only have 10K resistors with me though!



  • ah, it's ok i'll wait a few weeks for the ethernet shield thanks all the same.



  • @Eoin-O'Dowd Ok.



  • hi @Boken-Lin ! I finally had time to try out your suggestions.
    so here's the output of /etc/config/wireless.
    upload-aa342e80-b4ab-4324-bfa1-70c49f4202e3

    /etc/config/network delivers:
    upload-12f57f84-fdd7-4183-a5c5-5154f4028ad1
    upload-85a60d4b-fc00-4ffc-a66b-b32691828ab0

    I hope it helps! I'm trying another network right now, to avoid problems with the network authentication. I only need the wifi-password now and no additional network-passwords etc ;)



  • Hi @Nito-Weber in /etc/config/wireless, can you change

    config wifi-iface
    	option device 'radio0'
    	option network 'wlan'
    	option mode 'Router'
    	option encryption 'psk2'
    	option ssid 'SitecomA3A738'
    	option key '15066589'
    

    to the following:

    config wifi-iface
    	option device 'radio0'
    	option network 'wwan'
    	option mode 'sta'
    	option encryption 'psk2'
    	option ssid 'SitecomA3A738'
    	option key '15066589'
    

    Save the file, and issue wifi command.



  • That block is there twice:
    upload-cbbfe62a-94df-4955-883c-11d390c6a733

    i'll delete one of them.



  • Hi,

    Had the same problem, the Omega didn't recognize my home network too.

    Then I saw the Wi-Fi configuration with the option 'US' enabled. This option disables the channels 12 & 13, which are not allowed in the US (or only with power restrictions). They're allowed in Germany, where I live, and my router is using channel 13, so I changed the option to 'DE, and voila, the Omega immediately found my home Wi-Fi network and connected to it without any further problems.

    HTH!

    ~ HD ~



  • Thank you @Hans-Dieter-Stich ! I did the same as you did, but that was the output again... as always:

    upload-3c4ac8a2-6bc0-4b55-bf4e-ff3e9b3e9c38

    how can i enable radio0 ?



  • Hi @Nito-Weber, can you run the following commands:

    uci set wireless.radio0.disabled=0
    uci commit
    wifi
    


  • @Boken-Lin i did it and that was the output:
    upload-5170d23e-7bda-496e-8ad3-5b8694ac9c1a

    i tryed ping google.com and it worked and now i can finally run oupgrade !!!! thank you so much @Boken-Lin , we made it! :heart: :+1:



  • @Nito-Weber Awesome!



  • @Boken-Lin
    Hi
    I have tried eveything listed above and still no luck in connecting to my Wifi.
    If I setup a hotspot on my ohone I am able to connect and have done the firware upgrade but still am not able to connect to my wifi.
    I have an Arduino YUN that connected first time without any problems.

    My wifi is running WPA2 with aes. This is the first device that I have had problems connecting to my WiFi.

    Any help would be much appreciated.



  • Hi @Ian-Carr, Does your Omega able to serve an access point? Can you connect to the Omega via serial terminal, and copy and paste the output on the terminal when you try to connect with the wifisetup command?

    Thanks.



  • @Boken-Lin Here is the output from wifisetup.

    wifisetup
    Onion Omega Wifi Setup

    Select from the following:

    1. Scan for Wifi networks
    2. Type network info
      q) Exit

    Selection: 1
    Scanning for wifi networks...

    Select Wifi network:

    1. EnergyCybernetics2
    2. EnergyCybernetics2

    Selection: 1
    Network: EnergyCybernetics2
    Authentication type: psk2
    Enter password: **********

    Connecting to EnergyCybernetics2 network using intf 0...
    [ 227.080000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 228.560000] wlan0: authenticate with 4c:5e:0c:36:0a:bd
    [ 228.580000] wlan0: send auth to 4c:5e:0c:36:0a:bd (try 1/3)
    [ 228.580000] wlan0: authenticated
    [ 228.600000] wlan0: associate with 4c:5e:0c:36:0a:bd (try 1/3)
    [ 228.610000] wlan0: RX AssocResp from 4c:5e:0c:36:0a:bd (capab=0x431 status=0 aid=1)
    [ 228.620000] wlan0: associated
    [ 228.620000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 233.610000] wlan0: deauthenticated from 4c:5e:0c:36:0a:bd (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
    Checking wwan device status...
    wwan is not up!!
    Checking internet connection...
    [ 244.490000] wlan0: authenticate with 4c:5e:0c:36:0a:e1
    [ 244.510000] wlan0: direct probe to 4c:5e:0c:36:0a:e1 (try 1/3)
    [ 244.720000] wlan0: direct probe to 4c:5e:0c:36:0a:e1 (try 2/3)
    [ 244.930000] wlan0: direct probe to 4c:5e:0c:36:0a:e1 (try 3/3)
    [ 245.140000] wlan0: authentication with 4c:5e:0c:36:0a:e1 timed out
    [ 245.930000] wlan0: authenticate with 4c:5e:0c:36:0a:bd
    [ 245.950000] wlan0: send auth to 4c:5e:0c:36:0a:bd (try 1/3)
    [ 245.950000] wlan0: authenticated
    [ 245.980000] wlan0: associate with 4c:5e:0c:36:0a:bd (try 1/3)
    [ 245.990000] wlan0: RX AssocResp from 4c:5e:0c:36:0a:bd (capab=0x431 status=0 aid=1)
    [ 245.990000] wlan0: associated
    [ 250.990000] wlan0: deauthenticated from 4c:5e:0c:36:0a:bd (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
    ERROR: request timeout, internet connection not successful
    Disabling network on iface 0 ...
    Done!
    root@Omega-09C5:/# [ 271.910000] wlan0: authenticate with 4c:5e:0c:36:0a:bd
    [ 271.930000] wlan0: send auth to 4c:5e:0c:36:0a:bd (try 1/3)
    [ 271.930000] wlan0: authenticated
    [ 271.960000] wlan0: associate with 4c:5e:0c:36:0a:bd (try 1/3)
    [ 271.970000] wlan0: RX AssocResp from 4c:5e:0c:36:0a:bd (capab=0x431 status=0 aid=8)
    [ 271.970000] wlan0: associated
    [ 271.980000] wlan0: deauthenticating from 4c:5e:0c:36:0a:bd by local choice (Reason: 3=DEAUTH_LEAVING )

    root@Omega-09C5:/#



  • @Nito-Weber , might be a good idea to remove in your firs post the [resolved] from the title. So we can continue using it for the same problem with the experiences you made.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.