Sill no SD Card



  • Re: Omega2+: reboot and sd card fixed!

    Did the firmware upgrade with great hopes, but still no luck. No SD card visible on my Onion Omega2+.

    I'd like to mount it so I can reformat it as ext4 so I can eventually make the SD card the boot volume and put a LAMP stack on this thing.

    But, I'm unable to mount the card at all:

    root@Omega-5D21:~# ls /dev
    autofs mtd3ro ppp
    bus mtd4 ptmx
    console mtd4ro pts
    cpu_dma_latency mtd5 random
    full mtd5ro shm
    i2c-0 mtd6 snd
    kmsg mtd6ro spidev32766.1
    log mtdblock0 tty
    memory_bandwidth mtdblock1 ttyS0
    mmcblk0 mtdblock2 ttyS1
    mmcblk0p1 mtdblock3 ttyS2
    mtd0 mtdblock4 ttyS3
    mtd0ro mtdblock5 uinput
    mtd1 mtdblock6 urandom
    mtd1ro network_latency watchdog
    mtd2 network_throughput watchdog0
    mtd2ro null zero
    mtd3 port
    root@Omega-5D21:~# mount /dev/mmcblk0 /mnt/sda
    mount: mounting /dev/mmcblk0 on /mnt/sda failed: No such file or directory
    root@Omega-5D21:~# mount /dev/mmcblk0p1 /mnt/sda
    mount: mounting /dev/mmcblk0p1 on /mnt/sda failed: No such file or directory


    I read that the new firmware is supposed to auto-mount the SD card in /tmp/mounts, but no luck there, either:

    root@Omega-5D21:~# ls /tmp/
    RT2860.dat lib run
    TZ lock shm
    dhcp.leases log state
    dnsmasq.d overlay sysinfo
    etc resolv.conf tmp
    hosts resolv.conf.auto wifi_encryption_ra0.dat
    root@Omega-5D21:~# ls /tmp/mounts
    ls: /tmp/mounts: No such file or directory

    root@Omega-5D21:~# df
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 5632 5632 0 100% /rom
    tmpfs 62880 80 62800 0% /tmp
    /dev/mtdblock6 25728 760 24968 3% /overlay
    overlayfs:/overlay 25728 760 24968 3% /
    tmpfs 512 0 512 0% /dev


    At this point I'm glad I only paid $5 for this thing, as I'm realizing that you get what you pay for.



  • @WayneL Do you actually have /mnt/sda? I mean, mounting the card at /mnt/sda won't work, if there is no /mnt/sda... Also, you don't need to mount it in order to format it.



  • I had to create the /mnt/sdc dir before it would properly mount. Those are not created automatically.



  • @Brad-Buskey said in Sill no SD Card:

    I had to create the /mnt/sdc dir before it would properly mount. Those are not created automatically.

    Default behavior is to mount card and usb-storage (if you are running on dock) under /tmp/mounts.



  • @Zogg-Baubas I didnt want mine there because I intended on using the SDCard for all future storage and a swap file. I dont like using /tmp.



  • The SD card mounts at /dev/mmcblk0p1 for me. I usually mount it at /mnt/mmcblk0p1 and it works.



  • I just received my onion 2+ day before yesterday and after upgrading to firmware version 0.1.9 b150 manually my 64GB SD now mounts in /tmp/mounts

    Note: 0.1.9 b149 did not work for me.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.