Can't connect to hidden SSID



  • Hello,
    I am not able to connect with OMega2 to hidden SSID.
    I know that already there are some topics with solutions for the problem but none of them works for me.
    I have following setup on my router:
    0_1485596553934_wifi_settings.png

    But Omega2 is not able to connect to it - unless I uncheck "Hide SSID" checkbox, making the SSID visible............

    here is the settings inside /etc/config/wireless

    config interface 'loopback'
    
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'US'
            option disabled '0'
    
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key 'APPASS'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEncrypType 'AES'
            option ssid 'Omega-XXXX'
            option ApAuthMode 'WPA2PSK'
            option ApCliSsid 'MY_SSID'
            option ApCliPassWord 'MY_PASSWORD'
            option ApCliEnable '1'
    
    config wifi-config
            option ssid 'MY_SSID'
            option encryption 'WPA2PSK'
            option key 'MY_PASSWORD'
    
    

    Any ideas or ways to solve the issue?



  • Same problem. Even when I connect, then hide SSID, it disconnects



  • yes you can connect hidden SSID by changing option ht from '20' to '20/40'



  • correction, should be '20+40'



  • @Calvin-So This does not help :(



  • Reading almost everything posted on this so far and my own trial and error lead me to trying to use the bssid in addition to the ssid values.

    Which works... sort of.
    My wireless doesn't connect to the hidden ap on boot, but a simple edit of the /etc/config/wireless to change option ApCliEnable from '0' to '1' followed by:

    uci commit
    reload_config
    wifi
    

    results in it connecting fine. I still have to work out what is going wrong at boot, but thought I'd share this in the mean time while I work my way through the wifimanager and wifi scripts.

    So if anyone wants to try this, you will first need to get the bssid by using aps like so:

    # aps
    WRTnode AP scaner.
    Begin scaning APs, pls wait...
    Finished.
    APs available are...
    ra0       get_site_survey:
    Ch  SSID                             BSSID               Security               Signal(%)W-Mode  ExtCH  NT
    11                                   3c:47:11:8b:fi:fi   WPA1PSKWPA2PSK/TKIPAES 86       11b/g/n NONE   In
    
    # 
    

    Then add the bssid so that it appears in the config wifi-iface as option ApCliBssid and config wifi-config as option bssid alongside your other values. Mine look like this:

    # uci show wireless | grep -i bssid
    wireless.@wifi-iface[0].ApCliBssid='3c:47:11:8b:fi:fi'
    wireless.@wifi-config[0].bssid='3c:47:11:8b:fi:fi'
    

    Remember to change the ApCliEnable from '0' to '1' if it is currently '0', followed by:

    # uci commit
    # reload_config
    

    Followed finally by:

    # wifi
    setting apcli
    APCli use bssid connect.
    

    And check if your interface has now come up:

    # ifconfig apcli0
    apcli0    Link encap:Ethernet  HWaddr 42:A3:6B:00:Fi:Fi
              inet addr:192.168.1.3  Bcast:192.168.1.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:185941 errors:0 dropped:1 overruns:0 frame:0
              TX packets:134863 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:109980847 (104.8 MiB)  TX bytes:8482977 (8.0 MiB)
    

Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.