WiFi SSID with an apostrophe



  • Last weekend I went through a world of pain because of an apostrophe... The SSID I wanted to connect had an apostrophe in its name – hey don't shoot the messenger! Not my network! – and that caused wifimanager to barf on my shoes. Apparently the wifimanager bash script doesn't seem to like to have apostrophes, and isn't secured against that. The error happened around line 46 (I forgot, and since I have fixed the issue I sure don't want to try again), but I remember that it was xargs that threw the error, and there's only one instance.

    I fixed the issue by editing /etc/config/wireless and also removing settings for that SSID with the icu command.
    Could we maybe have a new version of wifimanager that takes care of apostrophes? I can't be the only one who stumbled onto this?

    Cheers


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.