omega wifi is not being detected



  • Got my unit, started it, saw the wifi immediately, logged in, connected to wireless network, updated firmware, changed root pass, installed nmap, powered down & took it home. When I powered it back up, I cannot see it from any of me four macs or 2 debian boxes. powers up both boards, but no wifi to connect to.

    Thoughts?



  • @charlie-galliher The Omega has just one WiFi interface, but through software, it is able to create two virtual interfaces to serve an AP as well as connecting to a home router. However, the Access Point virtual interface can only be turned on under these two conditions:

    • If the interface connecting to the home router is connected to the home router, or
    • If the interface that connects to the home router is disabled.

    This means that if the interface is configured to connect to the home router, but is unable to connect (either due to wrong password or DHCP timeout, etc), the AP interface won't be active either. In this case, you simply need to disable that interface for the AP interface to be active again. To do this you will need to connect to your Omega via serial terminal, and use the wifisetup command to reconnect to the wifi at your home.

    We are working on a feature that allows the Omega to detect multiple networks and connect to whichever one that's available (just like a computer).



  • ahh - I see. I'll bring it back to work and try it. Thanks.



  • can it be build that when no "normal wifi connection is detected, AP Mode start.

    Now I can at home connect with 2 networks normal and AP Mode, but if I get my onion to somewhere else -and I need connection- AP mode is also disabled



  • @Anco-van-der-Kolk Yup, that's something we are working on right now. We are also add the feature that allows the Omega to remember the wifi networks i has connected to, so that it will auto connect in when a network is available.



  • I know this post of kind of old but wanted to voice my interest in having it be able to revert to AP mode when it can't connect to another network. I've been playing with another IOT type device (also from Kickstarter), called the WiPy, which I received around the same time as my Omega and it switches automatically to AP mode when I take it out of the house. Tonight is the first time I took my Omega out and I just assumed it would go into AP mode like the WiPy did. The bummer part is I only have my iPad so I don't have any way to access the console.

    • 1 for the auto AP feature!

    Keep up the good work! The Omega has been the easiest and fastest for me to get programmed the way I wanted over all the others I've tried, and I've tried quite a few. My next hurdle is to figure out how to get the power usage under control. It's usage is so much higher than other boards when doing similar tasks but maybe I've missed some key programming items or sleep settings. I might just have to go with a bigger battery so I can keep the all the features.



  • Hi @Moriah-Trostler, the Omega actually has this feature. However it is run only once every 5 minutes. If you leave it in an environment that it cannot connect to the wifi it was configured to connect to. It will turn the wifi off and start the AP.



  • @Boken-Lin Sorry but this is not working for me


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.