PHP files not being interpreted.



  • I have followed the "tutorial" on install PHP and the bit right to where it says

    Note: If you receive a directory or file permissions issue, run the following command and try again. chmod -R 755 /www/php

    All that happens is the index.php file is downloaded rather than parsed. Any Ideas Thanks



  • Sounds like you don't have the .php interpreter setup in the http server config?
    Make sure that the following section of the instructions got completed:

    "Next we need to edit the uhttpd file, you can do this by using this command:"
    (The list interpreter and index_page addition to the config etc.).



  • Have you edit the /etc/config/uhttpd file?

    list interpreter ".php=/usr/bin/php-cgi"
    option index_page 'index.php'

    This is explained very well:
    https://wiki.onion.io/Tutorials/PHP-GPIO-Example


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.