wifimanager over 90% CPU usage - Omega2p



  • Seems the wifimanager process is the culprit for high CPU usage and Omega2 getting very hot (as reported by others).

    In my omega it was constantly using over 95% CPU (see attached) and the omega LED kept blinking.

    Disabled it from starting in /etc/init.d and now Omega runs cool. LED is also steady.

    0_1490873253182_wifimanager-high-cpu.PNG



  • By the way, disabling wifimanager was also a solution to Omega2 not rebooting (Device Firmware Version: 0.1.10 b160)



  • @Venet
    Omega2+ v0.1.10-b160, factory restore by long press
    wifisetup, the client successfully connected to the configured network

    Mem: 30264K used, 95484K free, 96K shrd, 3504K buff, 10008K cached
    CPU:   0% usr   0% sys   0% nic  98% idle   0% io   0% irq   0% sirq
    Load average: 0.00 0.00 0.00 1/48 3848
      PID  PPID USER     STAT   VSZ %VSZ %CPU COMMAND
     1091   793 root     S     1184   1%   0% udhcpc -p /var/run/udhcpc-eth0.pid -s
     3839  1922 root     R     1184   1%   0% top
     1918   885 root     S     1128   1%   0% /usr/sbin/dropbear -F -P /var/run/dro
      951     1 root     S     2284   2%   0% /usr/sbin/device-client
      989     1 root     S     1920   2%   0% /usr/sbin/onion-helper
      745     1 root     S     1884   1%   0% /sbin/rpcd
      793     1 root     S     1704   1%   0% /sbin/netifd
      974     1 nobody   S     1556   1%   0% avahi-daemon: running [Omega-5BE1.loc
        1     0 root     S     1532   1%   0% /sbin/procd
      928     1 root     S     1516   1%   0% /usr/sbin/uhttpd -f -h /www -r Omega-
      819     1 root     S     1404   1%   0% /usr/sbin/odhcpd
      736     1 root     S     1228   1%   0% /sbin/logd -S 64
     1836     1 root     S <   1188   1%   0% /usr/sbin/ntpd -n -N -S /usr/sbin/ntp
      458     1 root     S     1184   1%   0% /sbin/ubusd
     1922  1918 root     S     1184   1%   0% -ash
     2437   793 root     S     1184   1%   0% udhcpc -p /var/run/udhcpc-apcli0.pid
     1790     1 root     S     1108   1%   0% /sbin/mountd -f
      885     1 root     S     1060   1%   0% /usr/sbin/dropbear -F -P /var/run/dro
     2533     1 dnsmasq  S     1052   1%   0% /usr/sbin/dnsmasq -C /var/etc/dnsmasq
    ^C459     1 root     S      896   1%   0% /sbin/askfirst /usr/libexec/login.sh
    

    How could I reproduce what you wrote?



  • @György-Farkas said in wifimanager over 90% CPU usage - Omega2p:

    How could I reproduce what you wrote?

    @György-Farkas I'm not sure I understand the question. Are you asking how to disable wifimanager?

    If so this can be done through

    /etc/init.d/wifimanager stop
    /etc/init.d/wifimanager disable
    


  • @Venet
    I am watching my O2+ via serial terminal and / or via ssh (connecting to Omega's Wifi AP).
    I can not run wifimanager and top at the same to see that nice

    %CPU
    99 % {wifimanager}

    How did you do that?



  • @György-Farkas said in wifimanager over 90% CPU usage - Omega2p:

    @Venet
    I am watching my O2+ via serial terminal and / or via ssh (connecting to Omega's Wifi AP).
    I can not run wifimanager and top at the same to see that nice ...

    OK. A shell script might help me a lot ;)



  • @György-Farkas said in wifimanager over 90% CPU usage - Omega2p:

    @Venet
    I am watching my O2+ via serial terminal and / or via ssh (connecting to Omega's Wifi AP).
    I can not run wifimanager and top at the same to see that nice

    %CPU
    99 % {wifimanager}

    How did you do that?

    I see. On my Omega2 wifimanager was set to run on boot, so I didn't start it manually.

    I think the problem with wifimanager is that if it is run manually it never completes (as others also found in another thread).


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.