[Issue/Workaround] WiFi can't connect when AP passphrase has a comma



  • I've been struggling to get my Omega2+ to connect to my wifi for the last day. I tried all the suggestions in the other posts to no avail. I saw others had issues when the SSID had non-alphanumeric characters, and realized my passphrase has a comma in it. So I changed it to have only alphanumeric chars, and it connected immediately!

    The wifi command blows up with a non-obvious error when trying to connect when it has the comma:

    root@Omega-XXXX:~# wifi
    setting apcli
    Interface doesn't accept private ioctl...
    set (8BE2): Invalid argument
    

    I upgraded to the latest firmware (0.1.9 b159) but it still had the same problem. Only by simplifying the passphrase was I able to connect.

    Hope that helps someone else!



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.