Mega Omega Software Release!


  • administrators

    @Craig-Soich we're working on it but right now we're planning on releasing a slightly newer NodeJS version before IoTJS



  • This post is deleted!


  • @Craig-Soich And node wrappers for all of our libraries are also coming :)



  • @Lazar-Demin Retired and willing to help where I can so long as no interference with my toy-time.



  • @Boken-Lin What button are you all referring to don't have a button to press for reset or is this button the replacement for the on/off switch, on mine is broken so how do I reset?



  • Can you please let us know when the update will not affect the USB overlay for more root install space?
    Would really like to update my Omega but also don't want to repeat the steps for overlay and other steps which might affect when updating. Have you had any news as to the updating of the update?



  • @Boken-Lin Any word on the compilation of packages from the default OpenWRT repository against the versions the Omega uses? I'd really love to get kmod-usb-audio for a project I have going on and would rather not build it myself if I can avoid it :)



  • @fader We are still trying to figure out a way to manage all the packages and package versions. But in the mean time, here's the package for kmod-usb-audio: https://s3-us-west-2.amazonaws.com/onion-downloads/openwrt/kmod-usb-audio_3.18.23-1_ar71xx.ipk

    Cheers!



  • @Boken-Lin Thanks! I appreciate you bumping that package up in the queue!

    Unfortunately, it doesn't match what I have: it seems to require kernel 3.18.23-1-f390db95f2c49c8b1f6de2c8a8325b11 and I have 3.18.23-1-06fd4f256a5d6a59030da9979debc3f7.

    root@Omega-25AF:~# opkg install ./kmod-usb-audio_3.18.23-1_ar71xx.ipk 
    Installing kmod-usb-audio (3.18.23-1) to root...
    Collected errors:
     * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-audio:
     *      kernel (= 3.18.23-1-f390db95f2c49c8b1f6de2c8a8325b11) *         kmod-sound-core * 
     * opkg_install_cmd: Cannot install package kmod-usb-audio.
    root@Omega-25AF:~# opkg list-installed | grep kernel
    kernel - 3.18.23-1-06fd4f256a5d6a59030da9979debc3f7
    root@Omega-25AF:~# oupgrade 
    > Device Firmware Version: 0.0.5 b251
    > Checking latest version online...
    > Repo Firmware Version: 0.0.5 b251
    > Comparing version numbers
    > Device firmware is up to date!
    root@Omega-25AF:~# opkg install kernel
    Package kernel (3.18.23-1-06fd4f256a5d6a59030da9979debc3f7) installed in root is up to date.
    

    Both opkg and oupgrade say I'm running the latest firmware and kernel package, so maybe it's something building now? I can be patient, so no worries :) Just glad to know it's still being planned.



  • Hi @fader, ah, that's because it is built with our test build environment. I forgot to do a pull before doing the compilation. I will try to do another compile for you tomorrow. But yeah, that's the kind of versioning problem I was talking about in the last post. We still haven't thought of a good way to manage all this. Any idea would be greatly appreciated!



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.