I2C communication (write/WriteBytes returns None, Readbytes returns 0xff) using pyOnionI2C #I2C #OMEGA2



  • Using Python (pyOnionI2C): I am unable to communicate with I2c bus each and every time it returns:

    • on write it returns status as None

    • On Read it returns 0xff whether i am using any devAddr, addr

    I have omega2, python-light, RTC chip plugged into i2c, pyOnionI2C.
    0_1500369341203_i2cdetect_omega2.JPG
    using Shell script i am getting the same issue as below:
    0_1500369468190_2.i2cdetect_omega2.JPG

    below issue found(same) when i run python code available on github for i2c as an example.
    0_1500369686405_3.i2cdetect_omega2.JPG
    #I2C #OMEGA2



  • @Arshad-Alam said in I2C communication (write/WriteBytes returns None, Readbytes returns 0xff) using pyOnionI2C #I2C #OMEGA2:

    RTC chip

    Working on i2c interface as well; I get an identical return from i2cdetect for a completely different chip (digital potentiometer). Typically it should just return one address!

    I disconnected the i2c wires from the breadboard and still get identical (junk) output, so I'm wondering if it might be an error state? Hardware or software though?



  • As a follow-up, I got I2C working through specifically addressing the chip as specified in the docs, but i2cdetect never, even now, returned accurate information. i2cdetect response such as this (30-37, 50-5f) useless for troubleshooting; does not indicate anything about state of i2c bus.

    Thanks to the OP for downvoting my last comment, I hope you downvote this one as well.



Looks like your connection to Onion Community was lost, please wait while we try to reconnect.