Omega2+ bricked (with LEDE fw) [Resolved]



  • Hello.

    I've uploaded firmware to my Omega2+ and now it's 'bricked': OS works but WiFi and USB doesn't.
    sysupgrade omega2p-squashfs-sysupgrade.bin
    (without -n option)
    (fw from here: http://downloads.lede-project.org/releases/17.01.2/targets/ramips/mt7688/)

    I've tried to upload firmware from USB flash but got this error:
    CMD_FAT: ** Unable to use usb 0:1 for fatload **
    Upgrade F/W from USB storage failed.

    How to reverse it to original fw?



  • @V_Baczynski Use the latest version from here: http://repo.onion.io/omega2/images.

    sysupgrade -n http://repo.onion.io/omega2/images/omega2p-v0.1.10-b160.bin
    


  • Also if USB flash drive is not working, try to create a partition of 1GB on the USB drive and format it as VFAT. And then try again.



  • @Jackdaw USB & Internet doesn't work. I assume that WiFi should be configured manually, but I can't find how to do this properly.



  • @V_Baczynski First, please don't misuse the term "bricked". Your system is not bricked - it runs interactive U-Boot, and it boots Linux to a degree.

    A "bricked" system is one which as inert... as a brick.

    Most likely you should attempt USB recovery from U-Boot. As that does not depend on Linux at all, it should work - if you have a working USB drive properly connected and place the proper files on it.

    If you have a wired network adapter (magjack, etc) you could also use TFTP to load new firmware from U-Boot, again without relying on the Linux image presently loaded.

    It is worth noting though, that the lack of access to either the JTAG pins or all of the SPI flash pins, make the Omega2 a fairly poor choice for kernel level or especially U-Boot MT7688 development, as once you break U-Boot, there's perhaps no recovery possible without removing the shield can, and that does not come off easily.



  • @Chris-Stratton Okay, it's not 'bricked' it's useless (without working Internet and working USB).

    I need to configure WiFi. By default it is disabled:

    root@LEDE:/# cat /etc/config/wireless
    
    config wifi-device 'radio0'
            option type 'mac80211'
            option channel '11'
            option hwmode '11g'
            option path 'platform/10300000.wmac'
            option htmode 'HT20'
            option disabled '1'
    
    config wifi-iface 'default_radio0'
            option device 'radio0'
            option network 'lan'
            option mode 'ap'
            option ssid 'LEDE'
            option encryption 'none'
    
    root@LEDE:/# cat /etc/config/network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'IPv6_HERE'
    
    config interface 'lan'
            option type 'bridge'
            option ifname 'eth0'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config device 'lan_dev'
            option name 'eth0'
            option macaddr 'MAC_HERE'
    
    config switch
            option name 'switch0'
            option reset '1'
            option enable_vlan '0'
    

    As I mentioned before, USB recovery from U-Boot doesn't work and I don't know why.



  • I've found my old school 128Mb USB flash drive and finally recover the system with omega2p-v0.1.10-b160.bin firmware.


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.