Issue with urllib3[secure]



  • I'm trying to run a sample program from assistant-sdk-python, and I keep getting this error

    Traceback (most recent call last):
      File "/usr/bin/googlesamples-assistant-hotword", line 11, in <module>
        load_entry_point('google-assistant-sdk==0.3.3', 'console_scripts', 
    'googlesamples-assistant-hotword')()
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 
    570, in load_entry_point
        return get_distribution(dist).load_entry_point(group, name)
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 
    2687, in load_entry_point
        return ep.load()
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 
    2340, in load
        self.require(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 
    2363, in require
        items = working_set.resolve(reqs, env, installer, extras=self.extras)
      File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 
    867, in resolve
        raise DistributionNotFound(req, requirers)
    pkg_resources.DistributionNotFound: The 'cryptography>=1.3.4; python_version 
    <= "2.7" and extra == "secure"' distribution was not found and is required 
    by urllib3
    

    I have urllib3[secure] installed, with cryptography 2.0.3, so I shouldn't be having any issues. I've tried looking for others with this error, and I can't seem to find a solution. How can I fix this?


Log in to reply
 

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.