Compile against libasound

  • Hi all,

    noobish question perhaps, but how do I cross compile using libasound?

    I have an app which now complains on a missing <sysroot>/include/alsa/asoundlib.h.

    I'm compiling it with LEDE cross compiler according to this tutorial. In vain, I've done the menuconfig and enabled just about everything soundrelated under Kernel Modules/Sound Support and rebuilt the toolchain. I just can't seem to get libasound-dev into my sysroot :(

    Or is there another way to install libs to LEDE sysroot?

    Thanks a millions / Peter

  • I don't know anything about the LEDE build system, but I did build an emulator which was using libalsa. I managed to cross-compile it and link my programs against it. You can download the lib and headers from This worked for me where I was cross-compiling for my Omega2. Of couse, you'll have to install libalsa on your Omega2 for this to work, too. (opkg update && opkg install alsa-utils alsa-lib)

  • Sweet, thanks! This is allows me to continue.

    If I find a way to add libasound to LEDE, I'll post something here. I believe this might be the right path, though seems a bit cumbersome.

  • Ok, for others in the same situation, here's a proper way of doing it.

    In your LEDE toolchain, call
    ./scripts/feeds update -a
    ./scripts/feeds install alsa-lib
    ./scripts/feeds install alsa-utils

    run make again and your sysroot will be populated with alsa goodies.

    As @Maximilian-Gerhardt mentioned, you need to actually install alsa on the Omega2 as well.

  • Edit: for reference, see here,

Looks like your connection to Onion Community was lost, please wait while we try to reconnect.